Jump to content

No boat in Formello Avernum 2 CS, is it a bug ?


Yip
 Share

Recommended Posts

Happy new year everybody 🎉🥰🍾

 

I play Avernum 2 CS through Steam on a Mac. No mods, no cheats, the game works fine.

 

My characters are level 12 or 13. I have seen the event with the Vahnatai in Formello. But there is NO boat on the dock under the city.

 

I tried everything but even if i dance on my head there is NO BOAT ! What is wrong with me ? Is it possible to do something wrong during the event ? Or is it a bug ??

 

I tried to play it again with another party but still NO BOAT !!! I'm so frustrated !! 👹

 

If somebody can help me, i'll worship him/her for the rest of my life... 😃

Link to comment
Share on other sites

Happy New Year!
 

Sorry to hear about the problem you’re experiencing. Are you the same person who posted a similar query on the Steam boards recently?
 

I have a couple of ideas for how to get that boat back for you. However, in order to know which suggestion would be best to try first, it would be helpful to know a little more about the problem. Would you mind running a few quick checks for me? No worries if you’d rather not – if you’d prefer, I can just give you some suggestions right away!

However, if you are able to check some things, here’s what would be useful to know:
 

1. Is there anything strange going on with your junk bag? If you look through it, is it full of lots of strange daggers?
 

2. Try leaving the docks, entering three other different towns (say Formello, Fort Draco and Fort Ganrick), and then returning to the docks. Is the boat still missing?
 

3. Do any strange messages come up in your log when you enter the docks?
 

4. If possible, could you take a screenshot of the docks area and link to it here? This is just to check how the town is loading. I’m interested in the area of the town around the boat. Here’s a screenshot of the rough area it would be useful to see (borrowed from an online gameplay video):
 

Crystal-Souls-Docks.png
 

Sorry for asking lots of questions! The idea is to try and learn about the problem, both so that’s it’s easier to fix for you, but also for anyone else who comes across it!
 

As I say, if that’s too much, do just say so. With luck, I should be able to help you progress even so!

Link to comment
Share on other sites

Thank you very much Ess-Eschas for your answer ! Yes i posted on Steam recently.

 

Don't be sorry for the questions, you help me, it's really a pleasure.

 

1. Nothing strange with the junk bag, i fill it and empty it without a bug.

 

2. I tried many times to enter the three towns without any change. In fact i followed a path for three or four days, clockwise, Formello, Blasted ruins, Fort Ganrick and Fort Draco, etc. I can't remember how many times, trying to increase my levels, reputations and abilities to solve my problem.

 

3. Absolutely no strange message entering the dock. I tried to click on the boat's place with the same answer : Move : That space is currently blocked.

 

For the screenshot how can i do here, only with an url ? I have no server or image service to do that.

 

 

Link to comment
Share on other sites

Thanks for the answers! They were very useful, and they’ve helped to rule out a few possible issues.
 

The cause of your problem is still a little mysterious, but hopefully that will become apparent as we try to clear it up. At the moment, my best guess is that it’s a curious holdover from the code for the demo version; this boat is the point at which the (non-Steam) demo stops, so it’s possible something in your saved game is accidentally triggering that old section of the code.
 

So let’s try fixing your problem! Here’s the first thing to try. I'm not sure it will work, but it’s worth a shot!
 

First, create a copy of your saved game. This is to make sure you can restore your progress should anything go wrong. You can do this by just saving in a new slot! I suggest working from this copy for now, since that way you can just overwrite it if it’s no longer needed.
 

Leave the ruined docks, and return to Formello itself. Stay in the town, though, since this method won’t work if you’re outdoors. Press ‘shift’ and hold the ‘d’ key. A little text-input box should appear. In this box, type the following exactly as shown:
 

resetboats
 

A little message should appear in your log. Return to the docks. Has the boat appeared? If not, some more drastic action might be needed!

Edited by Ess-Eschas
Fixing some awkward grammar.
Link to comment
Share on other sites

Hem !

 

I tried this yesterday or before, searching on the web i found some cheats and i made an attempt but it didn't work. By the way, my boat bought previously disappeared and i spent 300 coins for nothing after that. Still have no boat in Ganrick but this is not important for the moment.

 

Many thanks for the answer. 🙏

Link to comment
Share on other sites

Good on you for trying that trick already! I had a feeling it wouldn’t help, but it was worth checking out!
 

I’m afraid this means that the problem might be a little tricky to solve. I’ll put my thinking cap on, though, and see if I can come up with something! The difficult part about this is that the code relating to that particular boat – and most of the code relating to boats in general – is hidden away deep within the game’s innards. However, it might be possible to come up with a workaround. I’ll see what I can do!
 

In the meantime, would you be willing to share your saved game? It would make coming up with a fix that little bit easier! Since you’re running on a Mac, I should be able to look at it directly myself. I might even be able to shove your party past the block manually, and then send you back a saved game where you can continue normally.
 

If you don’t know where your saved games are stored, below is the appropriate section from Spiderweb’s support pages. I hope this applies for Steam games too – although any forums users who know differently, do say!
 

“If you did not buy Avernum 2 from the Mac App Store, your games are stored in the Application Support folder, which can be difficult to find. To open it, press Command-Shift-G to Go To Folder, enter "~/Library/Application Support/Spiderweb Software", and press return. Your saved games are in the folder "Avernum 2 Saved Games." Open that folder and your saved games will be inside, in folders named 'Save0', 'Save1', etc.”
 

All I would need is the folder relating to your current party. If you're not familiar with a good temporary upload site, I suggest WeTransfer!
 

By the way, don’t worry about the language. You’re making yourself understood very well. Je vous comprends bien!

Link to comment
Share on other sites

15 hours ago, Yip said:

 

I tried to play it again with another party but still NO BOAT !!!

 

Did you just start with a new party or did you uninstall & then reinstall the game and 'then' start a new party? (which now that I read things a little closer, it's a registered copy if you got it on Steam)  Because if you just started a new party on the same install, it isn't too surprising that the bug may have recreated itself. 

 

If E-E's suggestions don't work, I'd try uninstalling the current program, downloading a new/clean copy from Steam, reinstall, & try it again (thankfully you are relatively near the start of the game so you won't lose too much time if you can't restore a saved game or doing so corrupts things again).

Link to comment
Share on other sites

9 hours ago, Ess-Eschas said:

All I would need is the folder relating to your current party. If you're not familiar with a good temporary upload site, I suggest WeTransfer!
 

By the way, don’t worry about the language. You’re making yourself understood very well. Je vous comprends bien!

 

😀

 

I found the folder, where can i send it ? Here on this topic ?

Link to comment
Share on other sites

One simple way to share the saved game would be to use an online uploading service, and post the link in this thread. Here’s a link to a service which seems to work fairly well:
 

https://wetransfer.com/
 

Unless you really want to, just ignore the opening registration prompts. Click ‘I just want to send files’. You’ll then be taken to a screen which allows you to make an upload. To make sure you’re dealing with the right kind of transfer, click on the little circle with three dots in it, and make sure that you’re on the ‘Get transfer link’ setting.
 

Once you’ve uploaded the folder, WeTransfer should give you a link. Then just post the link in this topic!
 

Of course, feel free to use another system if you’d prefer!

Link to comment
Share on other sites

53 minutes ago, Yip said:

Thank you Ess-Eschas, i'm familiar with computers but not with these sharing services online.

 

https://we.tl/t-3soyvkk733

Hello,

I downloaded your game to my Mac, then went back into Formello and called resetboats, the boats seem to have reappeared ; so I got on a boat and saved in Save2:

https://www.grosfichiers.com/uzkVrFnafgv

Link to comment
Share on other sites

Nice work, osnola! That’s something I was going to try myself, but you saved me a little time by preempting me!

 

Take a look at osnola’s save file, Yip, and see if that fixes your problem. If it does, then great! Although I would suggest that you keep an eye out for strange behaviour from boats in the future, just to be safe.

 

If this doesn’t solve your problem, though, let us know what happens. If you’re triggering the demo code somehow, it’s possible you’ll experience some further issues (which should be quite obvious). However, we already know more about your problem: that your version of the game behaves differently from osnola’s. That might give some indication of what to try next, should things still be acting strangely for you!

Link to comment
Share on other sites

Thanks a lot !

 

The workaround is just fine ! Of course if i experience some further issues i'll let you know.

 

Thank you Ess-Eschas, TriRodent and osnola !

 

Osnola il me semble que tu es en France, à l'INRIA ? Si tu es à Sophia Antipolis je ne suis pas très loin puisque j'habite Fréjus. Merci encore. 🙏👍

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...