• Announcements

    • Anapsi

      Logging in   05/10/2017

      If you had an account and can't log in as of 5/9/17, this may be because of a change in logins with new forum software. You can log in using your publicly displayed name (not your username) or your email address and the password you used before.   If you have problems with this, please ask any of the mods or admins. 
Sign in to follow this  
Followers 0
Sudanna

Nalyd Teaches You How to Run Geneforge 1-4 in a Window in Ten Easy Steps

14 posts in this topic

So, yeah, I managed to figure that out. Requires a program that's only for Windows, and these instructions are for a Windows 7 Steam user, though they won't be too different for other versions of Windows or for people not using Steam. We get this question somewhat regularly, so maybe a mod could pin these? Anyways, here's how.

 

FIRST, you will download the file at http://www.mediafire...DXWnd 1.21A.rar, which is version 1.21a of the English edition of DXWnd. There are newer versions of this utility and other places to get this version from, but this is the one that worked for me.

 

SECOND, you will unzip that file to the location of your choosing. Might want to keep it handy, though, the program in it needs to be running for this to work

 

THIRD, you will open the file, right-click on dxwnd, and run it as an administrator.

 

FOURTH, you will click on the Edit menu in the toolbar at the top and select Add.

 

FIFTH, you will click on the three dots to the right of the blank bar at the top.

 

SIXTH, you will navigate to the folder that contains the .exe for your desired version of Geneforge, click on that .exe, and click Open. For Steam users, and using G1 as an example, this will be at C:\...\Steam\steamapps\common\geneforge\Geneforge.exe. Where your Steam folder is is up to you to find out, but it's probably in C:\Program Files\.

 

SEVENTH, you will check the "DirectInput is hooked" and "Auto-correct mouse position" checkboxes.

 

EIGHTH, you will notice that the boxes under the "Initial co-ordinates and movable range" line read 0, 0, 0, 0, 800, and 600. For Geneforge 1-3, this is correct. For Geneforge 4, you will have to change the last two to read 1024 and 768.

 

NINTH, you will click "OK", but not close DXWnd. You will then open Steam, go to your library, select your desired Geneforge game from the list in the sidebar, and click the "PLAY" button.

 

TENTH, there will be some brief weirdness on startup. This should resolve itself quickly, and your desired version of Geneforge will now be playing in a window. You may experience some difficulty with the mouse not moving to all parts of the window. To resolve this, simply move your mouse cursor the four corners of your screen.

 

And that's it. You have now defied the designs of man and god to play G1-4 in a window. Remember to have DXWnd open and to start the game from Steam (as per NINTH) whenever you want to play. Non-Steam users will have a different location for the .exe and won't have to start from Steam, but all other instructions remain the same.

nikki., Wrath, Tridon and 2 others like this

Share this post


Link to post
Share on other sites

This should come in useful. Playing fullscreen was always a pain; you've got to alt-tab to multitask your processes.

The Hero likes this

Share this post


Link to post
Share on other sites

I attempted to pin this, but apparently I do not have permission. If a global moderator thinks that it is worthwhile having this pinned, or otherwise highlighted, they will have to do it for you.

 

Sorry, and nice work.

Tridon likes this

Share this post


Link to post
Share on other sites

Much obliged, Triumph. Does this mean I'm in the cool kids club now? :p

Share this post


Link to post
Share on other sites

Very good program, I just tested it on geneforge 1-3 on spidweb oficial webpage version, and can be used the exes if you double click in the routes on program, also takes some more cpu when you start a game, like 5 seconds later becomes all normal, this will give some more time to this games to be played on news computers and at least me now can wait for the remake of g2 some more time :)

Share this post


Link to post
Share on other sites

Followed the instructions exactly, but the game just freezes up without displaying anything. I tried the newest version of the program to see if that helped, but I'm just getting a splash screen before the exact same issue. I'm on Windows 7 64-bit, so maybe that's the issue?

Share this post


Link to post
Share on other sites

These were done in 32 bit mode long before 64 was available.

Share this post


Link to post
Share on other sites

This should come in useful. Playing fullscreen was always a pain; you've got to alt-tab to multitask your processes.

Wow. You are such a computer genius. Now I didn't have to ctrl+alt+del just to get to the desktop... Come on out Trenton, I know alt+tab will be useful to you...

-----------

-Test Subject 8552

Share this post


Link to post
Share on other sites

Followed the instructions exactly, but the game just freezes up without displaying anything. I tried the newest version of the program to see if that helped, but I'm just getting a splash screen before the exact same issue. I'm on Windows 7 64-bit, so maybe that's the issue?

 

I did this in Windows 7 64-bit as well. Are you using the same version of DXWnd, and do you have all the correct settings? All I can say is to doublecheck that, and maybe run DXWnd as an administrator. If that still doesn't work, I guess you could try some of the other versions of DXWnd (it's a free utility, around on the net somewhere), but I couldn't get those to work myself. Sorry I can't be of more help.

Share this post


Link to post
Share on other sites

I have experienced that fairly old games have frozen before, though not Geneforge in windowed mode. I had luck updating my graphics card driver. Still I find it weird that games that barely has any graphics to speak of can freeze due to an oudated driver, but there you have it. Has worked for me in a few rare occations.

 

By the way; I thought this thread was pinned. Was I temporarily blind, or was it not pinned earlier?

Edited by Tridon

Share this post


Link to post
Share on other sites

Not pinned, but linked in the header.

Tridon likes this

Share this post


Link to post
Share on other sites

The link in the first post seems to be dead. Can anyone provide a working one? I really want to play in a window. Thanks for this!

Share this post


Link to post
Share on other sites

I've edited the first post, the new link should work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0