Jump to content

Geneforge Mutagen - No Allowed Resolutions Found Error


Recommended Posts

Just got a new 16" MacBook pro with the M1 chip. Wanted to continue playing Mutagen. But, I get a "No allowed resolutions found" error when Mutagen starts, in the dropdown box where you select screen resolutions. I'm running from Steam.


I tried:

1. rebooting

2. uninstall/reinstall game

3. changing laptop resolutions


Any ideas? I really want to get back to playing my game. 

Link to comment
Share on other sites

  • 2 months later...

Posting an email I sent to Jeff here, as this is a reproducible error on the M1 16 inch Mac with the notches. Hopefully we can get a fix!



I am a developer myself and have done a bit of leg work to diagnose the issue, as well as a potential solution. When trying to run Geneforge Mutagen on an M1 16 inch macbook pro, you get the error someone posted here. I receive the same error.
I believe the reason is that the notch at the top of the screen adds additional pixels (74 exactly), and it is not passing the whitelist check for allowed resolutions / aspect ratios.  
Display information :
16.2-inch Liquid Retina XDR display (3456x2234 pixels, 254ppi)
Screen Aspect ratio : 1.54010695187
Apple has a fix for this, where you can turn off the pixels for the notch within the display,
This will scale the app to render WITHOUT the 74 pixels for the notch on the screen, making the display 

Screen Aspect ratio : 1.6, ie standard 16:10

Is there any potential this can be addressed? Even if it requires me editing some files on my computer, I just really want to get the game running...



Link to comment
Share on other sites

Just to follow up in case it was not clear.


I tried running the app with turning the notch off (https://www.macworld.com/article/546104/how-to-macbook-pro-macos-monterey-block-notch-menu-bar.html), however you receive the same error! 


I think Geneforge is checking the original screen resolution, not the resolution that results from turning off the notch!

Link to comment
Share on other sites

  • 1 year later...
On 3/10/2022 at 5:00 AM, Spidweb said:

We've released a new version that should fix the problem. It's v1.0.2b. Download it where you downloaded the original.



I just bought Avadon 3 on Steam, and I think I have the same issue. I get the same symptom/error at least.

I'm on a 14-inch, 2021 MacBook pro.


I did a quick test and I don't have the issue with Queen's Wish 1-2, Avadon 2, Avernum 1-3 (the remakes), only Avadon 3 (of course, the one I wanted to play 😅).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...