Jump to content

Queen's Wish Freezing and Flickering?


Recommended Posts

I have downloaded Queen's Wish Demo twice now - v 1.0.1 - on a 2012 iMac running OS 10.11.6. My computer appears to well exceed all the minimum requirements listed for the game.


I have not made it past the hall outside the initial bedroom scene without the game starting to flicker and freeze. The mouse freezes in the game window and closing the game requires a force quit every time.

The flicker and freeze has happened as early as the character setup screen (once) and as late as after checking the locked doors in the hallway and trying to proceed north (once). Typically, the doors out of the bedroom are the problem point, so I've only stepped into the hallway three times in eleven tries.


Playing in a window vs not doesn't seem to have an effect; I haven't been able to determine that the graphics settings have any effect.


When it froze on the character setup screen, the background music kept playing even though the mouse was completely frozen in the game window. I can access the menu bar when the game is frozen, but no game-related menu commands seem to have any effect (i.e. "quit").


Does the game actually run on MacOS 10.11? I'm reluctant to buy the full game if it's not going to work.

Link to comment
Share on other sites

Hmm.  If it's the 2012 iMac that comes with a GeForce card, that should meet the listed requirements.  However, that is still a 7 year old computer, so there's certainly room for something to not line up.


2 things worth trying, to isolate what's going on:

- If you're running through Steam, try launching the application manually instead.

- Disable as many background processes as you can (whether other apps, or just extensions like antivirus software) -- it's possible there's a conflict with something you have installed.

Link to comment
Share on other sites

Thanks for the suggestions!

The display is just the iMac built in 27" LCD display (no additional monitors connected):
Resolution:    2048 x 1152 (note I've picked this and also picked lower resolutions when choosing the window size)

Pixel Depth:    32-Bit Color (ARGB8888)

Graphics chip: NVIDIA GeForce GTX 675MX 1024 MB


I'm not using Steam - both times, I've downloaded from the Spiderweb Software website.

With no other applications running and after freshly restarting, I made it a smidge further (talked to the prince, tried to open the chest *flicker, flicker*).

Restart again, having saved this time before opening the door north out of the hallway and loading saved game - froze on opening the door to the throne room and having the text pop up.

It seems like opening things is my downfall.


I have Avadon 1 and 2 on this computer and Avernum 1's demo; they don't show the same issues after some testing.

Link to comment
Share on other sites

Thanks for the extra info.  This does appear to be a stumper.  Could be a graphics software issue, could also be something unrelated -- like a conflict with installed software that operates as a background process (rather than being an application that you can open and close).

Link to comment
Share on other sites

13 hours ago, Pounce said:

With no other applications running and after freshly restarting, I made it a smidge further (talked to the prince, tried to open the chest *flicker, flicker*).

Like @The Rural Abjurermentions, it seems to be a gpu issue. It's a long time I haven't used a Mac so forbid my question. :) Do you have two graphics cards, one integrated and a discrete GPU like we have on most Windows machines? If yes, can you choose which to use to run the game? On my Windows PC, Queen's Wish runs on the integrated graphics which is largely enough.

Link to comment
Share on other sites

3 minutes ago, The Rural Abjurer said:

Those particular iMacs shipped with the GeForce card -- I don't think they had the old Intel integrated graphics card that so many of us have such ugly memories of.  I don't think it's a given that this is a GPU issue.

Ah. I don't dislike the idea though, maybe things are better now (my computer is two years old)? :)


@PounceAre you using beta drivers for your GPU? If yes, just deinstall them and install the latest stable version. :)

Edited by ladyonthemoon
Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Same problem (on imac, flicker, freeze, force quit, etc...). Very annoying.

It improved a little bit when I set the game with "Draw fewer graphics" but the problem eventually came back.

Are you playing on Steam ?

If so, the solution is here:


It just says to turn off Steam Overlay in the game setting (can be tricky to find).

Problem solved. Except, it just happened once again since then so it's much, much better.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...