Jump to content

Geneforge on Windows 10: Out of ideas


Recommended Posts

Recently I've been trying to introduce a friend of mine to the Geneforge series. He has a Mac that used to be able to run it, but now it's almost broken and takes minutes to do *anything*, so his only main option is to use his Windows 10 desktop. As some of you know, the first 3 (sometimes 4) Geneforge games have major lag problems running on modern Windows computers. People have described plenty of ways to fix this, but none of them are working for us.


We have tried:

-Running the game normally (worked about as well as you'd expect)

-Setting compatibility mode to Windows XP Service Pack 3 (doesn't work and fails to load save data)

-Setting compatibility mode to Windows Vista (improves performance at first, but drops back down to full lag after just a few minutes)

-Downloading the Compatibility Administrator tool and enabling ForceDirectDrawEmulation (works about the same as Windows Vista does, with the added bonus of black flickering)


I don't know what to do. Nothing we've found on the internet appears to work. His computer is very high end (like, 16 or so GB of ram) so it's definitely not too weak to run it. I can't think of anything else that would create substantial improvement. If anyone here could offer some advice I'd greatly appreciate it.


EDIT: Something I forgot to mention is that during the DirectDraw playtest, one time he tried to save on a new file, and it just... didn't save. Save file remained blank afterwards. It worked every other time but if the game can straight up fail a save that's something we'll also need to look into.

Edited by Bearfax
Link to comment
Share on other sites

Not sure what you're running into, but I've played all five Geneforge games on Win10 with the only issue being a slow load of the save, etc. menu in 1-3.  Plays fine otherwise.  No special preparations. Nothing special about this machine either. 


Doesn't help resolve your issue, except maybe to help narrow your search. 

Link to comment
Share on other sites

  • 4 months later...

Weird. Both Geneforge and Avernum (old game) work perfectly on my computer:

  • Windows 7 SP1 up to date,
  • Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz (8 CPUs), ~2.6GHz,
  • 8gB of ram,  
  • Intel(R) HD Graphics 530.

The games do not use the Nvidia GPU.


Maybe it's a problem related to Windows 10 itself? Or it's pure lottery and your friend is out of luck...



Link to comment
Share on other sites

The first few Geneforges for me run ok I guess, I think it is meant to be a slow paced game to begin with.  BUT when I try to pause the game there is an eight-teen second delay each time.  Also the sound quality is atrocious with really horrible static with the repeating music (birds chirping, people talking, things being slid across the floor, etc.) loops.  The same can be said for Nethergate: Ressurection in terms of the sound quality, not the long delay between pausing.  However I think the sound may be due just to my subpar laptop, but the pausing should not be doing that regardless and I have Windows 10.  I made another thread about all that, but just posting it here as acknowledging the problems you are having with it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...