Jump to content

Can't open scenario in BoA scenario editor

Smite the world

Recommended Posts

When I tried to open a scenario (after i created a scenario of course) there was an error showing up in a window that said,

"Unhandled exception:c0000005

At address: 0042fd60"

Then a window shows up saying,

"Blades of Avernum Edit v1.0.3.exe has encountered a problem and needs to close..."

And then it closes.

I don't know if some files got corrupted or something. confused

I have Windows and i don't know if i downloaded the Mac version instead. Can somebody help me?

Link to comment
Share on other sites

If I'm reading correctly, you opened up the BoA scenario editor (which opened fine), created a scenario (setting its name, outdoor size, etc.), which also worked. The crash only came when you tried to load the scenario.


I highly doubt you were using the Mac Editor; the Editor wouldn't have opened in the first place. Presumably this isn't a one time thing, so maybe try reloading the editor.


If redownloading the editor doesn't work, maybe try the 3D Editor (pick 'Win3DRelease.zip).



Out to lunch.

If not back by five, out for dinner also.

Link to comment
Share on other sites

"Unhandled exception:c0000005

At address: 0042fd60"

It really would be handy if Spiderweb gave us a list of what those error messages meant in human - readable terms. Then we could go straight to the error.


Possibly you could provide a link to the scenario on your post and we can see if it crashes on our PCs. Have you been able to load all your other scenarios without any problems?


If so, you may be able to isolate the error: create a new scenario and import zones (outdoor or indoor sections) from the crashing scenario, one at a time. After you import a zone, save the new scenario and try to reload it.


If the error seems not to be in a zone it may be in the initial scenario part of the bas file. (The first fifty to seventy lines as seen when the file is opened in the MS-Dos Edit command.)


If you can isolate the error, the question becomes is it in a script or is it in the Bas file itself? This sounds like the latter.


Khoth's Alint program detects many, but not all, errors that occur in scripts.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...