Jump to content

Avadon Android bug with Trail of the Drake quest


Recommended Posts

Killing Shunacha does not trigger whatever is supposed to happen next. Nathalie does not speak, and the Drake does not appear on the main floor. I have killed Shunacha countless times now, sometimes first, sometimes after the golems and the shielding spirits.


Sometimes he dissapears while I am fighting the spirits. Sometimes I can kill him with one blow after killing the first spirit.


I even reloaded to an earlier point in the game, before visiting the Trail of the Drake. Once I got to him, I still had the same bug. About to abandon the quest, please help.

Link to comment
Share on other sites

Hmmm.... I am hearing rumors about that Trail of Drakes (from my dreams). It might be where Zhossa mindtaker fled (pretty obvious)... I don't have those android *blah blah* but this could be a bug or you don't have a special item...


Originally Posted By: adk
Sometimes he disappears while I am fighting the spirits. Sometimes I can kill him with one blow after killing the first spirit.

He disappears while you were fighting the spirits? does it show a dialogue? if it does, then it isn't a glitch. I don't know how this android stuff works (is it also programmed by scripts?), just try waiting for mods to come...


Welcome to Spiderweb software. Killing shunacha countless times is a good way of losing your sanity. And leave it at the door if there are still some left...

Link to comment
Share on other sites

allow me to explain a bit more since I'm having exactly the same bug.


it seems it's the "shadowstep/cunning decoy" ability that's broken when used by an npc.


the first action that Shunacha does after appearing is this ability ( "leap" appear on top of his head)


then I can kill the decoy ( one shot it in fact)

or kill the golem or the spirits.


but the 'true' Shunacha cease to exist. he never appear again, never attack me , don't seems to be hit by any area-of-effect spell,...


Earlier in the game, another character "ceased to exist" the same way ( one prisonier the second time I've got into the dungeon of avadon: another one of the same "class")



after like 10 tries this morning, he didn't bug the same way in the firsts turn but after like 10 turn, another bugged 'leap', and it's over.

Link to comment
Share on other sites

I'm having the same problem. I just figured out that by leaving the territory, the lower level "resets", so I can go through the whole drill again. Maybe I can kill the protecting spirits quickly enough, before Shunacha does the "leap." Or is there an entanglement spell that will prevent him from using this ability? Stun him so he loses a turn?


And I had the same thing with Shigaz in the trap in the Bandit Lair. He would "leap" and then was gone when the battle was over. I had to keep playing that one until I could wipe out the bandits in just a few turns, before he used the ability.


Playing on Android, BTW. Other than this issue, loving the game!

Link to comment
Share on other sites

I have run into this issue as well... and think I managed to get past it by accident, though I can't swear to the sequence of events:

  • I ran into this issue for the thirtieth time or so with Shunacha (and the fifth time with having already destroyed the four spirits first), having previously saved the game just prior to going into the crypts so I could restart with little time lost.
  • In annoyance at this happening again, I switched to another game to work off some frustration, and another one.
  • Somewhere in the process, Avadon performed an auto-save even though I was in mid-combat, presumably when it got rotated out of RAM.
  • When I switched back to Avadon several hours later, it automatically reloaded from auto-save... and I found Shunacha had reconstituted as Shunacha rather than a default Shadowwalker, and the other four spirits were still dead.
  • Needless to say, I made short work of him, re-saved the game once I was past that, and continued on.

I can't promise this will actually work, because I'm still not sure what really happened, but I think it's possible to get around this if you force the game to auto-save in the middle of combat, then only ever restart from that auto-save.

Link to comment
Share on other sites

Running into this bug on the Android platform, version 4.0.3.

Playing on a Transformer Prime tablet.


On the Beraza Bandit Pits quest during the underground battle; Shigaz will suddenly stop moving after performing the Shadowstep.

He will usually take damage and die after this, but if I keep healing him and finish the battle alone, he simply disappears.


The game is unplayable beyond this point as my character is trapped, and the story cannot continue.


This quest is part of the main storyline, and cannot be skipped, as suggested by Apportable.


Reproducing the error is simple, it occurs every single time this battle is played.


Kind of a major bug...

Link to comment
Share on other sites

It's definitely a bug and only seems to be happen on android. I had the very same issue in the final fight with Neray. I ended up just having to level up high enough to kill her before she picked that ability. It is nearly impossible in Trail of the Drake though, since you have to kill the shielding spirits first. He just freezes after doing the ability and gets one hit killed without activating thy he script that says you killed him.

Link to comment
Share on other sites

I think you might be right. Strange though as I assumed the reason for the laggy performance was because the developer was using aome sort of Spiderweb Virtual Machine to run his scenario files.


If these are run natively and not on top of VMs, what could account for the laggy interface?

Link to comment
Share on other sites

  • 2 weeks later...

I was running into this problem too. Here's how I got around it:

When the fight begins keep an eye on Suncha's Shade. When he does that stupid leap and the name changes to Shadowalker, exit the game without saving. Leave it alone for a little while then start again. You should reenter the game midfight a turn back from when you quit and the enemy's name should be Suncha's Shade again. Lather, rinse and repeat. It took me about 5 cycles, but it did eventually work for me.

Link to comment
Share on other sites

  • 1 month later...

Hi folks,


The update which fixes this bug has been released for the Humble Bundle. Thanks very much for your patience while we resolved the problem. You can download the update via your Humble Bundle download page or by using the Humble Bundle Android app. Please note that the fix is not retroactive - once you update, you'll need to open a save file from before encountering any NPCs which used Cunning Decoy in order for the fix to kick in.


~The Apportable Team~

Link to comment
Share on other sites

  • 11 years later...

I had this bug happen in the Steam version (PC) just now, it's a fresh download from 2023. 😧


I killed the dude and walked all around, exited the dungeon and all, and the Drake won't appear.


Nevermind, didn't realize you had to go ALL the way up the main hall. Sorry for the necro...

Edited by johnmyster
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...