Jump to content

Geneforge 4 Windows demo not installing


Recommended Posts



I'm not having any luck installing the Geneforge 4 demo. The installer goes to the InstallShieldWizard screen, checks my operating system, configures the Windows Installer, extracts "Geneforge 4.msi" and then closes--it doesn't do anything else. I searched my hard drives (including hidden and system files) for "Geneforge 4.msi" using the Windows search thing, and nothing turned up.


The demos for most of Spiderweb's other games install okay (I just tried Avernum 4 and Geneforge 3, both of which worked fine). I've redownloaded the installer three different times, each from a different mirror, and nothing seems to help. I've also successfully uninstalled and reinstalled the Windows installer (msiexec.exe) from the Microsoft site--that doesn't help either. Any idea what is going on?

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...