Jump to content

Slowdown problem with Geneforge 1


Recommended Posts



I downloaded Geneforge 1, and not long into the game, in certain sections of the first areas, the game is suffering large slowdowns as to make the game unplayable.


My PC:

AMD64 3400+

2.5 GB ram

Geforce 7600GT 256mb

Soundblaster live.

XP home SP2.


I have tried all the tips on getting the game to work posted at this website (Redownloading, drivers, etc) and to no avail. All of my other games work fine (Avernum 4 works fine, and my demo's of the other Avernums also work perfectly). I have read other posts in here with similar problems, but no solutions. I am wondering if any solutions have been found?

Link to comment
Share on other sites

Hi guys smile


On my gaming PC, which is offline, I don't actually use an Antivirus program. No need. I have no idea why this happens. I have tried redownloading on two different PC's and then playing them on mine. I have tried restarting PC. I have tried updating and going back in drivers...


Honestly, I have tried a lot of things. My next attempt will be downloading the demo from Manifesto games and seeing if this works....


Also, as I have said, A4 does work fine. GF1 doesn't. Consequently I bought A4 and am having a ball....


Anyway, I am going to download GF2 and 3 and test them as well.


Please help me with this problem. I don't know why this is happening, but it is, and I don't have this with any other game (As yet, let me check the other GF games).


Edit: There is one other post in here where a guy seems to be having the same prob with GF1. In it Jeff says he will look into but then the thread was never posted in again. http://www.ironycentral.com/cgi-bin/ubb/ultimatebb.cgi?ubb=get_topic;f=2;t=000782


There you go.


When I get back home, I will replay the area in which the slowdowns happen and explain fully EXACTLY where on the map they happen. Hopefully this will give you guys something to really look at.

Link to comment
Share on other sites

This problem does get reported from time to time. It is rare, and it can happen with any game. Everything I've seen about it before makes me strongly believe that it is not a bug in my code. (If it was my bug, it would happen much more often, because everyone would have it, and it would probably happen a lot more in one program than others.)


It could be caused by many things. A bug in someone else's driver. A 3rd party application. An operating system glitch or corrupted file that keeps old graphics resources from being properly dropped from memory. I have no idea at this point, and all i can suggest is to stick with the games that are working on your system.


Oh, and someone mentioned that more people with Avernum 4 seem to have this problem. As I have said in the past, the reason there are more people with problems with Avernum 4 is that more people play Avernum 4.


Sorry I can't be of more help, and I hope Avernum 4 works out for you. :-)


- Jeff Vogel

Link to comment
Share on other sites

Why not make a database of the systems used by people when they have this problem? Perhaps a correlation can be seen that will help point out what the cause is, or at least narrow down the options.


Even a collected list in a thread stickied at the top of this forum might nail something down if everyone with the problem posts in it.


Not home yet. Will try out GF2 and 3 then and report back, I am determined to try getting GF1 to work as the few moments I spent with it intrigued me.


And yes, A4 has been a blast so far thanks Jeff. You earned your gold on that one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...