Jump to content

A possible solution, that brings many questions


Recommended Posts

Firstly I'd like to say hello, I like the story in the exile/avernum series alot, although I have a dismal dislike for the Avernum interface due to being on a laptop(no numpad, for some reason only 2 usb ports, and a dead pc-card slot... meaning both usb ports are quite taken) but disregarding that, i dont like things fullscreen.


Now see Im in windows, and frankly I recently got in a mood for maybe finaly beating Avernum 2 and 3 (Ive actualy finished 1 and 2 in their original exile form, but its been too long, ive finished avernum 1 aslo...)


Anyway then it came to mind, a crazy idea, see i recalled back when i wanted to run starcraft in a window(this lasted about a month, it relay doesnt run in a window well XD but anyway) Now you folks might recall, starcraft has no windowed mode. Well a talanted programer created a program called ScWnd, and... it works pretty well, and latter he whent on and made DxWind, a more generalised version of said program.


So i grabbed the latest version, and threw avernum 1 into it, and low and behold it worked... sorta...

After turning all imput device options to unchecked, one pesky opening ony issue vanished, one monster of a button issue vanished, and it became playible.

I also set resolution to 800x600 and clicked patch all processes(though i cant recall when or what i was thinking on this last one...)

(just to be sure, settings down the left side in dxwnd unchecked, unchecked, checked, checked, unchecked, checked, checked, checked, unchecked, unchecked, never can be too sure... right side all unchecked, down at the bottom as noted, patch all processes checked)


Avernum 1, 2 and 3 all had the same exact issues, those being. (exceptions noted)

A, this is the one i need to figure out how to fix, the actual game runs in the bottom right of the window, and the window size is 1024x768, while the game runs... 800x600 i THINK...


This one im currently messing with. (the one above this statement)


B, the mouse seems ever so slightly off by location, im betting if the window size can be fixed this will vanish. Along with being ever so slightly "displaced" acting in respect to movement direction and the sensitvity seems a little high...


Update 03-1

C, ew found a new one, apperently atleast the char creation text box is quite gone, and do i ever mean gone...

End of update 03-1


So far as i can tell, if i can resolve A, these games will run PERFECLTY in a window... other gliches to come mostlikely, but ya never know...

Update 03-2

Well the new glich is quite a pain, i imagine it can be worked around by running the game normaly for those parts... but blah.

End of Update 03-2


Anyway, so of course, i grabbed the Avernum 4 demo... heres where this gets bad. First, i noticed it lists 1024x768 on the game-page, so much for running it functionaly in a window, but hey i can try anyway! Right? Well...


It... doesnt relay function... to say the least.

Somethings... incredibly different about the actual engeon, so some imput from Spiderweb may give needed insight here...


Anyway off i go to mess with Avernum 4 alot more, 1-3 a little more(seeing if i can iron that one, rather pesky though not critical bug out) and also trying the same method on BoA, and the Genoforge series(although i have little to no interest in genoforge, prehaps they act like Avernum 4, Avernum 1-3, or something elce all together or whatever.) Just being thural, bored, and helpfull(i guess). ^.^ Hopefully this will atleast give a good clean way to run Avernum 1-3 in a window properly...


Anyway... comments, attempts, sucsess, failure, thoughts, ect. ^.^


Update 01: Yeah, already, just wanted to say Blades of Avernum runs just like 1-3, although the slight mouse gliches are more noticible, theyre no more actualy hasslesome(basicaly neglgible)


Update 02: Yes yes, updating too fragemntedly, anyway, Genoforge 1-3 act EXACTLY like Avernum 4... simular engeon eh. Hummm... Well hopefully this can be done ^.^'

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...