Jump to content

Wine, Exile II, and the OLPC XO


Recommended Posts

Despite not receiving my XO for several months, it has finally arrived. In fact I am using it to post right now. It's much nicer than I expected it to be. Unfortunately my experience with linux is fairly minimal.


I've installed wine on the machine and downloaded the .exe intaller. However, when I execute wine on it nothing seems to happen. Should I copy the already installed program from my other computer and run wine on the actual game file?


Also, anyone else with an XO?


EDIT: I've solved my problem with Exile II, and now I'm able to play it on the XO. Although now I'm having trouble getting the Linux version of Exile III to run. It installs correctely but when I go to the directory and run ./exile3 it doesn't do anything...

Link to comment
Share on other sites

  • 2 months later...

[minor resurrect]


Originally Posted By: Lt. Sullust
... Also, anyone else with an XO? ...


Another XO owner here.


Originally Posted By: Lt. Sullust
... I've solved my problem with Exile II, and now I'm able to play it on the XO. ...


So what exactly were the issues / resolutions for getting Exile II to run on the XO via Wine ?


Originally Posted By: Lt. Sullust
... Anyone know if any of the Avernums are wine compatible?


I recently attempted to get A5 running on XO w/ Wine, but ran into a serious error. After messing around with what I thought were graphics library issues and much searching for sparse information on this fairly unusual endeavor, it dawned on me that the missing GLX messages were probably a red herring unconnected with the real showstopper.


Over at WineHQ, their program database lists A5 (and the other Avernums) as working just fine with Wine on a couple Linux distros, so I suspect this is yet another symptom of the highly stripped-down XO OS.


Originally Posted By: Lt. Sullust
... I've learned that remote desktop also resolve these issues. ...


I finally just removed both Wine & A5 (space on XO is at premium), at that point concluding, as you, that rdesktop would be a lot easier, although requiring an access point. Kinda defeats the time-filler mode I was hoping for.


It would be nice to know what specifically is stopping A5/Wine from running on XO, and even nicer would be a solution, but the cryptic error message combined with the closed source game and the rare configuration makes this unlikely.


And now, with XP for XO on the table, maybe this all just goes away. Too bad, as this odd Fedora / Sugar animal has sort of grown on me (like an annoying but endearing mole - ok, wart).


Want to pursue this further ? PM is fine. Not sure this is of any public interest. (However, be patient with my response time; in the middle of evil work things.)

Link to comment
Share on other sites

I believe it will be fine to keep this in the topic. It would be helpful for others who have an XO.


The issues I was having with Exile II, was that I was originally trying to run wine on the installer. This didn't seem to do anything. Instead, I copied the full version from my laptop to the XO. The program now runs correctly when I run it through wine; however, there are still a few graphic oddities. I should also note that you need to run the program as root if you want to be able to save your game.


Dealing with Avernum 5, I believe it is a graphical issue relating to the XO. You cannot use rdesktop to play Avernum 5 either, as the resolution change is not supported. XP might solve it, but I have my doubts as the resolution will still probably be an issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...