Jump to content

Strange Geneforge 3 Error


Recommended Posts

I've had no problems with Geneforge 3 until today, when I installed some new software. Now whenever I try to launch the application, the resolution switches, then switches back, then the application quits and gives me a little dialogue box saying "Failed To Open Sound Channels" with "Okay" being the only clickable button.


The programs I installed today are:


Dent du Midi (http://www.apple.com/downloads/macosx/audio/dentdumidi.html) — an application for letting MIDI files to be imported into GarageBand


Aucaity (http://audacity.sourceforge.net/) — allows you to edit and record sound files


EV Nova (Ambrosia game)


I know the culprit has to be one of these three. EV Nova also wouldn't work when I launched it, so I deduced the problem was one of the first two. I deleted the applications folders from my harddrive, and tried to start Geneforge 3. Didn't work. I'm afraid one of these two programs messed with my system files, in which case I'll never be able to track down the problem and fix it.

Link to comment
Share on other sites

I assume with OS X if you throw away the folder containing the program, that is "uninstalling" it? Some OS 9 installers used to make an installer log that kept track of all the files the newly installed program created or altered. That feature seems to be gone in X, and I really miss that. All OS X programs I've installed were either as disk images or SIT files. Starting up a program for the first time will often cause the application to alter other files as it "settles in," but there seems to be no way of keeping track of what it's doing.


I deleted the EV Nova folder. But the problem remains...

Link to comment
Share on other sites

Originally written by Thuryl:
I've installed Audacity and have no problems with it, so it's likely your problem is with DdM.
I've left a similar cry for help on Ambrosia's message boards, as well as emailing the creators of Audacity and DdM. Hopefully someone will have some idea of what the heck is going on.
Link to comment
Share on other sites

After posting the crash log Panther generated when EV Nova autoquit on the Ambrosia bulletin boards, I looked through it more closely and noticed this bit. I've included all the header information from the crash log, and an excerpt detailing something called "Thread 2" which apparently crashed:




Date/Time: 2005-05-24 16:53:26 -0700

OS Version: 10.3.5 (Build 7P36)

Report Version: 2


Command: EV Nova

Path: /Applications/EV Nova 1.0.8/EV Nova

Version: ??? (???)

PID: 266

Thread: 2


Exception: EXC_BAD_ACCESS (0x0001)

Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000


Thread 2 Crashed:

0 ...ple.QuickTimeMPEG.component 0x8105fb78 S_ComputeDCT27 + 0x18

1 ...ple.QuickTimeMPEG.component 0x8105d108 ParseMpaLayer2Stereo + 0xab0

2 ...ple.QuickTimeMPEG.component 0x8105acd8 SetupThenDoMpaFrameDecode + 0x118

3 ...ple.QuickTimeMPEG.component 0x81058348 S_DoFrameDecodeWrapper + 0x64

4 ...ple.QuickTimeMPEG.component 0x81057cbc S_DoFrame + 0x60

5 ...ple.QuickTimeMPEG.component 0x81057a9c S_ParseAudioStreamForever + 0x214

6 ...ple.QuickTimeMPEG.component 0x81057870 AudioThreadEntry + 0xa0

7 ...ple.QuickTimeMPEG.component 0x8103bee4 MacThreadFunc + 0x78

8 libSystem.B.dylib 0x900246e8 _pthread_body + 0x28




So I'm beginning to wonder if one of the two audio programs did something to Quicktime. I'm using Quicktime version 6.5.2. iTunes seems to be unaffected, so maybe it's the video component or something that was messed up. To confirm this, I tried to play a Quicktime MPG clip which I've seen many times before with no problems, and received the following error:


"You may experience problems playing a sound track in "StarWarsEpisodeIIITeaser.mpg" because a software component needed by the movie could not be opened. Would you like to close the movie or continue?"


I can't imagine what either of these two audio programs would be doing to video files, so maybe it is EV Nova after all. I don't know...


Should I re-install Quicktime?

Link to comment
Share on other sites

Well, I finally resorted to visiting www.doctormacdirect.com, a website offering Macintosh technical support, and read their "Free Advice" page. To make a long story short, my Quicktime preferences files (in my user account library) had become corrupt somehow or other, so after throwing them away everything was fixed. Videos now play correctly, Geneforge 3 works, as does EV Nova. I've had preference files corrupted in the past on my iBook, and know that such things are usually inexplicable freak occurences that don't occur twice with the same software. I've re-installed the Dent du Midi program and used it, and it works fine. If I'm feeling particularly adventuresome tomorrow, I may try re-installing Audacity as I really need its noise filtering feature when editing audio files recorded from old LP records...


Anyway, so if anyone reading this ever comes upon a similar problem, try locating your preference files for the program causing you trouble and put them in the trash. WIth most programs, starting the program up again will create fresh new preference files. If it's a shareware program, though, your registration might be lost, and you may have to write the company you bought it from to get a new key. Of course, it's a good idea to back up preference files for shareware programs right after you register it!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...