Jump to content

Please help! Avadon: The Black Fortress Nightshade wolf quest, characters in vortex


Recommended Posts

Hi all,

Thank you so much for any help you can offer! I've been playing Avadon: The Black Fortress for awhile now. I just took on the "Nightshade": wolf quest in the Kva last night, where I am to encounter the pack and kill them. This was after I defeated the Titan Army, and completed the Elder's sidequest. 

A very peculiar series of things happened. First, I raced my characters up to the northwestern edge of the map to double-check a chest that appeared closed, and my main character seemed to temporarily disappear, but then she reappeared again. I left Goldcrag to enter the Kva Lands to find Nightshade. Upon my encounter with the strange, green wolf, my main character was immediately enveloped into darkness -- she became outside of the entire map territory, and nothing was clickable. Interestingly, the other two characters also became pitched into blackness, but when I reloaded my save file (which I saved, just before encountering the wolf), my main character had appeared to be permanently off of the map screen and in darkness. The other two characters still existed, but when I returned back to Goldcrag and attempted several trials, including entering and leaving the Titan Lands, Goldcrag, etc., nothing brought the main character back. Also, the Avadon pylon in Goldcrag told me, upon my attempting to return back to Avadon to see if that would reset the whole madness, "Can't move here from where you are". Which is, apparently, in outer space. So, I tried the autosave, and the same thing happened. Upon repeated attempts of opening both of these files, I found that most of the time, my other two main characters would become pitched into darkness and thrown off the map as well, so that nothing was functional, and no one anywhere to be found. Again, I tried to encounter the green wolf Nightshade, and, true to its deadly name, it yet again re-immersed ALL of my characters into immediate darkness, into the void.

A couple of things I'd like to honestly disclose, out of being new to troubleshooting glitches like this, and working on Macs in general (I have a Macbook Pro Retina 2015, no updated graphics card, 16 GB of RAM, running 10.14 Mojave OS.).

Firstly, I downloaded this game from the "MacGameStore", an app built into the MacBook. I read that I should uninstall and then reinstall the game for troubleshooting, but I'm concerned: will this delete all of my save files?? I do have prior save files from this game, but I am hoping I can somehow recover this one, so I don't lose about three weeks work of progress... that would totally demotivate me to continue playing. D:
So, will I keep all of my save files if I uninstall and reinstall the game?
Also, the MacGameStore has apparently discontinued this game. It tells me I can still "play and install it". However, I'm unsure if that means I can also uninstall it, reinstall, etc. without any issues coming up.
Again, I'm not a software or game expert. 

I really appreciate your help! I love this game, and I hope I can get my progress back! Nightshade sure is an apt name for this wolf to be reckoned with. I could not find this glitch on the site.

Thank you.


Link to comment
Share on other sites

The Save Game files should be in a separate area from the game files that you uninstall and reinstall, but you can always copy them over to another area on your hard disk or to a USB flash drive before doing anything else to be safe.


The Auto Save file is made when you leave a zone not in combat mode so it was corrupted when you first left a zone after the problem happened.


I'm afraid that all Save Game folders made after the problem first happened were corrupted so going back to the next earlier file may be your only hope.


Can't answer about whether you can do the install still from where you bought it and they would be better place to ask.


Good Luck.


Welcome to Spiderweb Software. Please leave any remaining sanity at the door. You don't want to lose any more here. :)

Link to comment
Share on other sites

Thank you for the reply, Randomizer!

I've reached out to the MacGameStore about the issue and am awaiting their response. My hope is that I can uninstall and reinstall the game successfully, without any errors, despite it being discontinued on the platform.

So, do you really think if I reverted to an earlier save file, I wouldn't experience this corruption of darkness and unplayability again? I just have a concern that, even *if* I managed a de-installation and reinstallation, the corruption could be embedded somehow within the code of the game (I'm not totally sure how it works, but I think that's how it works?), and it could just resurface. Potentially at any point, even if I avoided Nightshade, or that initial wolf I encountered, entirely. That would make me so sad.

Truthfully I love the series enough that this wouldn't stop me from playing it entirely -- but, given I'd lose a lot of progress and I don't like retracing my footsteps especially on such uncertain ground that it could resurface again unpredictably, I've thought about just advancing to Avadon 2, especially if I wouldn't miss much of the story, and there was a way to get perhaps a video cut-scene update... I don't want to look up the titles of the other main quests left, because I've already kind of spoiled enough of the game for myself 😕 but, could someone give me an idea of how many main quests are left, after the Titan's Army is defeated, and before I 
would have the opportunity to fight Redbeard? 
That was also my hope, to have the props of victory. And also, to feel the satisfaction of completing something, since I've had a habit of starting and not finishing some games. This is one of the few games I'd actually want to finish!


Link to comment
Share on other sites

Usually once a save file is corrupted, then it stays corrupted. However I haven't heard of your specific problem. so I can't say for sure.


Probably if you start from an earlier save game file and don't repeat the exact same action that caused the problem, you can play the game without any other problems. Just be more careful in moving near the edges of a zone until you are ready to leave to go to another zone. Make more different saves so you don't lose as much time if another problem occurs.


You still have a few more major quests to finish the game that you might enjoy, but you are close and Nightshade is an optional quest.



{spoiler]This is the hardest scripted fight in the game just because of one requirement that can make it take an hour.[/spoiler]

Link to comment
Share on other sites

Okay, I just successfully uninstalled and reinstalled the game, and moved my save files over to another folder on my hard drive. I tried keeping the save folder intact originally and then also tried moving the folder and deleting it, then copying the old folder into the new space for the Avadon game. The files are still corrupted.

I am noticing that I am able to detect which Saves, by number, are the problem (16 and 19, the autosave file). Is it possible that if I delete both of these save files in the Avadon Saved Game folder manually, there is a better chance that the game will no longer be susceptible to any further corruption, both before, during, or after the Nightshade quest? I'd be kind of daring to take my chance at Nightshade again, but if I had four or five save files as a back-up just as soon as I may encounter any problems... it would be tempting.

Also, I do notice that there is a ton of very complex code in the "header" folder of the Saved Game. If I was an expert programmer, would there be a way to detect the corruptive error within all of this code, and possibly be able to extract the tumorous problem, so that my main character would be restored within these save files?

I noticed that upon some tentative footsteps with Sevilin and Nathalie, before I engage in the combat that corrupts the file entirely (and initially damaged my main character into a permanent vortex), there is that green wolf waiting around the corner, and I believe its name is entitled "Altered Wolf". I can't be 100% though, because the second my characters engage in combat, I'm pitched into darkness for all three of them, so it's barely enough time to read the screen. Still, I noticed that the "data" text from a previous save file has the word encoded "Salamander" in it, and so I'm wondering if this data might have the words "Altered Wolf" in it, a programmer might be able to help me out... I could paste the code, and I'd be happy to offer some kind of small reward if someone can do this type of work (if that's allowed?)

I guess in the meantime, I could tentatively start to retrace my steps with the other file. But I'd like to know if there is anything else I could try to restore the files, or at the very least, if deleting the corrupted save files would ensure a smoother experience from here on out.

Thank you.


Edited by aliveanddreaming
Additional details about the code
Link to comment
Share on other sites

Yes... sorry, just a follow-up. In the "data" folder, there are pages and pages of complicated symbols and letters, but the words "Altered Wolf" appear at least 15 times, along with Nightshde. My main character's name is also in the code, and some symbological script as an interpretation for her corrupted locale in space appears next to it. Same with Sevilin and Nathalie, so... if I knew how to paste their respective code locations over my main character's one, and then change the coordinates by just a couple of points, it's likely she would reappear on the map again ... ? And then I could run like the wind from the wolves, or their codes could also be fixed, and keep my file!

I wonder if anyone would have this kind of expertise to help? It seems like it's my only hope to keep the progress I've made.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...