Jump to content

Recommended Posts

I have a large 4k monitor @ 3840x2160. As far as I can tell, my options are:

 

1. Let A4 change the resolution to 1024x768. This results in stretching of the text and art, which looks bad. Oddly, it also makes the game run very slowly.

2. Don't let A4 change the resolution. The game runs in a tiny frame in the middle of my screen, surrounded by black bars. It runs fast, and is scaled properly, but is... small.

 

Is there a third option I'm not aware of? I'd really like the game to be larger *and*  use the proper aspect ratio.

If it matters, I'm running the steam version on PC.

Link to post
Share on other sites
  • 1 month later...

A second option would be to use DxWnd. It does not modify any registry files, and runs without installation. While it is generally used to run fullscreen games windowed, it can also be used to change the aspect ratio/resolution of games.

 

Simply run dxwnd.exe, drag the executable for Avernum 4 into the program, and in the "main" tab, change the window position/setting to your desired resolution and check "Desktop center." In your case, you have a 4K display and Avernum 4 runs natively in 4:3, so the correct resolution for you would be 2880x2160. For a 1080p display, this would be 1440x1080. Keep in mind that this is going to be blurry no matter what, because Avernum 4 runs natively in 1024x768 and increasing the resolution does not increase the field of view and will only stretch, but this will keep it in the correct aspect ratio.

 

In the "mouse" tab, turn off cursor visibility (since A4 has its own cursor) and turn "Mouse Clipper" on, which locks the invisible windows cursor inside the frame. 

 

Then, keeping DxWnd open, you can either start the game from Steam or Windows. Here is what the game looks like on a 1080p screen with the native resolution.

 

 

Edited by Scrub
Link to post
Share on other sites
  • 8 months later...

I know this post is old, but I found another option. I have a 1440p screen myself and Geneforge 5 was way too small on native resolution. Steps to fix it were:

  1. Enable integer scaling in the GPU driver settings (tested on AMD GPU)
  2. Calculate half of your native resolution width and height
  3. Set the game to skip the settings screen on start so it doesn't mess with the settings file you are about to modify
  4. Open the "Geneforge5SettingsAM.dat" file in a Hex Editor and find the position where the resolution width and height is stored. I used HxD and it has a number search function to easily find it.
  5. Change both values to your calculated ones and save.

Now you have a sharp 2x upscaling of the game 🙂

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...