Jump to content

Issues with Save/Load/Quit Modal


Matt
 Share

Recommended Posts

I started playing the game late last night before bed, and I'm at work now so I haven't had the chance to digest much of it. So far, so good in terms of game play.

 

I tried to save and quit and was unable. Here are the steps I took:

 

1. Brought up the Save/Load/Quit Menu, and selected Quit.

     - Every time but one,  the game brought up the "Are you sure you want to quit without saving" modal with Cancel/Confirm

     - One time it brought me right to the Save modal

2. If it asked me to confirm quit without saving, I chose Cancel, which brought me to the Save modal

    - I also tried Quit without Save and that also closes the modal and doesn't quit the game

3. I saved and then hit Confirm.

4. The Save/Load/Quit modal closes and I'm back in game play, instead of the app closing.

 

I can't figure out how to close the game through its interface - I have had to use Task Manager to force stop the program both times I ended gameplay.

 

I had the bright idea to click "Return to Main Menu" and try quitting the game through there, however, upon clicking that I'm presented with an empty modal dialog window with Cancel/Confirm:

2eb53ec807182db2f51811dc1d1e19b5.png
 

Clicking either Cancel or Confirm simply closes the modal and returns me to gameplay.

 

System Specs:
Windows 10 Pro, 1.0.17763 Build 17763, x64

 

(also sent this to tech support email)

 

 

 

 

Link to comment
Share on other sites

22 hours ago, Spidweb said:

This is the only report of this we've had, so you might have a corrupted game file. We'll look for your support email.

It’s happened to me twice. After a force-quit the saved file opens fine.

 

EDIT: that was with the demo version. Hasn't happened with the full version after just about as many hours of play.

Edited by Raptor
Link to comment
Share on other sites

It happened again. Not sure what causes it, but I am also playing the demo (don't worry, I plan to buy the game next paycheque!). I also saved using the regular save menu instead of quitting then saving when prompted. Then I went to Quit, and the same thing as I outlined in my initial post happened again.

 

EDIT: I think what is happening is something is causing the "Quit" button to be bound to "Save" event instead. It's as if it's treating Quit as an alias for Save. It isn't asking me if I want to save before I quit, it's just shunting me to the Save modal. Hitting Cancel doesn't quit. Combined with the Main Menu button being broken, in this scenario an OS force quit is necessary to stop the program.

 

EDIT 2: The Windows dialog X (close) is also bound to Save when this issue occurs, apparently.

Edited by Matt
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...