Jump to content

Avadon 2 OpenGL sluggish, DX crashes


Lord Yanaek
 Share

Recommended Posts

Hi. Just noticed you have released Avadon2 so i went on trying the demo. Glad i didn't buy first. Currently the game is simply unplayable for me.

 

The OpenGL version works but is sluggish to the point it takes several seconds to play each combat animation when fighting the first 3 rats in the tutorial. The mouse has some delays too, it takes about 1 second for the pointer to move after i move the mouse, and it will move for about another 1 sec after i stop moving the mouse, making pointing to any menu item or in-game object a pain.

EDIT : I've just found the troubleshooting section of the manual, my FPS varies between 2 and 3!

The DX version of the game seems faster in the main menu, but it crashes when actually entering the game making it useless. I also have the no-text issue someone else encountered.

 

I have Windows 8.1 and my computer is not really old. I can give you more detailed system information if you need them.

 

I already tried running both versions in WinXP and Win7 compatibilty mode (WinXP this should force the game to use DX9 rather than DX11) but this changed nothing.

I tried running with minimal graphic settings as well as in window mode rather than fullscreen but it didn't help with speed for the OpenGL version. Turning animation speed to fast slightly improves combat speed, but not much, and does nothing for the mouse delays.

 

And BTW, manually installing the DX9 runtime didn't help either.

 

Anything i can do? I might try to upgrade my GPU drivers, but past experience told me not to do it unless absolutely required as it will often bring in new bugs along with solving old ones :rolleyes:

Nope, i can't, my driver is the latest one.

Edited by Lord Yanaek
Link to comment
Share on other sites

I have a similiar issue. On my Windows 7 AMD 1.6 Dual core- Integrated graphics, the frame rate is good- usually in the 40's, 50's or even 60's. However, combat approaches and animations are jerky, especially at first. Sometimes they even out later. This does not happen on my older (though faster) XP computer. I don't know if there is much that can be done about it. Maybe someone else does. I'm sure the problem is somewhat common.

Link to comment
Share on other sites

Ok, here is something that seems to improve the situation for anyone else having these issues, it's not perfect, but a noticible improvement. First, play with the Direct X version. If you bought the game from GOG (or elsewhere) as I did, try the demo version of this from the Spiderware version. Then set your Compatability mode to Windows XP (I also run as administrator and "check" disable display scaling for what it is worth). There are still some jerky movements, but combat always runs more smoothly. If this fix works you can always explain your situation (and verify your purchase) to Jeff and request a key, he seems willing to send you one to enable this mode. Hope this helps. If anyone finds a better solution let me know please.

Link to comment
Share on other sites

  • 1 month later...

Hi. Sorry to necro my own thread but I finally managed to fix this (this was actually a driver issue). Here is what i did in case anyone else has troubles.

  1. I downloaded hwinfo to get detailed system information. Another free system info tool might work too, i just wanted more than the basic windows stuff.
  2. Knowing the exact version of my GPU (board and chip), i downloaded the latest direct installer, not the auto-detector from AMD.
  3. I uninistalled the current drivers using the AMD installer
  4. I wiped all the temporary files from C:\AMD
  5. I used the device manager to remove the outdated windows driver from my system comletely, my screen turned to basic VGA mode.
  6. I used the installer for the latest driver i downloaded at step 2 to install the latest driver. Then, and only then i could actually update the driver. If not for step 5, no matter how i attempted to update (using the AMD installer or the direct driver update) i couldn't actually put the new driver on my system, Win would tell me i was already up to date (while i was not) or simply crash the installer.

75 fps with openGL mode now. Finally going to be able to play the demo (and probably the rest of the game later).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...