Jump to content

Run the Avernum Trilogy (and other Classic Environment games) on your OSX 10.7+

Recommended Posts

Some people are using Wine and the like to run the Windows version of the first Avernum Trilogy (FAT), but someone in another thread was having issues with that, so I'd like to give a very basic how-to on setting up an emulator to run FAT and other programs that need a Mac Classic Environment for on your OSX 10.7+ machine. As we well know, 10.7 did away with a lot of backward compatibility, and I wanted to play some old games on my laptop. The two main emulators for this are Sheepshaver (for the curious: the name is supposed to be a play on "shapeshifter") and BasiliskII. I'm going to give a rundown on Sheepshaver but, if it gives you a lot of trouble on your machine, you might try BasiliskII (some guy's setup guide video for BasiliskII here:



Sheepshaver is my preferred emulator because it is a standalone program with its own GUI, is fairly easy to set up, and it also happens to be the best one I've found for running Realmz (which some of you might be familiar with from the days when Spiderweb Software was associated with Fantasoft. Fun fact: Exile II-III and Realmz even have some shared graphics and sprites). Oh, and it's free, so that's good, too.


The three things you'll need are the program itself (duh), an old Mac ROM, and the actual system files. Sheepshaver has its own support community and commensurate site where you can get the latest version, and some altruistic soul has provided the other needed files here: click me I'm a link! which is a godsend since the old Apple ROM and OS files are otherwise a pain to find. Scroll down on the redundant robot link and find the New World PPC ROM and the MAC OS 9 Boot Image.


When you open the Sheepshaver (SS) folder and try to run the program for the first time, it will fizzle and immediately auto quit. This is normal. To move forward, we need to rename the ROM file we downloaded to "MAC OS ROM" so SS will recognize it, and drop it in the SS folder with the actual application. Go ahead and create a new folder titled "Shared" and drop it in there, too. The boot image we downloaded can stay as "OS9.img" but we're going to want to select it and do Get Info so we can check "Locked" (sometimes SS won't accept it as a disk if it isn't *shrug*) then drop it in the SS folder, too. SS should now open and give a grey screen with a floppy disk that has a blinking "?".


Now go to the toolbar and open preferences in the SS menu. The ROM file should already be filled in, since SS booted off of it and all. The Unix Root is our middleman folder that lets us move stuff from our main machine to the disk we are going to create. In this case, it is the "Shared" folder we created. Use the Browse button by that Unix Root row to select this "Shared" folder. You should also see an option for RAM size below that. I've never fiddled much with it, but I recommend giving it a RAM zip a machine back then could have expected, like 256 or 512. Check the "Disable CD-ROM" box. We then want to use the "Add…" button to select the OS9.img file. This is what SS will boot off of when we reopen it. Now we want to create our hard disk with the "Create…" button. Name it OS9 (or whatever suits your fancy), and give it an appropriate size (I only have a few games I run, so 600mb gave me more than enough wiggle-room) then save it in the SS folder. All of our file work is done, so we just need to finish up the preferences.


The Audio/Video tab will have the video mostly up to you, but my video setup is Window - Dynamic - 1024 - 678 and enable quickdraw checked. I haven't messed with the audio, so I left Output and Mixer devices as /dev/dsp and /dev/mixer respectively.


The Miscellaneous tab should have all CPU Options, except that experimental one at the bottom checked. The Mouse/Keyboard shouldn't have Raw Keycodes checked, unless you need to use a non-qwerty key set. I like Mouse Wheel Function set to Page up/down (those of you on MacBooks will be able to use the two finger slide scroll with this option). Serial/Network can be left alone, with Ethernet Interface just being filled in with "slirp" for some reason that I don't know.


All that done, just hit save! You'll need to force quit SS now (shortcut of cmd+opt+esc), since it is not functioning at this point.


When we reopen SS, you'll boot up and get a "disk is unreadable…" message, that prompts us to format/initialize the volume we created ("OS9" if you followed my example). I just named mine the classic "Macintosh HD" but its whatever floats your boat here. You'll want the Mac OS Extended [your volume size here] format from that drop down bar. Now hit the initialize button. You should get a warning prompt about volume erasure that you just hit "continue" on. We now have a desktop. Whoo!


You should see your boot disc (the OS9 image), the volume you just named, "unix," the trashcan, and a little extra toolbar near the bottom (you can click the tab on the end of it to minimize). Opening the OS9 disk, we should see a "System Folder" that we can then drag n' drop into our newly named volume. Double check that it successfully copied, then go to the SS preferences (on the OSX toolbar, not the emulated one) and remove the OS9.img from the volumes list. Now quit SS (shutdown from the "Special" tab in the emulated toolbar does the same thing) then reopen it. SS will boot and the desktop should look the same, sans the removed OS9 disk image. We now have the final product!


Anything you want to run in SS, just drop in the "Shared" folder. If you then open the "Unix" folder, it will be there. Just remember to move any application to your "Macintosh HD" disk folder (NOT just the desktop) before you attempt to run it, to ensure optimal operation. Some applications will be fussy if you don't move it to the created volume. You're all set to get your nostalgia on.


A few final notes:

SS, being an emulator, is a very fussy program, so don't be surprised by occasional error messages (I've never had one interrupt a game in progress, however), or needing to quit and reopen, not just select the "restart" option in the emulator. I've also noticed that SS absolutely hates it when you quit a game, then reopen it (or another application within SS) without quitting and reopening SS, too. This applies to the installers for the FAT, so you'll need to install one, quit SS, then reopen and proceed each time.


As I said in the beginning, this is a basic guide just for a fast start. You can certainly modify how SS operates with the preferences, but I haven't done it myself, so you'll probably need to consult the SS forums should you be so inclined to personalize your emulator's performance.


I think that's about it.



Link to comment
Share on other sites

Yeah, just found that out for myself when I ran into a weird bug and tried it. For some reason, A3 has been running perfectly but when I went to try A1 and A2 just today, neither of them were able to load saved games. Everything else works fine, including the prompt for "save as," but when "load save" is clicked, it gives the thinking icon briefly, but no window opens up to let you browse. Like the other poster, the Wineskinned versions don't seem to work for me (it "opens" and the toolbar changes, but no window appears and nothing else happens), and I even tried using Crossover on the plain Windows version to see if that would work, but that failed, too.


Would you happen to have any ideas on the subject?

Link to comment
Share on other sites

  • 2 weeks later...

Found the issue: the only volume I was simulating was in OS extended format. On a hunch, I tried adding one in standard format, and that seemed to fix it. No idea why that was the case (probably a quirk with those system files and sheepshaver), but now it works no matter where the game files are placed on the SS desktop.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...