Jump to content

Cross-compiliation of the 3d editor on the Debian


Recommended Posts

If this were SV, the subtitle would be a series of angry faces and cursing.


Copied the existing makefile over, changed the executable names to their proper i586-mingw32msvc-* form, yadda yadda yadda. However, a notable problem comes up rather quickly.


sylae@vanadium:~/blades-nightly/source/BoA3d$ make -f Makefile-Nightly-i586
make: *** No rule to make target `BlAEditor.cpp', needed by `BoA3DEditor_BlAEditor.o'.  Stop.


The issue seems to be that the file names have spaces and the makefile doesn't. I've tried adding spaces. I've tried quoting the full filename. I've tried backslash-escaping, nothing will make this error stop appearing. Quite irritating.


But Wait, There's More! Call right now and symlinking the non-spaced names to the spaced ones won't work either. As a free bonus to you, our valued customer, neither will renaming!


I'm running GNU Make 3.81. Any tips? Anypony else hit this issue?

Link to comment
Share on other sites

I took a look at this, renaming the files to the ones in the makefile seems to work, but there are a couple of extra headers / libaries i need to put in for it to compile, so I'll get the updated makefile on the svn tomorrow-ish.


EDIT: no I won't, sorry, it's taking me too much time. I might do it once the editor's a bit more stable. Until then, if there's an svn update really worth having I'll probably have a build for it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...