Jump to content

Stuck in pt2 of Adventurer's Club 3...help?


Blades2011
 Share

Recommended Posts

Hi All,

 

Just joined the forum, can't believe I picked up BoE again after so, so many years. But more interesting than most of the games out there today.

 

Had been playing Adventurer's Club 3 and am stuck in part 2 and not sure what to do that this point -- so any help would be appreciated.

 

I am stuck on the Slith island. Checked the city but only got the 'laser' and can't cross the chasm. Checked the outside and found the refuge for the gumby but nothing more. With the choice made earlier that would have ended the scenario, is this suppose to happen, to be stuck forever?

 

Also, for some reason I can't get the alchemy set. I have a feeling this would have really helped at some points?

 

Thanks in advance.

m

Link to comment
Share on other sites

Hello back, 'all'. ;^}

Welcome back.

To answer your questions, albeit in reverse order...

 

The Alchemy set will be given to you by Fregk-Ursia in Grah'Mok. In your conversation with her, she should have told you the she wanted some Nightshade.

You should have also been given a Quest to retrieve the Heads of some Caveworms for someone who will pay you for them. (IIRC, there are a total of three.)

When you are in the Cave of the Caveworms, lookd for a Secret Passage through the Cave Wall at 51, 04&05. There you should find the Nightshade. Return to Grah'Mok and mention the word, 'Nightshade', to Fregk-Ursia and she will give you an Alchemy Set as a reward. She doesn't mind because she's sure you can't make Potions anyhow.

 

I don't know what you mean when you say that you are "stuck on the Slith Island". I can only presume that you haven't entered the City of Basshuk.

You need to enter the City of Basshuk and will need to learn a Password. Enter the Council Chambers on International Street and speak with Chief Sslatik. He will tell you that Password. At the City Gates tell the Guards you have a message for the Chief's friend, Kumar. When Kumar comes to speak with you, say the word, "Ssvechtza"

(I don't know if you need to actually speak with the Chief. You may be able to just say the Password.)

 

As to the "Greenball Express"...

I'll end up writing half a Novel to explain in detail what you need to do, so please excuse me if I answer your questions in sections, starting with this one.

First, In Magestica, Level 2, speak to a Gumby Servant at 11, 05 in a Residence at 09, 07. Listen to his 'problem' and see if you can follow through with what he needs you to do.

when you get him out of Magestica, you can take him to the Area you've described, but there is much more to this Quest; it's actually a "two-parter".

 

Let me know if you are stuck after accomplishing this.

I watch this Board pretty regularly, so you shouldn't need to wait for too long for a reply.

 

me

Link to comment
Share on other sites

Hi Ahbleza,

 

Thanks for your quick reply!

 

1) Alchemy set. Thank you! I figured you get it from Fregk-Ursia but couldn't get to the dialogue where it wanted something. I kept getting dead ends on the dialogue. I spent 2 hours talking to that thing! Thank you, how did you get to that part of the dialogue that it was missing something, it needed something? I had already gathered the nightshade, so it took me 10 seconds to finish that one and get the potion of light and more!

 

2) Slith Island. I meant the island of Zenarbial, after you get teleported to Kunisulitz (when you reject Vargas's offer to join after 'healing' Lucivius). I explored the town and nothing, I explored the island and only found the refuge for the gumbies. But I can't figure out a way to move forward with this game being stuck, having my priest spell level decreased!

 

3) Gumby. Oh, I got gumby out and dropped him (it?) off at the devastated sanctuary. As explained, I found the mountaintop sanctuary on Zenarbial, but I am stuck on the island!

 

Aside from that I've accomplished almost all the quests out there, except the scavenger hunt (stuck at the "ruby" clue one), the demon cave (can't get over water, I am thinking this is linked to the alchemy set potions?), and don't have access to the manor [all part 2 'quests'].

 

Thanks again!!! smile

m

Link to comment
Share on other sites

Sorry I'm slow getting back to you. I started last night, but got side-tracked. ;^{

2.) Assuming that you've been to the "Lazy Lizard" and spoken to the Bartender, Ssleezak, and the Receptor, Savel, and are at the point where you realize you've lost Priest Spell Points, and I assume you've been to the Ferry Landing where you reafirm that, "Lucivius does NOT want you to leave this island!"...

You have to climb Mt. Zsarnek. Go to (469,032), receive the message and then climb further to a clearing at (473,030). You will now need to Cast, "Flight" to pass a "High Wall you cannot climb" in four places. They are, (474,023), (469,018), (464,010) and (472,007). This will bring you to (471,013), Mt. Zsarnek Summit.

Enter the Shrine at (31&33, 18). Walk over to and 'Look' at the Statue of Odashai. When asked if you want to Pray, answer, 'Yes'. You will get a message regarding what you could do with this Site and should realize who you need to talk to about it.

Before you leave, get the Blue Orb from the Chest at (32,26).

Now, return all the way back down the Mountain and re-enter the "Lazy Lizard".

Talk to Savel again and ask about the Ferry. He'll mention a 'Teleporter'; ask about the 'Teleporter'. Go where he tells you and you'll be teleported to another location where you'll need to work your way through.

Once this Puzzle is completed you can work your way back to "Safe Ground" and go to the Transit Center. Go to Magestica to speak with Quintus.

(You'll know what to talk about.)

Once you've completed this, you may have some unfinished Quests. Post again and I'll tell you which I did next.

Also, because the "Scavenger Hunt" is pretty involved, I found it easier to accomplish a few of the Items as I found them and then, at a 'quiet' point in the Game I concentrated on only the "Scavenger Hunt" to complete it and then return to the main Story-Line. Something like this really just helps to confuse all the other things you're trying to accomplish.

Again, post about which you want to do next. I think I do have any answers you may need.

P.S. I assume the "Ruby" you're referring to is the clue that refers to "rubies, sometimes found in caves, etc."

In the Magestica Prison, in the southwest pod, there is a Ruby Pedestal with a note.

Keep on keepin' on. Not being much of a 'Player', I found this to be the only difficult Puzzle Scenario that I really enjoyed. Although, when I first started with BoE, I was totally confounded by it and must have asked for help a hundred times. There are four or five Scenarios that I re-play every month, or so. This is one of them.

me

Link to comment
Share on other sites

Hi Ahbleza,

 

Oh, no worries, thank you for the help!

 

But I had figured it out this morning over a coffee (don't ask me why I started up early this morning) on the big-headed guy in the bar and got through the manor (and yet another sphere).

 

And yes, I figured out beforehand it was Quintus that the gumbies needed.

 

So I did manage to figure all this stuff out (sometimes a hangover+coffee helps these things!), but thank you for writing it all down!

 

The only thing different is that praying to the statue doesn't do my party any good, but the timer node told me what to do.

 

So basically now I am running around with not much to do since the barriers are back up and Grimly is not helpful. Aside from the main quest the ones I have yet to finish are:

 

* Vigara (the 'viagra' thing...not much clues there, I've asked the pharmacy and medics everywhere);

 

* Scavenger hunt (I will pursue this later today since you tipped me off on the 'ruby' clue);

 

* Under San whatever, the demon summoning cave (I got the summoning book/instructions but still need to get over the water. Can't figure out where to learn to swim or to crack the cave ceiling);

 

* Priest spell level 7 (I assume to restore my level 7 spells I go to the priest guild, but can't get the dialogue to get to that stage...some of the dialogue clues are infuriating, like the alchemy set thing!);

 

* Magite weapons...the orbs (I assume I need to 'make' some of the orbs by mixing, but I am way short on orbs. I tried different combinations already, even on the side areas, but no go. I assume you need all of them to get this place open? I would have thought an orb would activate one of the side chests at least...).

 

Well, that's where I am. This is a great scenario, but I am carrying way, way too many things. And the storage unit is so out of the way. Keys to carry, orbs, reagents, notes, etc... While I was stuck I managed to create a brand-new party, while getting my old party's equipment (that was a tedious transfer without the editor!), and building them up with loads of money and easy fights (neph cave near Grimly's old fort) and all the places i can buy skills... I sometimes think this scenario makes it too easy to create a 'god party'...

 

Again, thanks for your help!!! smile

m

Link to comment
Share on other sites

Yet to finish are:

 

* Viagra: After you obtain an Essence Crystal for Frank Twinsen, the Casino Guard in Liberty, to get a Key to the Magestica Prison that you need, he happens to mention the phrase, “Black Market”. When you ask him about it, he will send you to Harold at 05, 20 in Liberty; who sends you to Helveticus at 06, 05 in Magestica, L2; who sends you to Marlow at Riddenport, who sends you to Quentin in the Residential Area of Zenith, who sends you to Tess, also in Zenith but in the Business District, who sells the infamous Viagra pills. You’ll get a large, green pill for 500 gold.

Link to comment
Share on other sites

Yet to finish are:

 

* Priest Spells, Level 7 (scattered around):

** In Zenith, Residential Area, Brother Thomas: Give him the 1,000 gold pieces you found in the Donation Box and he will 'reward' you by instructing your Party in Spell Casting. This will raise your entire Party's Priest Spell Ability by 1 point.

** When in the Priest's Guild you can learn Level 4, 5 & 6 Spells.

I'm sure you know this already, but I was just saying...

 

*Pelzbaraii:

08, 15: Tome on a Pedestal: 'Revive All'

*Pelzbaraii South:

07, 04: Tome on a Pedestal: 'Ravage Spirit'

*Dhurnhold:

42, 40: Store, 47, 46: Chest, Scroll: 'Resurrect'

*Hanod:

Library: 59, 52: Tome on a Pedestal: 'Divine Thud'.

Shop: 59, 24: Split Party to cross a Floor Plate to get to 59, 30: Tome on a Pedestal: 'Mass Paralysis'

Bank of Hanod: 20, 14: Chest: Scroll, 'Word of Recall'

*Balinport:

57, 32: Weak Wall to 56, 34: Bookcase: 'Wall of Blades'.

Library, Main Floor: 16.42: Tome on a Pedestal: 'Avatar'

Link to comment
Share on other sites

Hello, Ahbleza!

 

You are amazingly quick and helpful!

 

1) 'Viagra' -- well, I had already found the 'black market' chain of people but haven't bothered to trace each down because the price they offer for some items are so derisory I didn't bother. That solves that one, thanks!

 

2) Scavenger hunt -- all I needed was that 'ruby' clue. I finished it pretty quickly after that. Thanks!

 

3) Priest spell -- I was already level 7 with all the spells, but after Lucivius removed a level I need to gain it back quick. I knew it was Thomas I needed to speak to but couldn't get the dialogue to the right area. I like this scenario a lot, but there are a few dialogue holes (like with the alchemy set).

 

4) Under San MOrbis -- yes, I got all 3, but I haven't been back since I got the laser. That makes sense. I'll go back now.

 

Thank you so much again! I'll get these done and then have to figure out what's left do do after all this!

 

Thanks!!!

m

Link to comment
Share on other sites

Hi again,

 

Quick update (yeah, lounging this Saturday away playing BoE on the laptop...). Got the 'Vigara' thing done. Priest spell I had already returned the donation earlier, so now I gotta get a skill potion to get it back up via a trainer. Headache.

 

I am now at the pentagram in the demon cave and despite laying out all the reagents there is failure time after time. I found several combinations that fits the description, so this is another one of those 'annoying' bits. Did I miss something really dumb?

 

 

BP BP

 

M SA BM M

 

 

BM N N SA

 

 

These 2 plus a few others all match the 5 conditions on the description from the book. I tried them all. I even inverted the pentagram and followed the conditions. No go.

 

Sometimes it's frustrating when things move so quickly, to be undone by what seems like a dead end...

 

Maybe it's time to take a break and enjoy the last of the sun...

 

Thanks again!

m

Link to comment
Share on other sites

I know I get a bit 'chatty', so please forgive me for a little here.

I joined BoE in '04 as a retiree and, although I'm not much of a Player, I wanted to keep my hands and mind busy, so I began writing Walk-Throughs and documenting Items as a "Hobby".

I originally wanted to give them away to be posted, but some of the Scenarios have information that is and should be, for lack of a better term, "Censored" and what I feel should NOT be released. You'd have to play several of the Serial Scenarios to understand what I mean.

Since I'm still making them, am still alive and kicking, and have accumulated a lot of information on numerous Scenarios, I expect to keep watching this Forum for a lot of years to come.

Most anyone who has the desire can now learn the Updated Scenario Editor. There are several knowledgeable people who have done some absolutely wonderful work with the Open Source Code and made my Hobby much easier. Others can learn to do things like this rather easy, too.

FWIW, check the next post.

me

Link to comment
Share on other sites

m

I not only make Walk-Throughs and *.bmp images of things in a Scenario, but often make an Appendix if a Scenario has a lot of Side Quests, etc. The following is a list of the Titles of the Side Quests in the Appendix for AC-3, Retribution. Use it to see what you have/have not completed and give a whistle if I can be of any more assistance.

me

 

Appendix for:

The Adventurers’ Club,

Volume Three

Retribution

 

This Scenario:

This Scenario, even more so than each of its predecessors, is particularly long and complex. The Author has put a LOT of work into this Scenario, with not only a multitude of his own Graphics, but into the interweaving of events that require the Player to take this Scenario much more seriously than one might expect. Not only is the main Story Line long and complex, but the Author has included a great number and a great variety of ‘Side Quests’ for the Player.

Generally, the Author has introduced each Quest as the Story Line unfolds. These Quests may require a Special Item, or Circumstance, to accomplish. Once the Party learns of the Quest and acquires the Item or Circumstance, the Quests may be done at any time convenient to the Story Line. There are several Geographical Areas in this Scenario and many Quests, so the Player might choose to wait until they are in the proper area to deal with a particular Quest. With that in mind, there are a great many ways to actually play the Scenario.

° ☼ Tonwéya ☼ °

wicá wa máni ishná

1.) Taking Homer home:

2.) Underground Caverns; or Combat Training Area:

3.) The Chicken Killer:

4.) The Golden Unicorn:

5.) The Lost Boys:

6.) Little Brown Pups:

7.) Guild Quests:

7A.) Alchemists’ Guild Quest; or Potion of Light:

7A1.) There are five Pages to the Recipe Book stolen by Hobblings:

7B.) Fighters’ Guild Quest; or the Cutthroat Commune:

7C.) Mages’ Guild Quest; or Looking for Lucinda:

7C1.) Familiar Creation:

7C2.) Dead Man's Poppy:

7D.) Priests’ Guild Quest; or the Holy Goblet:

7E.) Thieves' Guild Quest; or Unstealing the Statue:

8.) Owaji Championship:

9.) Memories of a Murder:

10.) Search for “A Little Girl”:

11.) Quest for Viagra:

11A.) Black Market:

12.) The Field Trip:

13.) Hydra Egg Noodle Soup:

14.) Prof. Marvelus' Traveling Chest:

15.) Three Heads Are Better Than One:

16.) The Greenball Express:

16A.) A New Sanctuary… Untamed Region:

17.) Gumbies Make Good Scarecrows:

17A.) Grandfather's Secret Stash:

18.) The Lost Treasure of Magus Bagarnis III:

19.) Burrower Beast Infestation:

20.) Quintus Finds Religion.

21.) Virgil’s Tower.

22.) Uncle Shamus is missing.

23.) A Demon Down Under; San Mortis.

24.) Monster in the Lake; Lake Venom.

25) Poppin’ Fresh Doughboys.

26.) When Treasure Chests Attack.

27.) The ‘Press Your Luck’ Show.

28.) The Scavenger Hunt:

29.) Miscellaneous Items of Interest

30.) Specialized Trainers and Augmenters:

30A.) Trainers:

30b.) Augmenters:

Link to comment
Share on other sites

23.) A Demon Down Under; San Mortis.

In the tunnels that lead to San Mortis, there is an opening, (U-22, 41), that leads to two Levels of Caverns.

Work your way around Level 1 you find an opening at 06, 31 which leads to Level 2.

Work your way through Level 2, crossing the crevasse using the mini-graviton. At 34, 41 you see a small pool of water formed by a crack in the ceiling above.

Return to Level 1 and find a small pool of water at 22, 07. Freeze it with the ‘Wand of Refrigeration’ to cross it. There is another large pool of water at 27, 31.

Return to Level 2 to 34, 41 where you see water dripping from a crack in the ceiling above. Use the Laser you received from Quintus to blast a hole in the ceiling above and a torrent of water comes down.

Return to Level 1 and the large pool of water is drained for you to walk across the area. Follow a path on the other side to an opening at 55, 29.

Work your way through Level 2 to an opening at 58, 54.

Now that you are in the Demon’s Furnace, work your way to the southeast section where you find an area in the shape of a Pentagram, or Star with a Red Altar in the Center and Braziers at each of the five points of the Star. Go to the Altar and ‘Look’ at it. The Scenario will ask if you want to read the book, “Demonology 101”. It will tell you where to place the Alchemical Ingredients in the Braziers They are as follows: Mandrake at the top and then, going clockwise, Blood Moss, Nightshade, Sulfurous Ash, and Black Pearl.

 

46, 41: Mandrake

39, 46: Black Pearl

3, 46: Blood Moss

40, 53: Sulfurous Ash

52, 55: Nightshade.

 

Once this is done, return to the Altar and ‘Look’ at it. You will have summoned a Cacodemon and he will summon Lesser Demons. Concentrate all your fighting with the Cacodemon only. When you defeat it, all the others will disappear.

With the Cacodemon destroyed, you can now access the area behind 26&26, 45. There are two chests there. One has a Ruby Sword and the other has a Red Orb.

Link to comment
Share on other sites

Hi again,

 

No worries, happy to be chatty, that's what these forums are for, right?

 

Thank you for the demon solution. One thing that ticks me off a little about this puzzle is that frankly, there are several 'correct' solutions for the puzzle. It would have been ridiculously tedious to play through each combination to find this 'correct' one out of all the other 'correct' combinations!

 

For some reason the barriers to Lucivius's castle disappeared after I did this puzzle, and for some reason when I tried opening the summoning room door it had Tiberius answer? Huh? How did that happen? Bug in the game?

 

In any case, playing the floor buttons thing is a nightmare. I figured out the combination via the 3 runes (using the color code in the bookshelf). But I went both clockwise and counter-clockwise and it has done nothing. It's really annoying to not have a clue, even sound-wise, to see whether you are on the right track, and how to 'reset' the puzzle if you miss one.

 

It is this kind of tedium that gets me to not work on the puzzle myself but to ask for hints! frown

 

Anyway, I'm at the end, I think I've finished all the side quests (including the orbs to get the 'big' weapon, the 'elemental slayer'...which is quite useless, really). But this floor button thing is trying my patience...

 

Maybe it's sitting in the sun for the afternoon that got me irritated...who knows!

 

Thanks again for all your help!

m

Link to comment
Share on other sites

m

If you mean the four buttons in the T'Lanhg Hideout, this is the location of the four buttons and the order they must be pressed:

37, 04: Button 1.

37, 07: Button 2.

37, 13: Button 3.

37, 16: Button 4.

37, 10: Secret Passage opened by pressing buttons in proper order.

Push, step on, these buttons in this order: 1-4-2-3. The Secret Passage will open.

 

My 'Walk-Through' doesn't include the actions and consequences of the Nodes in the Games, so I can't tell you specifically what dropped the Barriers to Lucivius' castle. I'll take a closer look at the Walk-Through in the hope of remembering something, but for now I'll post this to get you past the buttons.

me

Link to comment
Share on other sites

Hi, sorry for delay. No, I meant back to Lucivius's castle. For some reason I used another party and had to fight the 4 sets of guardians on each barrier. I did find a bug that somehow had the barriers all de-activated and no guardians to fight...but that's another matter.

 

Lucivius's castle, to get the key gate to open is a nightmare. I've been through the T'Langh thing awhile back. This is the end, trying to get to the summoning chamber.

 

Thanks,

m

Link to comment
Share on other sites

There really is no delay; these things do take time and this Scenario, probably as much as most, takes a long time to accomplish. It sounds like you're doing just fine, stay with it.

I took a look 'inside' the Scenario and from what I can see...

After supper, go to your Room and go to sleep.

The next day, after breakfast, you will all go to a Gravesite. After you are done at the Gravesite for Gunther the Door for Sister Elysia's Room becomes unlocked and the Barriers to the Summoning Room are gone.

Well, that's the way it looks and how it reads in my Walk-Through.

me

Link to comment
Share on other sites

Hi there,

 

That seems to be between 2 different event nodes...

 

The first time you visit Lucivius's castle you go to sleep and go to Gunther's grave and talk and all. Then you get to the point of teleporting to that whole meeting on that island that you escape from (the one you helped me with at the beginning of this whole chat).

 

I now have fought back into Lucivius's castle, past the barriers and killed the earth elementals. I am trying to unlock the gate inside Lucivius's bedroom by stepping on the buttons in the towers -- and that's where it is not working. I have the right tower combination and so forth but it is a no go. Am frustrated because it is slow to run through all the towers each time.

 

So that's where I am stuck. Once I get that gate open I can get the key to the summoning room, and then I assume is the final battle for the scenario...oh, so close and...

 

Thanks!

m

Link to comment
Share on other sites

m

Sorry for the size of these answers, but as in this case they are all pretty much copied from my 'Walk-Through'.

Talk to Sister Elysia...

Ask “Locked”, or “Room”. She says, “All I know is that to open the locked gate to get the key, you need to know the correct combination. There are three runes that you need to discover the solution.”

Ask, “Runes”. She says, “They are hidden throughout the castle. One time, I caught him placing a rune in one of the potted plants. Maybe that's where he's hidden all three.”

(* edit. To solve this Puzzle; to access the Summoning Room and Lucivius, you need to gain access to his Room. Find the three Runes hidden in Potted Plants.)

39, 23: Potted Plant. Look. Just below the surface of the dirt, you find a blue rune. The number, ‘276’ is engraved on the surface of the rune.

33, 30: Potted Plant. Look. Just below the surface of the dirt, you find a yellow rune. The number, ‘941’ is engraved on the surface of the rune.

13, 11: Potted Plant. Look. Just below the surface of the dirt, you find a red rune. The number, ‘358’ is engraved on the surface of the rune.

(* edit. And, in case you either forgot, or hadn’t yet been in the Library…)

36, 23: Door to the Library.

38, 27: Bookshelf. Look. The books on this shelf are all the same. They are all old, leather bound volumes of historical references and the like. Very dull reading. But three books grouped together stand out from the rest. Their covers are brightly colored. The first one is blue. The second is yellow. And the third is red. You attempt to take one, but find they are glued to the shelf. Very strange.

(* edit. You now have all the information you need to solve this Puzzle. First, Sister Elysia told you the Spare Key to the Summoning Room was,” locked away in his room”. Second, Sister Elysia also told you that, “there are three runes you need to discover the ‘correct combination’. Third, Ethel told you that Lucivius has the extra key locked away and that it has, “something to do with Buttons in the Guard Towers”. Fourth, Ethel also told you that the Guard Towers are, “numbered one through nine, going clockwise” and that, “the first tower is the southern one at the entrance to the courtyard”. Lastly, the three books in the Library are in a ‘fixed’ position so the color sequence will remain constant. Putting all these clues together you realize that to unlock the Gate to Lucivius’ Room, you need to push the Buttons in the Guard Towers in the sequence indicated by the three Runes in the proper Color Order; Blue = 276, Yellow = 941, and Red = 358. That was the easy part. The difficult part is that there are Elementals in all the Guard Towers.)

Hopefully, this should do it. ;^}

me

Link to comment
Share on other sites

Hi there,

 

I had already done all that, in that specific order. Elementals weren't bad to deal with if you can lure them out between the door. But I have tried it the correct order several times to no avail, even re-loading games and so forth. And still no go.

 

Do I step on the spots or do I have to do something to activate them? Or am I missing something totally?

 

I'm just about to give up on this game. Shame, considering how good it was.

 

Nevertheless, thanks for your help, as always.

m

Link to comment
Share on other sites

Assuming that you have, indeed, cleared out all nine of the Towers, this is what is next...

 

(* edit. Now go back and do the rest of the Buttons in the proper sequence.)

(* edit. In each of the appropriate Towers, Get the Rugs to expose the Buttons. Then Look at the Buttons.)

Tower # 2; 32, 60: Rug. Get. Button is exposed. Look. There is a large button here waiting to be pressed. Do you? Yes or No? ‘Click’.

Tower # 7; 33, 08: Rug. Get. Button is exposed. Look. There is a large button here waiting to be pressed. Do you? Yes or No? ‘Click’.

Tower # 6; 23, 09: Rug. Get. Button is exposed. Look. There is a large button here waiting to be pressed. Do you? Yes or No? ‘Click’.

Tower # 9; 55, 52: Rug. Get. Button is exposed. Look. There is a large button here waiting to be pressed. Do you? Yes or No? ‘Click’.

Tower # 4; 10, 33: Rug. Get. Button is exposed. Look. There is a large button here waiting to be pressed. Do you? Yes or No? ‘Click’.

Tower # 1; 54, 61: Rug. Get. Button is exposed. Look. There is a large button here waiting to be pressed. Do you? Yes or No? ‘Click’.

Tower # 3; 23, 47: Rug. Get. Button is exposed. Look. There is a large button here waiting to be pressed. Do you? Yes or No? ‘Click’.

Tower # 5; 10, 09: Rug. Get. Button is exposed. Look. There is a large button here waiting to be pressed. Do you? Yes or No? ‘Click’.

Tower # 8; 48, 19: Rug. Get. Button is exposed. Look. There is a large button here waiting to be pressed. Do you? Yes or No? ‘Click’.

(* edit. That should have unlocked Lucivius’ Room.)

 

41, 23: Door to ‘The Master’s Bed Chamber’.

46, 28: Door from the Bedroom to a Closet.

44, 30: Chest. Look. You think you’ve found a trap. Do you try to disarm it? Yes or Leave?

Inside this chest is a large, black key. You take it and place it in your pack.

 

41, 30: Door from the Bedroom to a Foyer.

40&42, 34: Doors to the ‘Summoning Chamber. You use the black key you found in the chest, and the door opens right up.

 

Enter the Room and you will encounter Lucivius.

 

May I suggest that one simply does not "give up". You can shelve the game for a while and then come back to it once your mind clears. Having come so far, it seems a waste to have tried in the first place and I don't think anyone wants to wear that collar.

I'm not much of a "Gamer", per se, but find my "puzzles" in the research and documentation. It took me several years and more than a little help from strategic members of this community.

One of my "standards" is that there is always an alternative; always. The problem is that I usually have one heck of a time seeing it. ;^{

There is a bit more here to accomplish, but you're pretty close to completing it. Have at it!

me

Link to comment
Share on other sites

Hi,

 

Thanks. All I needed to find out was that I actually have to take the damn carpets and that activates the buttons. I thought you just had to walk over the proper ones. It's these little illogical things that sometimes drive me nuts.

 

I guess I can finish the game now.

 

Thank you for all your help.

m

Link to comment
Share on other sites

Have you played either AC1 & AC2? If not, that's what the conclusion of the Scavenger Hunt referenced.

When I first started playing these Games, like many others have done, I went straight for the most highly recommended, and was in "over my head". Also, I didn't realize that many are sequential. That is really important if you're interested in the actual Story-Line.

Because I'm not much of a Player, I quickly learned to look for sequential Scenarios and enjoy them much more for what and why they were created, rather than just 'beating' them.

If you haven't yet played many of the other Scenarios, may I strongly recommend the ones known as, "The Arc" by Alcritas and the three by Drizzt.

There are eight by Alcritas and three by Drizzt. All have an over-all Theme, or Story-Line and, although they are a bit difficult at times, they are really worth the effort.

There are other really good Scenarios out there too, but I think you would enjoy these two groups.

(Besides, I have a complete Walk-Through for all of them.) ;^}

B well,

me

Link to comment
Share on other sites

Hi, I had played some of AC1 but some of it bored me so I quit. I usually don't like scenarios that I can't use my normal party, or have nodework that 'destroys' things in my inventory due to BoE limitations on dropped items. I didn't create a 'god party' and I like playing with the party I developed over time.

 

In any case I have played many of the scenarios you talked about and got through them pretty smoothly.

 

Thanks again for your help. I'll finish this one this coming weekend when things quiet down here a bit.

 

m

Link to comment
Share on other sites

Like many 'newbies' I started on the highest rated scenarios and soon found myself in over my head; AC-3 was one of them. I left it and restarted with several easier scenarios and worked my way up.

I made my way through AC-1 in a bit of a clumsy manner and then went back to re-play it and did all right. I had been working on the Walk-Throughs by then and they became more important than the Games themselves.

I didn't enjoy AC-2 at all because it was mostly difficult puzzles with a simple background Story-Line. It did, however, set the stage for AC-3.

When I went back to AC-3 it became a lot more enjoyable because I had a better understanding of how these Games are supposed to work.

Because I'm more interested in the Walk-Throughs, I admittedly 'cheat' when needed, but usually make it through a Game first and then return to figure out what I missed.

I don't much enjoy the endless slaughter nor the endless difficult puzzles, but feel that there have been some literary masterpieces 'out there' and, in truth, am really just looking for them. ;^}

Glad to have been of some help and hope you continue to enjoy these side trips from the 'real world'.

me

Link to comment
Share on other sites

Hi there,

 

Thanks again. Over the many years (on-and-off) of playing Blades I've managed to finish most of the scenarios made during its heyday. I need to try some of the newer ones.

 

The only three of those I never finished (major ones) are (1) Destiny of the Spheres (the 'thirst' thing drove me nuts as I am one of those people who love to explore the entire map); (2) Revenge (for some reason -- not from fatigue -- my party dies 2/3 of the way through walking outside, like some other clock has expired...I just gave up as I thought I was doing everything right) ; and (3) Doom Moon II (I just cannot get it going with that impossible combat to start).

 

Let's see which one I will play next...maybe the Za Khazi Edit for the hell of it or maybe Staff of Kayolith or Heirs to Theseus. We'll see...

 

Thanks again!

m

Link to comment
Share on other sites

Heirs is pretty basic and not all that difficult. The idea is that you have a fixed amount of equipment to deal with three battles. If you're conservative, you'll go right through it.

Kayolith is a whole different matter. The deeper you go underground, there's more of a draining effect on you.

I did the original Doom Moon and it was all right. I wasn't nuts about the pistol, but once you're into the game, you continue on.

The others I haven't played.

I've made a 'fair' collection of Walk-Throughs, but there are a LOT of Scenarios to be played and they take a long time to document, much less to play.

Of the ones you mentioned, I'd strongly recommend Kayolith. It's difficult, but adds a lot to the historical background of Al's Scenarios.

Have at 'em,

me

Link to comment
Share on other sites

  • 2 weeks later...

I finished Kayolith pretty quickly, it's not much of a challenge (except to find the hidden passage past the rockslides). Combats are not that hard either. Have not bothered with Heirs yet.

 

The one I'll get to one day is Doom Moon 2 once I figure out how to get out of the first combat (I finished Doom Moon...yeah, not thrilled with pistols, but that flamethrower was darn nice...).

 

m

Link to comment
Share on other sites

  • 2 weeks later...

I don't understand Doom Moon 2. Are you supposed to escape that fight or are you supposed to die? I found the weak area in the gate, blasted it, but I wasn't allowed to leave the cave thing place. So as a result, I made a sword that does 4,000 damage and gives 20 protection. I found that even though you kill a dragon, they still cast spells. After you kill all of them, still nothing happens. frown

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...