Jump to content


Avernum 3 on Mac OS 10.10.5 (Yosemite)


  • Please log in to reply
3 replies to this topic
Jol Jol

New Arrival

  • Member
    • Member ID: 17,579
  • 2 posts

Posted 12 October 2015 - 06:59 PM #1 Avernum 3 on Mac OS 10.10.5 (Yosemite)

I just finished A:ETP and A2:CS on my tablet, and have been hankering to dive into A3 again. Unfortunately, none of the copies I've tried (CDs purchased years ago, Gog.com downloads (for A3-6 - but A1 & A2 work, score!), and unofficial wineskin versions) are working for me. (Not even digging out the old laptop with 10.5.8!)

Is there a version out there that will work with Yosemite or do I need to get that copy of Windows I've been seriously considering to fire up Bootcamp? (Because I will, A3 was my favorite and I will go to those lengths to play it again.) And if I do go the Bootcamp route, which Windows OS is the best? (Last I looked 7, 8, and 10 were available.)

Thanks!

Tyranicus Tyranicus

Dollop of Whipped Cream

  • Member
    • Member ID: 4,151
  • 4,537 posts
  • LocationShadowvale

Posted 13 October 2015 - 06:43 AM #2 Avernum 3 on Mac OS 10.10.5 (Yosemite)

I'm not sure why neither the GOG nor my Wineskin versions don't work for you. They work for me in Yosemite. If you have access to a machine running 10.5.8 though, the version available on Spiderweb's site should work. If you do end up going the Windows route, you won't need Boot Camp just to play Avernum 3. You can use VirtualBox, which will let you make a virtual machine of a Windows PC (like an emulator). I'd recommend using Windows XP with that, if you can get a hold of a copy, since it is less resource-intensive than later versions and can run Avernum 3 without setting any compatibility settings.
"There are less fortunate people out there who can't sit in a chatroom and complain about privilege. You should check your privilege-checking privilege." —Dintiradan
BoA Scenario DatabaseSpiderweb Music DatabaseNethergate Graphics RewindAvernum Side Quest ListExile & Avernum for Intel Macs

Edgwyn Edgwyn

Avernite Dervish

  • Member
    • Member ID: 10,154
  • 741 posts
  • LocationHome

Posted 13 October 2015 - 06:18 PM #3 Avernum 3 on Mac OS 10.10.5 (Yosemite)

I just opened A3 on my laptop with OS X Yosemite (10.10.5) and it seemed to be working fine.  I think that the problem may be with your copy

Jol Jol

New Arrival

  • Member
    • Member ID: 17,579
  • 2 posts

Posted 21 October 2015 - 08:22 PM #4 Avernum 3 on Mac OS 10.10.5 (Yosemite)

Thanks for the info and advice. I tried redownloading A3 from GOG and it worked the first time I tried it - though it crashed when I went to save and didn't work when I tried re-opening after that. The GOG Galaxy app shows all but A1, A2 & A4 as incompatible for some reason. I went the VirtualBox with XP route instead and everything seems to be working!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users