Jump to content

Crashes under Wine (apparently sound related)


Prince of Kitties
 Share

Recommended Posts

With sound enabled I've always had crashes and freezes, but with recent versions of Wine and/or Classic BoE they've been getting more frequent.

 

When running Classic BoE from a terminal (using 'wine start /unix "Blades of Exile.exe"') I get a lot of

 

Code:
err:alsa:wine_snd_pcm_recover underrun occurred

 

Apparently every time a sound is played. This is apparently not fatal though. What I get in the event of an actual crash is something like this:

 

Code:
err:ntdll:RtlpWaitForCriticalSection section 0x7e677a90 "winmm.c: WINMM_cs" wait timed out in thread 04be, blocked by 001a, retrying (60 sec)

 

Is this a Wine bug, or a bug in Classic BoE? Has anyone seen something like this on Windows, with the game freezing when a sound should be played?

Link to comment
Share on other sites

ALSA (referenced in the first error message) is one of many sound softwares linux can use to play audio. It's been awhile since I've used Wine, but look for an option to change your audio to pulse, oss, or jack (if you have them). If that doesn't work, turning off sound should clear up those messages.

 

The second error is probably a Wine error; there's no winmm.c in the OBoE repository. Try running under a different Wine mode (in the Wine prefs, there's switches to emulate different OSes, try going to an older one).

 

While we're at it, what versions of Wine/ALSA are you using, and what distro?

 

Edit: It appears WinMM is actually a Windows sound driver. This page may be of some use. Also, you could try something like what this guy is trying to do.

Link to comment
Share on other sites

  • 2 months later...

FWIW, I've found a workaround: enable the "Fewer sounds" option (which is already indicated for crashiness). This seems to prevent the crashes, and as a bonus makes gameplay faster, because unnecessary sounds (like footsteps) aren't played.

 

Only problem is the option doesn't seem to be saved properly, so it has to be set again every time the party is loaded.

 

Edit: Wait, it is being saved, N/M. But it doesn't prevent all crashes. Better to just play with the sound off I guess.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...