Jump to content

Recommended Posts

I have reached a room with five teleporters. 

The central one takes me back to the stairs where I entered the lower level of the Tower of Zkal. 

The other four all throw me back (I stay in the same room) and make me feel disoriented, no matter how many times I try and enter them. 

How do I progress?

Share this post


Link to post
Share on other sites

The old Avernum 3 walkthrough mentions

"Enter the northeast portal. Go through the same portal again. Now take a journey into the southeast portal, then the northeast portal once more."
 

If you follow it, I managed to progress even though all it did in the remake is throw me back in the same room like you said.

Edited by ultra blue4

Share this post


Link to post
Share on other sites

Yeah, the north east of that portal room in the lower level. If it doesnt work, maybe go back to the ground floor and back down to reset? I know I followed what I wrote and went through just fine?

Share this post


Link to post
Share on other sites

Okay I get it:-

  1. Try and enter NE portal, get thrown back and disoriented. 
  2. Try again to enter NE portal, get thrown back and disoriented. 
  3. Try and enter SE portal, get thrown back and disoriented. 
  4. Try and enter NE portal, and you are teleported to a new location in the lower level of the Tower of Zkal. 

Many thanks for your help! 

Share this post


Link to post
Share on other sites

That's a better way of wording it. That tower was tough for me even though I played a lot of Avernum 3 back in the day and had the walkthrough. It had a confusing vibe to it for me. 

Share this post


Link to post
Share on other sites
  • I have tried the sequence and it doesn't work. I've gone back to the main floor hoping to reset, and it still doesn't work. I'm stuck. The only thing I'm wondering about is that I found the tower while exploring the island. I've never talked to the Mage with No Name. I hope I don't have to find him and do this all again.
  • I went back and talked to the Mage and then everything worked. I don't know exactly what did the trick, but it worked.
Edited by Faithful Hand

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...