Jump to content

Running the games on Intel Macs?


vorpal

Recommended Posts

Hi all,

 

I wonder if any of you have had any luck getting any of the SpiderWeb games to run on the new Intel Macs? I know that classic games won't run on these machines, but I figured that games in Carbon like the Avernum and Geneforge ones should be fine as they can execute through Rosetta.

 

Anyways, I was really dismayed this morning when I pulled out my new and shiny Geneforge 2 CD, tried to install it (which went fine), and then double clicked on the game, only to have it open in TextEdit as a bunch of binary garbage! Same thing for Blades of Avernum. Avernum 4 was the only one that worked okay.

 

Any ideas if this is fixable, or if Jeff has any plans to make these games playable? I just shelled out $55 for the Geneforge trilogy, had my PowerBook die just after I finished the first game, and now I might not even be able to play the other two frown .

Link to comment
Share on other sites

Get Info on the application and look under the Open With choices. I've occasionally had my computer decide that various Spiderweb offerings would be best treated as documents, but the application itself remains one of the choices for opening.

 

—Alorael, who also has seen the applications' icons go through a number of fascinating permutations. They particularly want to be Sibelius documents.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...