Jump to content

Avadon 1 -- any way to remove quests?


Recommended Posts

I already tried talking to Jenell back at Avadon, and the quest is still there. I also tried talking to Runner Faiga, and went looking for Vid, but he and his band were gone. I combed through Jarlswood and went through both of the buildings again with Jenell, but I just can't get this quest to finally clear. It's driving me a little bonkers, haha. How would I go about finding the quest number and using a script?

Link to comment
Share on other sites

Hello Alfaerin,


I think you might be slightly misunderstanding the issue you’re experiencing with your quest list! From what I can make out, you might have gone through the Jarlswood quests in a slightly unusual order, and I think that might be causing ‘Jennel’s Message’ to remain in your quest list.


‘Jenell’s Message’ is actually only loosely connected to the issues in Jarlswood. It’s a tiny quest, one that's designed just to lead you into the larger Jarlswood quest. For reference, this bigger quest is listed in the quest log as ‘Jennel’s Ideals’, and it’s that quest that involves dealing with the Shaman.


Jennel’s Message is actually a really simple quest. If you speak to Polus after Jenell has left Avadon for Jarlswood, he’ll mention that a message has been left for you in Jenell’s quarters – and the quest appears on your quest list. All you need to do to finish the quest is to just head over to those quarters. You’ll read the message, and the quest will clear. You’ll then be told where Jenell has gone, leading you to the first step on the road to completing the larger Jarlswood quest. It’s that simple!


Of course, if you guess where Jenell has gone, you can head straight to Khemeria without reading the message. I’m guessing that’s what you did? However, if you don’t deal with the message before finding Jenell in Khemeria, there’s no way to read it later. Unfortunately, that leads to the quest being suck in your quest log. After all, there’s no reason to go hunting for the message after you’ve already dealt with Jenell’s problems!


Still, there’s no need to worry. I have a fix for you, and it doesn’t involve script editing. (As a general rule, script editing is very powerful, but also comes with an element of risk. If you’re not careful, it can have unexpected results – so you should only edit the scripts if you’re confident you know what’s going on!)


Here’s how you can fix this issue without resorting to script editing! First, make a backup copy of your save file in a different slot – this is just to make sure that you can get back to your original save should anything go wrong. Now, use one of the portals to travel somewhere that isn’t Avadon. This is to make sure that everything loads correctly in Avadon itself. When you’re safely out of Avadon, hold down shift and press ‘d’. A little input box should appear your screen. In this box, type the following, exactly as it’s shown here:


sdf 1 61 0


Click the green tick. Hold down shift and press ‘d’ to open the input box again, and enter this:


sdf 100 3 2


Click the green tick again. Everything’s now primed for you! Teleport back to Avadon, and head to Jenell’s quarters. With luck, you’ll be able to read her message. This should clear the quest for you!


However, you’re not quite done yet. You’ve altered the state of your game, and you need to restore it! Head out of Avadon again. When you’re elsewhere, hold down shift and press ‘d’ again. You’ll need to enter a new code, but this depends on how you approached the mission in Jarlswood. Do you remember a situation in Jarlswood where you were given the option to spare some soldiers by letting them walk away? If you spared the soldiers, enter the following:


sdf 100 3 3


However, if you killed the warriors instead, enter this:


sdf 100 3 4


This is an important distinction, one that will become apparent a little later in the game!


Once you’ve done all this, ‘Jenell’s Message’ should have been removed from your quest list, and the original state of your game should have been restored! Of course, if something goes wrong along the way, and the quest doesn’t clear for some reason, do let me know. I might be able to come up with a slightly different workaround if this one doesn’t work for you!


Otherwise, welcome to the forums! It’s always good to see people coming here who enjoy the Avadon series!

Link to comment
Share on other sites

Thank you so much for taking the time to write that out, Ess-Eschas! Your solution worked perfectly! I think you're right that I went straight to Khemeria and that's what caused the problem. Thank you for the help, and the kind welcome ^_^ I bought and played all the Exile games waaay back when, then recently got a hankering to play them again. So I picked up the big SW bundle on Steam, binged Avernum 1-6, and now I'm working on the Avadon series.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...