Jump to content

Avernum: Escape from the Pit - Graphics Glitch


Recommended Posts

I just loaded up a new game of Avernum: EftP. As soon as the game starts, the graphics are glitchy: every few seconds a random tile will "light up" by displaying a grey or black square. It's a bit as if those ground tiles were flickering. I've tried changing the game area and resolution, that did not help.


I never had problems with Avernum on my machine before. I've had to change out the graphics card about two years ago, however, and I guess I haven't played it since then. I own the game on Steam, I'm running Windows 7 Home Premium (Service Pack 1). My graphics setup is as follows: ASUS VS228 flatscreen, NVIDIA GeForce GTX 1050 graphics card (current drivers), Intel Core i5-2400 3.10 GHz CPU.


I'd appreciate it a lot if somebody could help me. I'll be happy to offer more info if needed.


EDIT: After fiddling around, I found out that "Play game in window" from the start-up options screen seems to remove the flickering. How do I go about achieving that in fullscreen mode?

Edited by JFS
Link to comment
Share on other sites

Hello JFS,


Unfortunately, I can't offer you any direct help on this problem – I'm a Mac user, so this isn't an issue I can test out myself. However, since the forum has been a little quiet on this point, I thought I'd offer you a suggestion.


Have you tried sending a quick email to Spiderweb's support address? Spiderweb is usually very prompt at offering helpful answers to questions like these. In particular, the company has put a fair amount of thought into how their graphics are displayed – if anyone knows a solution, it will be them! Here's the address, should you need it:




Good luck! I hope you manage to find a solution that lets you play in full screen without the flickering. If you do, let us know here how you managed it!

Link to comment
Share on other sites

Hello, I'm a Windows programmer.
Tiles "lighting up", as you describe it, sounds like Avernum isn't buffering its frames correctly.
Since playing in a window seems to resolve the issue, try playing in fullscreen mode with a lower resolution setting.
Also, are you playing on a monitor with a refresh rate higher than 60hz? If so, try playing on a different monitor.
I would also be interested in the in-game frames per second; run Avernum, load a game and press shift-D. Then type "fps".

Edited by Unbound Servile
Link to comment
Share on other sites

  • 3 weeks later...

Thank you very much for your replies, and sorry for me not getting back faster.


I have not yet sent a mail to Spiderweb, thank you for the suggestion. Playing in fullscreen with a lower resolution does not help, at least not at the resolutions I've tried. Another monitor is unfortunately no option. FPS ranges between 24 and 61, but generally revolves around 50-55.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...