Jump to content

Blades of Avernum fails to start


Thralni

Recommended Posts

Hey all,

 

Problem with BoA here. I'm on macOS 10.12.5. BoA fails to start properly. Downloaded twice now, opened the dmg and moves BoA's folder to Applications. macOS complains Spiderweb is not an "identified developer", so I go into the System Preferences to allow it to open anyway. The BoA icon appears for perhaps half a second on the dock, doing it's bouncy animation, then disappears and never comes back. On second try, BoA's icon doesn't even appear on the dock anymore - it's like I didn't even try to start it. Any ideas?

 

Link to post
Share on other sites

Without having actually having checked back to this thread, I did exactly what Slarty suggested. I bought the GOG.com version. That version worked instantly but claimed to be 'unregistered', even though GOG.com claims to sell games without DRM. After some fussing about I managed to get it working and it is registered. So, indirectly, thanks for the suggestion Slarty! (Is that still how you are referred to, by the way?)

 

I entered WtRM, to have a look at some of the things Chessrook44 mentioned in one of his video, but was immediately greeted by an error that some custom graphics that I had put into the scenario couldn't be loaded... I guess I'm not out of the woods yet, but getting closer at least!

Link to post
Share on other sites

Another update. It does seem to work fine. The problem with the graphics is local, on the level of the scenarios themselves. So far, every scenario I have downloaded from the BoA scenario database has given me errors trying to open the .cmg file. The .cmg files I have on my computer from my own scenarios still work fine, however. These were, however, never zipped. Given that .cmg files are ancient, I'm guessing they are not used anymore by modern Macs, so that extracting them from their zip archives may cause unforeseen problems. I doubt the problem is with the actual zip files. Not quite sure how to circumvent these problems... Maybe a version of Stuffit Expander that manages to work on these new Macs still...?

 

Update: Wow, SE still exists and is updated to work on modern Macs...

 

Update2: Expanding WtRM archive with Stuffit Expander worked! The .cmg file of WtRM loads fine now. It seems SE has retained the ability to expand .cmg files, whereas the other extraction program I commonly use (Keka) has not.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...