Jump to content

Geneforge 1 ghost demo preventing full game installation [SOLVED]


Minion

Recommended Posts

Issue solved:

 

Save game path found in this thread: http://spiderwebforu...d-games-folder/

 

In Windows 8.1, Geneforge saves games and settings to the folder C:\Users\USERNAME\AppData\Local\VirtualStore\Program Files (x86)\Geneforge, which is not deleted when uninstalling the game. Deleting the file GFPrefs.dat erased the demo settings and allowed the full and registered game to be installed correctly.

 

---

 

This issue has been mentioned before, but the poster never mentioned if they found a solution.

 

I am running the Windows version on Windows 8.1.

 

After finishing the demo of Geneforge 1, I bought the Geneforge Saga bundle from Humble Bundle and ran the installer for G1 without uninstalling the demo first. When I started the game, it was still unregistered, and uninstalling and reinstalling it did not work. The strange thing is that no matter how many times I uninstall the game, my save files and preferences remain, and I assume this is related to the issue.

 

I did find one solution: Installing the game in a different directory. This seems to bypass the "ghost demo", but when I try installing the game in the default directory, the issue reappears.

 

Since Geneforge doesn't take up much space, I am not that worried about having an invisible copy of it lying around on my computer, but if anyone has any idea of where the ghost files might be found on, I would appreciate it.

 

I hope this might be of help to anyone else who happens on the same issue.

 

PS: After reinstalling the Humble Bundle version in the new directory, I noticed that it also remembered my settings (Always Change Resolution) from my previous, experimental installation. So it appears that the Geneforge data is being saved somewhere on the computer and not deleted properly.

 

PSPS: It appears that Geneforge does not save games to the save file folders in Windows 8.1. I copied the save file folders from the demo into a separate directory and just tried copying them back into the data directory of the new, full install, but the save slots are all blank. Considering that the temp files in the folders are all 1 KB, I guess I shouldn't be surprised.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...