Jump to content

BOE Windows Version


Bilinker
 Share

Recommended Posts

I will most likely be yelled at for this either being answered somewhere else or me just being too dumb, but I was looking over the Windows Code that was put up both by Jeff himself and Ormus's and I'm a little confused. I understand that the code needs to be compiled, but how? I'm using Dev-C++ and I simply created a new project and added all the files, but to get it to actually start working, I think i need to do more than that. In addition are there any libraries needed to be linked in order to allow the code to work? Also how are the images and sound files stored? I know I probably sound clueless, because I suppose I am, but if anyone could help me out, that would be great. If you need me to clarify or explain anything just ask.

Link to comment
Share on other sites

I would like to basically report what I've done and what worked just in case anyone was in the same boat. After downloading Ormus's:

"BoE for Win32, game + scenario editor + all source codes + VoDT", I extracted it into a folder in C:\. Then I edited all the folders to have no spaces, because DEV sometimes has errors if the folders are stored in spaces. Then I basically created a new DEV-C++ empty project, saved it in the folder \source_code\Blades_of_Exile,(made sure the project was a GUI not a Console APP) and then added /Dev-Cpp/lib/libmsimg32.a and /Dev-Cpp/lib/libwinmm.a into my linker under parameters in the project options. Then I added all the files from that folder into the project. When I compiled it, it said I was missing a .dll file, it's called boesounds.dll and it's located in a different folder, I suggest just searching for it then copying and pasting it into the folder you're using to build the game. Then I compiled and it worked, sort of. It gives a compilation error:

 

make.exe: warning: Clock skew detected. Your build may be incomplete.

 

However, the program sill works. The game loads, but it has no sounds or graphics. I assume thats what the error is trying to tell me. I know where the sound and image files are, I think. I just don't know how to link them in. Can anyone help??

 

In addition I get a warning message:

 

*** Warning: File `GAMESTR.RC' has modification time in the future (2025-07-17 17:27:00 > 2007-07-22 17:35:55)

 

I don't know what that means, or if it is just what happens during the compilation. Once again if you need clarification or an explanation, feel free to ask.

 

EDIT: The sound effects do seem to work, I assume that is because the .dll file was added...

Link to comment
Share on other sites

OK well I finally figured out my problems, I needed both the folders that contained the scenarios and the images in the folder in which the executable file was located. So overall, it was a success. I still am getting the Error message and the warning (see previous post), but it doesn't seem to be affecting the program itself. So basically now that I figured all this out, the only thing I can do is to thank Ormus and everyone else working on updated and changing the code. Thank you all very much, it has saved me time and helped put me on my track for what I want to do. Although this topic didn't really have anyone else in it, hopefully if anyone else was as clueless as I was, they could look at this and save some time tinkering around.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...