Jump to content

"Unhandled exception"


Recommended Posts

I recently downloaded the demo for Geneforge. I thought it was a great game and bought a registration code for it. However, I had deleted the previous Geneforge I had and I went online to download another version. After the second screen describing the background story, I ran across an "unhandled exception: c0000005" at the address 0x000000000044afef4. I tried to restart my computer. When that didn't work, I tried shutting off my computer and turning ift back on, to no avail. I then decided to delete this copy of Geneforge and I downloaded another copy. When I ran it, the same problem occurred at the same place in the game and at the same address. I have downloaded the game five times now, and the same result keeps happening. I bought this computer just a couple of months ago, so it should have all the newest equipment and technology, and it does have DirectX on it. I even got the patch for it to see if it would help, but it didn't. What should I do?


I have an HP Media Center PC that runs Windows XP and it contains an Intel processor chip.

Link to comment
Share on other sites

I had the same problem a short time ago. For me the solution was rather simple. Try setting the program compatibility mode for Windows 98/ME. If you don't know how, the steps are as follows.


Find your Geneforge executable, in your Geneforge directory (default location C:\Program Files\Geneforge). Right click on it and pick "Properties" from the menu, then click on the "Compatibility" tab from on the new window. Click on the box next to "Run this program in compatibility mode for:" and then select Windows 98/ME from the drop-down menu. Then hit "Apply."


Hopefully it will solve your problem with very little fuss.

Link to comment
Share on other sites

  • 1 year later...

After searching in the forums for help with a Geneforge 1 crash right at the end of the game, I found this thread. Not only did Tannhauser's suggestion work for me in resolving the crash, it also resolved some graphical issues.


Before I tweaked the memory setting, the fonts used on the game screens wouldn't load properly, which meant the text at the bottom might get cut off or hidden behind buttons.


Once I made the changes described in Tannhauser's post above, everything worked great!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...