Jump to content

Recommended Posts

So I originally came to this series with geneforge 5, as such never really played 1-4 so I've decided to get them and try them out since I enjoyed the 5th one. After loading up geneforge 1 however I'm noticing an issue with my mouse. Things are really choppy and lagging. I'm assuming it is due to the fact that I'm running this on Windows 7 64-bit. Just wondering if there is a way to fix it. I've tried opening it in compatibility mode but no luck.

Link to post
Share on other sites

I have the exact same problem as you, and the only solutions I can tell are this:

 

1.) Play in XP compatibility mode. It might help.

2.) Be a singleton. It slows done more for every animated character on screen.

3.) The later the game, the better it is. G1 is worst, with it being a bit better in G2, and somewhat more so in G3. As observed, not an issue at all in G4.

 

Really though, they are old and coded to run entirely off a 32 bit processor. Its going to take until the remakes for the issue to be fixed.

Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...

I suspect this fix for Avernum 4 mouse hitching problems (from forum user "sea") might also work for Geneforge 1-3:

 

Quote:
You'll need to download the Microsoft Application Compatibility Toolkit.

 

http://www.microsoft.com/en-us/download/details.aspx?id=7352

 

Launch the 32-bit version, create a new custom database, then a new application fix. Navigate to the affected game executable, select it, and then, on the second page of fixes, look for "ForceDirectDrawEmulation."

 

To make sure the fix stays, right-click the database and select "Install" which will apply the fixes when you launch the game outside the Compatibility Administrator.

 

Original post:

 

http://www.spiderwebforums.com/forum/ubb...ng_Probl#UNREAD

 

 

I had the same problem with lag in menu/inventory screens in Avernum 4 and this fixed it for me. It's worth a try with Geneforge 1-3 as I think they use the same/similar engines.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...