Jump to content

Terrible performance in early Geneforge titles


TheGameSquid

Recommended Posts

Hi,

 

I've wanted to purchase a couple of Spiderweb games for a long time now, and I figured that now they are having a nice sale this month, I might as well pick up the entire Geneforge Series.

 

However, I was doing a small test-run of the demo yesterday evening when I figured out the performance was pretty abysmal. I have played many Spiderweb demos before on older machines, and they always worked fine.

 

The problem is that the framerate drops dramatically whenever animated sprites appear on-screen. It's pretty bad when me and my single creation are walking around, but whenever an enemy or two appears, things get extremely irritating. Whenever I'm navigating menus or not looking at animated sprites things work just fine.

 

For the record, I'm running the demo on a laptop with Windows XP Service Pack 3 using a pretty powerful graphics card (at least, for Geneforge standards), the NVIDIA Quadro NVS 320M.

 

Any ideas on what might be causing the problems? I'm assuming the demos all contain the latest patches? In this state I'm afraid I won't be able to buy the game, which of course makes me very sad.

 

Thanks in advance,

 

 

TheGameSquid

Link to post
Share on other sites

It may not necessarily help in your case, but the following steps reduced the lag on my machine, in Geneforge and Geneforge 2.

 

1. In Windows explorer, browse to the game executable (in the Program Files folder), right click and open the Properties sheet. Set the Compatability Mode settings to Windows 98/ME.

2. In the NVIDIA control panel, under 3D settings, add specific program settings for Geneforge applications, setting all the configuration for DirectX to favor High Performance instead of Quality.

 

After these steps, the game is still not as fast as it I remember from when it was first released, but I found it sped up enough to become playable after this.

Link to post
Share on other sites

Thanks for the reply Micawber.

 

Putting the game under compatibility mode for 98/Me didn't do a whole lot, but changing it to 95 seems to improve things a little.

 

Other than that, I already changed the setting to favor high performance instead of quality long before I started playing Geneforge.

 

Changing the CPU affinity didn't do the trick either, nor did changing the priority of the process...

 

As it stands now, performance is a little better, but still very annoying. Still not sure if this warrants a purchase unfortunately.

 

I guess could try starting with more recent games, but I would probably feel like I was missing out on a bunch of stuff, and Geneforge 1 does seem like one of the more interesting games in the Spiderweb catalog. Starting out with Avadon doesn't seem like a good idea either, don't want to get TOO used to that lovely interface grin

Link to post
Share on other sites

Did you actually change the DirectX settings? Changing the windows visual effects settings (under control panel/performance) to turn off windows animations etc will do nothing to help Geneforge. However, I found that changing the display adapter settings on the NVIDIA card does have a significant impact on DirectX games.

 

Also, if you haven't changed the settings in a long time, make sure you get the latest NVIDIA driver. The new ones do seem to have more settings that you can change on a per-application basis.

Link to post
Share on other sites
  • 3 weeks later...

I am having this exact same problem and I have windows xp with a ATI card too (4850HD).

 

The first 2 areas were playable although getting into the menu to save took like 40 sec. But once I got to the first village my FPS took a major hit and went to like 2 fps which is unplayable.

 

I tried a virtual machine with window 98 but after installing I noticed steam doesn't support 98 frown.

Then tried windows xp on a virtual machine, steam and geneforge installed but the mouse sensitivity had major bugs ingame which caused it to be unplayable.

 

Then I noticed all of you got ati cards too so I went into my device manager and DISABLED my video card ( luckily my motherboard has some standard video card in it). I rebooted and the game ran like it is supposed to.

 

I really hope Jeff can fix the ati card issues cause I don't like disabling my video card each time to play smile! So for everyone where the game doesnt work well you should try this atleast to see if it is really the card or just me.

Link to post
Share on other sites

I am playing Geneforge 1 atm with a sixcore amd and a radeon 5800 (so no nvidia control panel) on Win 7 64Bit - and i´m also experiencing massive performance issues. Kind of frustrating to have a machine which is able to play current titles maxed out with >100fps... and which fails to run a 10 year old title frown

 

Everytime the white transparent "hint" font is displayed over the main window, the frame rate drops tremendous and i am hardly able to move the mouse or to click a button. There are other times when the framerate drops (e.g. the "You have died"-screen), but this must be the most bothersome.

 

If i play in windowed mode everything is good, but in the correct resolution it is hardly playable. Window mode is not really an option, since i have a 24" screen and a resolution of 1920x1080... and i don´t want to play with a magnifying glass.

 

I have tried so far:

- reducing colors to 16Bit

- Compatability Mode settings to Windows 98/ME and 95 (took me a while to find out how to get my save game back btw. - the location changes after altering this)

- Deactivated visual designs (aero)

 

 

Nothing fixed it so far frown

Any other ideas?

 

 

[edit]

This sounds familiar, i guess i´m having the same problems:

http://www.spiderwebforums.com/forum/ubbthreads.php?ubb=showflat&Number=212406#Post212406

[/edit]

Link to post
Share on other sites

try this: launch geneforge and then alt-tab to windows, open task manager and in there open process tab and then find geneforge's process and then click it with right mouse button and choose set affinity and limit it to only 1 core.

 

also it could be some Win7 oddity, especially on 64bit version.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...