Jump to content

Avadon on Steam


Recommended Posts

I recently purchased Avadon on the iPad and thought the game would be so much better if I could use a mouse. I saw it on Steam today and bought it instantly. Only problem is, the Steam version crashes everytime I start the game up. I also installed the Avernum 6 demo and had the same problem until I ran it in DirectX mode, as is recommended. So I think that is the problem with the Steam copy of Avadon.

 

Is there any way to run the Steam copy in "directx" mode?

Link to post
Share on other sites

what is your graphic card?

 

usual reason for crashing is damaged file (graphic driver or some 1 of game files) so first thing to try is install latest graphic drivers (or reinstall if already has latest) and ig not helping then uninstalling game and deleting all remaining files of it and then wnloading new copy and installing again.

Link to post
Share on other sites

ATI Radeon HD 5700 Series

 

Everything should be perfectly in order, and I did just install the demo from this site here, as I saw a topic with problems from direct2drive and wondered if it's the same for steam. The demo also didn't work, just crash upon startup and a window saying it doesn't work. I have Windows 7 home Premium.

 

EDIT: just checked and I have the latest grpahic drivers, and as I now downloaded the game twice I don't think it's a corrupt file.

Link to post
Share on other sites

Well I have verified the cache on steam so that's now 2 different downloads, and a verification. If the chances of that being coincidence aren't extremely low then there's something very wrong anyway, so I don't think that's the problem.

 

EDIT: aaaand downloading it again Because I clicked: use this option (fullscreen 1900x1200) always, and I want to try if windowed mode works... but damn people, I just wanted to play this takes my free evening!

 

EDIT2: Oh that's just fantastic... for some reason deleting all local content and downloading it again (all through steam) does NOT give me the initial resolution option screen back! FFS... I do not want the software to remember my choice over an uninstall.... >_< I am becoming pissed, I will do something else and check back here tomorrow.

 

Thanks if anyone can help me.

 

EDIT3: error message:

Probleemhandtekening:

Gebeurtenisnaam van probleem: APPCRASH

Naam van de toepassing: Avadon.exe

Versie van toepassing: 0.0.0.0

Tijdstempel van toepassing: 4e4358bd

Naam van foutmodule: atioglxx.dll

Versie van foutmodule: 6.14.10.10907

Tijdstempel van foutmodule: 4e167a7f

Uitzonderingscode: c0000005

Uitzonderingsmarge: 0072142f

Versie van besturingssysteem: 6.1.7601.2.1.0.768.3

Landinstelling-id: 1043

Aanvullende informatie 1: 0a9e

Aanvullende informatie 2: 0a9e372d3b4ad19135b953a78882e789

Aanvullende informatie 3: 0a9e

Aanvullende informatie 4: 0a9e372d3b4ad19135b953a78882e789

 

 

Link to post
Share on other sites

Sorry for doublepost but 4 edits don't make it more readable I think....

 

So, I didn't let it go, as I thought of one more thing to try: the demo with the AvadonDX file they gave as solution in that other thread about gamestop/direct2drive: It worked! So I indeed have the exact same problem as the original poster: So also the same question: is there a way to make the steam version start the DX version? I would like to have the steam achievements and overlay and such while gaming... thanks!

Link to post
Share on other sites

Avadon on Steam does require OpenGL compatibility. If you buy Avadon on Steam and it doesn't work, you can try the DirectX version from our site. To obtain it, read the section on DirectX here ...

 

http://www.spiderwebsoftware.com/avadon/techsupp.html

 

If only the DirectX version works, we can provide you with a registered copy. Contact us at support@spiderwebsoftware.com, and we can provide you with a key to register the DirectX version from our site.

 

This will not provide steam achievements and such, as it's not a Steam app, but it will provide a working game.

 

- Jeff Vogel

Link to post
Share on other sites

Okay that's a pity about the achievements but at least I have the game then, thank you for your support in these matters. I really appreciate it.

I played the demo a bit and it seems exactly my cup of tea laugh So pretty happy altogether, I'll email you right now smile

Link to post
Share on other sites

Yes the DirectX version worked for me. And just for the info I am using an Asus Laptop. It has an ATI Mobility Radeon HD 5870 and im running Win 7 64-bit. I think it has a problem with OpenGL because there are certain other games that wont run, most of them being ones that use or require OpenGL. But thanks for the info and getting my copy to work. I will send an email shortly.

Link to post
Share on other sites

It's probably not a cool idea to say that in response to the games developer, even if you did already purchase the game.

 

Talking about illegal activities is against the Code of Conduct of these fora, and also it's pretty rude.

Link to post
Share on other sites

Just some quick info that may be of use: I purchased Avadon on Steam and had trouble getting it to run. It would run in windowed mode only. Now I have gotten the game to run in 1920x1080 full screen mode by going into Catalyst Control Center and setting Wait for Vertical Refresh to ON and enabling Triple Buffering under Open GL. It will also work if you disable Triple Buffering and turn Wait for Refresh OFF. My specs are as follows: Win 7 64 bit, ATI 5770 gfx card, and Cat. 11.7 drivers. Hope this helps.

Link to post
Share on other sites

Hero! That works!! That's simply amazing! How... did you EVER think of trying something like that?

 

In any case, I can confirm that setting triple buffering on under Open GL and Wait for Vertical Refresh ON (unless specified by application otherwise) works! It's great, steam achievements, here I come ^^

Link to post
Share on other sites
Originally Posted By: Earth Empires
I have ATI/AMD Radeon 4870 (latest drivers unless 11.8 has just come out) and WinXP 64bit and no problems with Avernum 6 or Avadon 1.

Could be on some weird bug on Radeon 5xx0s drivers.


I have a 4870 running 11.8 and see the same problem with Windows 7 Pro x64. After selecting fullscreen and 1920x1080 (and remember these settings frown ) the Avadon demo just 'stops working' every time I try to load it.

Forcing V-Sync ON in the catalyst control panel (wait for vertical refresh under gaming->3d application settings) fixes the problem.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...