Jump to content

Avadon v1.0.1 Public Beta, REVISION B


Recommended Posts

I have wrapped up the first set of bug fixes and improvements into Avadon. The public beta of v1.0.1 is here ...


[Removed. Update released. Just get it from the main game page.]


Any comments or feedback is welcome at support@spiderwebsoftware.com. Even if you try it and it seems to work fine, a message to that effect would be valuable. If everything seems to be fine, I will release it for real on Wednesday.


* Avadon has been upgraded to a newer game engine. It should now be slightly faster for most users and do a better job of cooperating with the operating system.

* Avadon will now run on case-sensitive hard drives.

* Moving the PC Roster header bar to the bottom of the screen no longer freezes it there.

* When you clear the flooded corridor in the Jhereth Deeps, it will still be cleared when you return to the area.

* The demon Incarnus can now only be defeated once.

* A map of Lynaeus is ow in the Avadon folder.

* Other minor tweaks and typo fixes.


EDIT: 3/8/2011, 2:25 PM


I have removed b1.0.1 and replaced it with b1.0.1b. This revised candidate fixes several problems with the first 1.0.1, most notably ...


* A very rare crash on launch should be fixed.

* On first launch (when you get the Are You Sure You Want To Run This? warning), the game wasn't being moved to the front. This should be fixed.

* The F13-16 keys should work now (if the OS hasn't mapped them to something else).


If you tried the first v1.0.1, please migrate to this one. Thanks to everyone who replied and e-mailed me. If this version works better, a note to support@spiderwebsoftware.com is much appreciated!


- Jeff Vogel


Link to comment
Share on other sites

pulverizer, I just checked this on an iMac and a MacBook and it's launching in full screen just fine. Are you SURE you are not telling it to run in windowed mode?


Perhaps go into your preferences folder and delete the file "Avadon Settings", run the game again, and, when the resolution screen comes up, just run the game without changing anything.


Has anyone else who tried it had trouble playing in full screen mode?


- Jeff Vogel

Link to comment
Share on other sites

Tried with a fresh download (after deleting the installed copy and preferences) and still the same problem. I guess it might be best to wait for some other folks who might have a similar setup as me to respond, to see if this is something particular to my machine. I am using one of Apple's newly released Macbook Pro models, if that makes any difference.


I'll continue to play in windowed mode in the meantime smile

Link to comment
Share on other sites

I have discovered the culprit: Automatic graphics switching. The machine is initially running with the integrated graphics and starting the game switches it to the discrete graphics card. However, it seems there's a slight delay during the switch due to which the game/OpenGL starts up before the switch is complete, pushing it out of full-screen mode.


If I disable the automatic graphics switching, such that the discrete graphics is being used from the beginning, the game enters full-screen correctly. Not sure if there's anyway for the game to ensure that it waits before the switch is complete to launch (especially as it is the launch that initiates the switch).

Link to comment
Share on other sites

Originally Posted By: Master1
Jeff: In the Jhereth's Deep, the trapdoor just a little below Zephyrine (marked H on your map) appears in the automap, but the actual game just has a blank floor. I have screenshots if you'd like. Running v1.0.1 on a PowerBook G4, OS 10.5.8

I can confirm that the trapdoor is present and functional for me (I did check the map in the hintbook.) Running b1.0.1b, as Jeff refers to it in this thread, on an Intel iMac/10.6.6.
Link to comment
Share on other sites

"Stickying" is something moderators and administrators can do to threads. It literally sticks the thread at the very top of the forum, so that even if newer threads are made, it still sits above them.


Unstickying is removing the "stickied" status of a thread, and god help me if I have to explain "stickied".


(The new release works great for me, by the way Jeff, though I guess this is moot now. (Running 10.6.6)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...