Jump to content

Lamentations - McSorely missing can't progress without him


Recommended Posts

Another day another scenario. After fixing the show/hide town problem in this scenario I decided to play through.


All was going well until after returning from the Jayhawks and getting to Renalda's locked door. I knew I had to find McSorely but he wasn't in his house and I couldn't find him around Alverstaff.


Is this a feature or a bug? If a feature then any direction would be great. If a bug, what is happening and how can I repair it?

Link to comment
Share on other sites

Alcritas said "Lamentations is simply broken", in my previous thread. (http://www.spiderwebforums.com/forum/ubbthreads.php?ubb=showflat&Number=213050#Post213050)


You could possibly place him yourself and attach him to any relevant nodes in the town.


I'm having trouble myself with the scarecrow in Redemption not appearing, and have basically given up trying to fix it.

Link to comment
Share on other sites


You've spoken to McSorely the first time through and you're looking for him after the death of Renalda...

He's one of the crowd hanging around after Renalda's body is found.

I had to walk around and talk to the others a bit and then returned to McSorely and ask, "Job", "Found", and then, "Entered".

He would have told you about the "Specail Brew" made by Helga and that there is a map on a bookshelf in his house.

All this makes Helga's House now visible.

If, indeed, there is a problem with the Scenario, give a whistle and I'll send you a copy of what I have. It's v1.0.0 and I'm pretty sure it worked for me.

If you're using the new OBOE and are up to it, check the Nodes to see how each triggers the other.

Link to comment
Share on other sites

First of all, I said Lamentations is similarly broken (meaning it has the "reveal" town non-bug problem), not simply broken. Milla's post indicates she has fixed this problem.


After you return from the mini-Jayhawk mission, head to the southern half of town and report your success to the commander. Then head north. McSorely should be milling about. He will tell you the requisite information right away, but you have to poke around a bit at first. Later on, he'll just spill the beans.


I don't know of any New BOE problems with the Scarecrow, it worked for me in my recent play through. Could you describe what you've done/where you're at in the scenario?

Link to comment
Share on other sites

Right, so this is the sequence of what should happen-


1. You defeat the Jayhawks in their fort, they release the quickfire, etc..


2. You had back to Alverstaff. In the southern half of town, in the town hall, meeting area, etc... you should find General Montgomery.


3. You talk to General Montgomery, it triggers a dialogue window.


4. You head north, and a crowd has gathered around Renalda's place.


It sounds like you either haven't talked to Montgomery, or he's not there. Is this what's happening?



EDIT: While these aren't "new" versions in the sense that they're all at least 6-7 years old, at the following link you can find (more) updated versions of my scenarios than you can following the links at the top of the page. Please note, the "reveal town non-bug" hasn't been corrected for any of these. I will be happy to email a copy with that bug corrected to anyone who wants one.



Link to comment
Share on other sites

That's where I got the scenario from.


General Montgomery doesn't have a dialogue window, he just sits there.


I'll see if I can fix that as I already fixed the reveal town thing before I played.



Looking at the scenario through the editor, it appears that there are two generals on top of each other and one has the relevant dialogue personality (number 50). The wrong one is being removed via destroy monster?


EDIT 2: There are two general in the actual game and since the non-speaking one is creature number 22 compared to 40 it's non-existent dialogue is coming up first.


EDIT 3: Not really a fix but to continue I gave the non-speaking general the personality 50 and the game is currently moving through nicely. Not a real fix though, as I'm seeing something similar with the mayor but her dialogue box worked fine in the meeting.

Link to comment
Share on other sites

I tried to explain earlier that I'm not going to post the Walk-Throughs I've made.

It began as a hobby and I feel it should stay that way.

My original intention was to release anything I made and to encourage others to do the same so there would be a permanent resource library to cover for the Authors who had left the BoE Community, such as Tarl Kudrick.

With the release of the Source Code and the subsequent OBOE, that makes posting Walk-Throughs, which are complete 'cheats', totally unnecessary.

I feel that it's the Player's obligation to 'Play' the Scenario as it was meant to be, not to 'Cheat' their way through. Believe me, if I can do it, anyone can.

Again, I only wanted to preserve information previously unavailable, but which is now readily available to anyone who wants to earn it.

I hope this encourages the respect for the Authors that they so justly deserve.

Isn't that what we're here for?



P.S. The 'fixed' Scenario is not one of Alcritas'. It was done by a different Author whom I have been unable to contact and it was the only one they did.

It's unethical, (and hopefully, illegal), for me, or anyone other than the Original Author, to modify and release anything.

I'm sure that Jeff never had that in mind when he released the Source Code.

Link to comment
Share on other sites

Emailing is just convenient for me. Obviously I don't get a lot of BOE requests nowadays, and the only reason this is an issue at all is the release of an open source BOE that is ever-so-slightly different from the original release.


It was always extremely easy to circumvent the scenario creator's obstacles in BOE, now it seems trivially so. As for allowing others to release modified versions of my scenarios; it doesn't strike me as a major issue in the limited case of correcting a bug created by the change in source code, but it opens the dangerous door of potential plagiarism just a bit wider; something that's hit me before in this medium, so I appreciate Ahbleza's hardline stance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...