Jump to content

Demos won't install


Recommended Posts

Hi there, I've tried downloading several of the demos and have had spotty luck at actually getting the installation exe to run.


So far Nethergate's the only one that's successfully installed on my computer. But Geneforge 2 and Avernum 3 won't install. I've tried dowloading GF2 only once, but have given it a go with each of the Av3 links offered. Each time I try to run the demo.exe file the blue Install screen flashes very briefly and that's it.


Could the file be getting corrupted every time I download?


I guess it could be a problem on my end but I don't know why Nethergate would install correctly and the others won't.


What up? Any help or suggestions greatly appreciated.

Link to comment
Share on other sites

Thanks for the reply.


I'm on windows 98, dinosaur edition (read: not 2nd) and after the first failed install I kept everything closed while downloading.


I would try a different place to download the installers from but every place I've been able to find is just linking back to the spidweb or ironycentral downloads.


Are there other download sites out there?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...