Jump to content
Celtic Minstrel

Experimental releases

Recommended Posts

After a long silence, I have finally produced a new build! Windows users can download it here. I am still unable to produce a Mac build that will run on modern Macs, but if someone else provides one, I'll mirror it on my site.

 

This version has quite a few performance and stability improvements. There is a change to the save file format as well. I believe older saves should still load, but I can't guarantee they'll be playable.

 

In addition, the Linux version of the game is finally usable. It now has a custom-built menubar, allowing Linux users to use alchemy, create new characters on the fly, access the journal, and so on… as well as using the editors. The Linux menubar is thanks to another contributor who goes only by "xq". I don't know if they have a forums account.

Share this post


Link to post
Share on other sites

Another new build can be downloaded here. There are a few bugfixes, but the main difference is that the game will load graphics from the userdata directory in preference to the actual game directory. This could be used to make the UI look like Exile 3, for example, without needing to constantly modify the program directory.

 

By "userdata" directory, I mean the location where Open Blades of Exile reads (and sometimes, writes) user-specific data. On Windows, this is in %APPDATA%\Blades of Exile. On the Mac, it will be $HOME/Library/Application Support/Blades of Exile, and I believe the Linux location is something like $XDG_CONFIG_DIR/openboe. To make the game load custom graphics, create a "data" directory at this location, and a "graphics" directory within that. (Other directories here will also override default resources, for example "sounds" or "fonts".)

Share this post


Link to post
Share on other sites

Mcafee also seems to think they are a big improvement, in that it lets me run them without randomly quarantining them (so far).

 

Was wondering, was BoE supposed to be full screen only, and the character and scenario editors part screen only, or was that just me?  In any case, thanks.

Share this post


Link to post
Share on other sites
20 hours ago, Thaluikhain said:

Was wondering, was BoE supposed to be full screen only, and the character and scenario editors part screen only, or was that just me?  In any case, thanks.

Yes, the editors have no fullscreen mode. The game itself can be toggled between windowed and fullscreen mode in the preferences (File menu on Windows/Linux, app menu on Mac).

Share this post


Link to post
Share on other sites

Hmmm, ok, so there's a Vahnatiai option now (have to rethink my usual 2 of each party) with one Vahnatai graphic, an Anama Member option (which everyone who isn't a caster should always take, I guess).

 

Have noticed that the "save as" function inside a scenario is the same as "save", doesn't give you an option to choose where you are saving to.  And there's a really annoying flickering thing down the very bottom, the only way I can play the game is to play on small screen and stick the bottom below the edge of my screen.

 

The normal screen is a little small and the 2x is too big to fit on my screen.

 

I should stress, I'm not meaning to sound too critical, these are just things I've noticed that seemed worth mentioning, it's still very nice to be able to play the thing at all, and I appreciate the work done on the mod.  On to replay "Burned".

 

EDIT:  Ah, found some things.  The controls are a bit sluggish, and I can walk through anything (walls, trees, caves).  Also, ran into an outdoor encounter of goblins and they didn't seem to be able to move or attack, just stood there until I killed them.  Put a PC next to one and "stand ready" -ed and they didn't attack in their turn.

Edited by Thaluikhain

Share this post


Link to post
Share on other sites
2 hours ago, Thaluikhain said:

Hmmm, ok, so there's a Vahnatiai option now (have to rethink my usual 2 of each party) with one Vahnatai graphic, an Anama Member option (which everyone who isn't a caster should always take, I guess).

Well, if you want to have an optimal party, and eliminate the possibility of some characters learning mage spells later on, sure.

 

2 hours ago, Thaluikhain said:

Have noticed that the "save as" function inside a scenario is the same as "save", doesn't give you an option to choose where you are saving to.

…really? Save as was working last time I checked… I'll check again though.

 

2 hours ago, Thaluikhain said:

And there's a really annoying flickering thing down the very bottom, the only way I can play the game is to play on small screen and stick the bottom below the edge of my screen.

Indeed, this is very annoying and I'm still not sure where it comes from. I think I have an idea to "fix" it, though.

 

2 hours ago, Thaluikhain said:

The normal screen is a little small and the 2x is too big to fit on my screen.

While I can't promise it'll look good, it's possible to edit the bladeprefs.ini to set the UISCale to 1.5 (or any other value you want to try)

 

2 hours ago, Thaluikhain said:

EDIT:  Ah, found some things.  The controls are a bit sluggish, and I can walk through anything (walls, trees, caves).  Also, ran into an outdoor encounter of goblins and they didn't seem to be able to move or attack, just stood there until I killed them.  Put a PC next to one and "stand ready" -ed and they didn't attack in their turn.

Other than the sluggish controls, what you're describing is debug mode plus ghost mode. Shift-D will disable it. There was a bug where sometimes they'd spontaneously enable themselves, which will be fixed in the next build.

Share this post


Link to post
Share on other sites

Ok, reloaded my save game, and Shift-D got rid of that problem, thanks.

 

But all my maps had been erased, both the outdoors where I was, and the two towns I'd visited.

 

Also, went to the blacksmith and bought some stuff, and it's not identified when I got it.

 

There's also a weird thing when I trigger a special, and nothing happens until I click again, which sometimes happens when it's a one time show text thingy.  Annoying but not game killing.  Monsters don't seem to make death noises, and animations are very slow, again, not big problems.

 

"Save as" is working again, though clicking on "Cancel" still saves, rather than cancels.

 

EDIT:  Saved and exited, and upon reloading, the map of the town I'm in is still there, but the outdoor map is not.  Next town I go to also has the map still.

 

ALSO EDIT:  The "Go back" function in the dialogue doesn't do anything.

 

ALSO ALSO EDIT:  When casting spells at a target sitting on top of a special, it kept triggering that special.  Which could be useful if you could do that on purpose, now that I think of it.

Edited by Thaluikhain

Share this post


Link to post
Share on other sites
1 hour ago, Thaluikhain said:

But all my maps had been erased, both the outdoors where I was, and the two towns I'd visited.

Huh, haven't seen that one before… just to clarify, by maps, you mean the areas you've explored on the automap, right?

1 hour ago, Thaluikhain said:

Also, went to the blacksmith and bought some stuff, and it's not identified when I got it

This one should be fixed in the next build.

1 hour ago, Thaluikhain said:

There's also a weird thing when I trigger a special, and nothing happens until I click again, which sometimes happens when it's a one time show text thingy.  Annoying but not game killing.

This almost sounds like it could be related to the debug mode bug, as there's a step-through mode that shows the current node in the transcript and pauses after each node… but it also sounds like it could be something totally different?

1 hour ago, Thaluikhain said:

"Save as" is working again, though clicking on "Cancel" still saves, rather than cancels.

Ugh, really? That's a pretty terrible bug…

1 hour ago, Thaluikhain said:

ALSO EDIT:  The "Go back" function in the dialogue doesn't do anything.

This one is known… Go Back is currently broken.

1 hour ago, Thaluikhain said:

ALSO ALSO EDIT:  When casting spells at a target sitting on top of a special, it kept triggering that special.  Which could be useful if you could do that on purpose, now that I think of it.

Yes, the ability to trigger specials by casting spells is intentional… however, it shouldn't be triggering just any special… so this is still a bug. (Also, the white special spots are supposed to be impassable to monsters.)

 

EDIT: I opened #267, #268, and #269 based on your post.

Share this post


Link to post
Share on other sites
23 hours ago, Celtic Minstrel said:

Huh, haven't seen that one before… just to clarify, by maps, you mean the areas you've explored on the automap, right?

 

Yeah, that's it.  Just loaded it again and it's just the outside map.  Though had saved inside a town, will have to try when saving outdoors.

 

23 hours ago, Celtic Minstrel said:

This almost sounds like it could be related to the debug mode bug, as there's a step-through mode that shows the current node in the transcript and pauses after each node… but it also sounds like it could be something totally different?

 

Yeah, getting messages like "Step: Stuff Done Equal? - 20" and "Step: Destroy All Monsters - 26".  Both before and after I turn debug off with Shift-D.

 

EDIT:  And another one, this one bigger and weirder.

 

When fighting the Blight Spirit (which is the end fight for Burned), I got killed after a bit, so reloaded and tried again and got taken to the main screen with my party, despite having saved in a scenario.  Loaded from there and went back to the proper spot, and was able to kill the monster with one hit (doing normal damage for that PC, which is not nearly enough to one shot it), start get the ending dialog but the game exited when it reaches the "change terrain" step.  Reloaded it a couple of times (no problem with loading), and the same thing happened, until one time it didn't, the fight was running normally for a few turns and then just froze.  Had to close BoE and start again, at which time I oneshotted the monster and the game exited again.

Edited by Thaluikhain

Share this post


Link to post
Share on other sites

Hmm, okay, seems like there's a second bug there in that node step-through mode isn't properly linked to debug mode. I believe the shortcut to disable it is Shift+1 (probably requires debug mode enabled); alternately, when you see those messages, I think escape will disable them as well (which shouldn't require debug mode enabled).

Share this post


Link to post
Share on other sites

Oh, is the one hit kill thing part of the Debug mode?  Turning it off seemed to fix that, though BoE was struggling during some turns (during the monster part of the turn, it soon said the program was not responding, though it was able to run the rest of their turn, just without me being able to see what was going on, sounds and damages still worked), managed to barely win the fight but it still exited the game during the Change Terrain step.

 

EDIT:  Oh, Shift-1 stops those messages about specials coming up, though it still kills the game at what I presume is the Change Terrain step.

Edited by Thaluikhain

Share this post


Link to post
Share on other sites

Huh, that sounds like a fairly bad bug if the game crashes trying to change terrain. Is there an error message or does it just suddenly die? A saved game should help debugging it, and of course I'd need to know the scenario.

Share this post


Link to post
Share on other sites

It just suddenly dies after the fight with the Blight Spirit at the end of Burned.  Killing it triggers a string of specials, there's a display text and a destroy all monsters one, followed by the change terrain one.  Actually, I don't know for sure it's the change terrain one doing it, but it's the last one to get a message come up before crashing.

 

I think the same scenario also has another change terrain and that worked fine.  You go through a door and it locks behind you, I'd presume that'd be a change terrain special, but don't remember if a message came up for it.

Share this post


Link to post
Share on other sites

Ok, used the editor to leave the scenario, copied Nephil's Gambit into the scenario folder to try that, but only Burned is coming up on the list of custom scenarios..

Share this post


Link to post
Share on other sites

Oh man, looks like I'm going to have to work on trying this out! Upgraded from Windows 10 to Solus 4.1 a few months ago, and was just musing the other day about what it might take to get OBOE to run on Linux. Looks like there's one less thing to wonder about.

 

Thanks, Folks. :D

Share this post


Link to post
Share on other sites

Just a heads-up if you're building the Linux version from HEAD – while HEAD builds, it has some crashes that are fixed by pull request 274, so you'll want to merge that locally as well (something like "git pull origin refs/pull/274/head" should work). It's not merged yet simply because I haven't had a chance to give it a detailed review.

 

There are still some unimplemented bits in the Linux code, but the game itself pretty much works from what I understand. It might not build on BSDs though (at least one person, possibly two, tried that with no success).

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Celtic Minstrel, first of all: THANK YOU SO MUCH! I'm truly impressed to see Blades again after so many years.

 

I'm running into a reproducible glitch in The Valley of Dying Things:

Create new party (default party, no changes) and start The Valley of the Dying Things.

Head straight to the school (no Avizo stone or anything)

When I enter the first level of the school and then exit (without touching the gate), the game completely quits on me.

 

Windows 10 (1809) x64

BoE version: BoE-Win-a8e120d.zip    2020-02-10 00:58  downloaded from: http://pentalithia.ca/oboe/?C=M;O=D

 

Save file here: https://drive.google.com/file/d/1cdog2TejtFdwwvdUbbmIN8O9YXsTFx2D/view?usp=sharing

 

Please let me know if I can help test more or provide more detail.

Edited by magelore

Share this post


Link to post
Share on other sites
Posted (edited)

(removed confusing link to an older version of CBoE that Celtic Minstrel had no part in producing)

Edited by Mage Lore

Share this post


Link to post
Share on other sites

I want to note that, while that version you download probably works, it's not the latest version and in particular not a version I had any part in producing. The latest available version is the most recently-posted download in this thread. It has some bugs and glitches, however, so if all you want to do is play the game, the CBoE version you obtained should be sufficient.

Share this post


Link to post
Share on other sites
Posted (edited)

Hello,
unsure, if this can help:
I compiled a 64-bit version of cboe with XCode 10.1 and then tried to launch Blades Of Exile. At least on my MacBook Air (OSX 10.13), two problems were obvious:
- the background of the main windows is random,
- the dialogs and the mini_map are often displayed incorrectly.

I tried to change the code a bit, now the dialogs and the mini_map look good (at least on my computer). So I forked the cboe code ( on https://github.com/fosnola/cboe ) and I commit a patch to fix (or not) this problem; feel free to use it, if you think it's good.

Edit:
- I commit a second patch to avoid destroying the texture before creating the sprites. The display is much better :-)

Edited by osnola

Share this post


Link to post
Share on other sites

Hello,

if anyone is interested, I've compiled an intel 64 version of cboe for OSX, it can be found at  http://pentalithia.ca///oboe/?C=M;O=D BoE-Mac-Apr2020.zip.

 

However, the executables are not signed, so you'll have to convince GateKeeper to run them. On my Mac running OSX 10.13, I had to run in the terminal:

cd ~/Downloads/BoE-Mac-Apr2020
xattr -d com.apple.quarantine BoE\ Character\ Editor.app/
xattr -d com.apple.quarantine BoE\ Scenario\ Editor.app/
xattr -d com.apple.quarantine Blades\ of\ Exile.app/

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/9/2020 at 11:30 AM, golingarf said:

Is this in playable condition yet? I would love to be able to use archery and whatnot.

Under OSX (and on my mac), the biggest problem is the menu, i.e. you can use the file menu (open, save, save as), but if you use other menus and it opens a dialog, the application crashes when this dialog is closed (so you must avoid using the menus :-~). I guess this problem doesn't happen if you use other platforms.

 

Otherwise, there are still a few bugs but most things seem to work (except the mini-map and the journal that don't work properly when you reload a saved game, ...). 

 

Currently, I'm playing the first scenario: The Valley of Dying Things, basically, I have seen few problems:
- some out-of-bounds array readings,

- I do not get some reward when I return some quest, 

the only big problem I've seen is when I leave Magic School: there remains a nasty bug which can crash the game :-~

 

So I guess if you make frequent backups, everything can be fine (or not).

 

Edit:

I just finished The Valley of Dying Things scenario on OsX.

 

If anyone is interested, I can rebuild new executables for OsX (Intel 64), which solve the following problems:

  •  the mini-map is working again,
  •  the journal notes work again (but if you want to access them, you must first save your game, see the menu problem below),
  •  coming out of school of Magery doesn't crash the game anymore,
  •  some memory problems are also corrected.

 

But it will not fix:

  • the executables still won't be signed,
  • the menus (except Open/Save/Save As) continue to crash the game if a dialog is displayed when you close it, so you must save your game before using them,
  • no reward is given for the quest,
  • the spell Dispell Fields isn't working properly or I don't know how to cast it,
  • there are still some small display problems, the most spectacular is when using the Opening Stone which works well, but the display is very weird...
Edited by osnola
update

Share this post


Link to post
Share on other sites

I tried playing Nightfall, and it definitely doesn't work as intended. Special encounters are routinely treated as already having been triggered even though they haven't, the game treated me as having an item I didn't, etc.

Share this post


Link to post
Share on other sites

The game is "playable" but there seems to be some buffer overrun issues (or something) that prevent quests and events from working correctly in some cases. I'm not sure if these issues can be fixed with the help of asan. It could even be something like the SDF coordinates not being initialized somewhere, so that random SDFs are set to random values or something.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...