Jump to content
Sign in to follow this  
FrenchFries

Geneforge 4 display problem

Recommended Posts

Thought I'd fire up G4 and sample it while still playing G3. The Geneforge games I have are the steam versions. Running on Windows 10.

 

G4 starts up displaying everything off center. It's like it's only showing the upper left part of the screen with the main menu down around the bottom right. The mouse behaves weirdly, too. Move the mouse to the bottom right and it shoots down there like lightning. Move the mouse to the upper left and it struggles to get there. 

 

Tried running the game in various compatibility modes with no luck. Even tried setting windows to 1024x768 and it still does the off center thing in the exact same way. 

 

Share this post


Link to post
Share on other sites

Let me just add that I normally have windows at 1920x1080 resolution, but like I said above G4 did the same thing even with windows set to 1024x768. 

 

Also, only G4 has this problem. No other Geneforge game does this.

Share this post


Link to post
Share on other sites

Could you upload some images to Imgur and link them here so we can see exactly what the problem is?

Share this post


Link to post
Share on other sites

Ouch... Steam version works for me. Well, used to work in my 1366 x 768 computer. Are you sure you set the settings correct? Since GF games are small, would you mind unistaling and reinstalling? 

 

GF4 is: 
- IMO the best of the four games
- A real MUST to play game since it's the only time you start with the good guys: The rebels!!!! 

 

LONG LIVE THE REBELLION!!!!! 

Share this post


Link to post
Share on other sites

Which settings are you referring to? I've already tried uninstall and re-install. It makes no difference. 

 

Yeah. I wish I could play it. 

Share this post


Link to post
Share on other sites

If you are still have trouble with this, there is a program called dxwnd on sourceforge that allows you to play the game in basically windowed mode

Edited by Halt

Share this post


Link to post
Share on other sites
5 hours ago, Halt said:

If you are still have trouble with this, there is a program called dxwnd on sourceforge that allows you to play the game in basically windowed mode

 

Well, that kind of fixed it. It's now in a small window on my screen, but at least I can see the whole thing. I'll see if I can increase the window size. 

 

However, the mouse is still wacko and barely even responds. Completely unplayable with mouse like that. Mouse wants to hug the bottom right corner of the screen and struggles to move out of that bottom right corner. 

Share this post


Link to post
Share on other sites
13 hours ago, FrenchFries said:

Which settings are you referring to? I've already tried uninstall and re-install. It makes no difference. 

Not surprising. Uninstall does not get rid of the G4 folder in 'my documents' that contains the Geneforge4Settings.dat .Try deleting that ? The game will create a new one on the next start.

Share this post


Link to post
Share on other sites

Found it. Odd. All other Geneforge games save their info under My Documents/Spiderweb Software. Geneforge 4 saves it's own folder outside the Spiderweb folder. I deleted Geneforge4Settings.dat. It made no difference. The mouse still acts wacko. 

 

It's like G4 ignores windows hardware mouse inputs and instead tries to read and create it's own input settings for the mouse and gets it all wrong. The way the cursor pulls and yanks around it reminds me of playing 90s flight games with an uncalibrated joystick.

 

Let me add that I've even tried two difference mice and it's still janky.

Edited by FrenchFries

Share this post


Link to post
Share on other sites

Aww. Well it was worth a try. And yeah, it's not your physical mouse.

 

Other things you can try with low probability of success:

 

http://spiderwebforums.ipbhost.com/topic/17549-avernum-4-mouse-hitching-problem/?tab=comments#comment-232161

 

Try the demo right here from the site, also try the gog installer.

 

If your cpu has integrated graphics switch to that.

 

Aspect ratio settings from display driver and monitor.

 

 

 

 

Share this post


Link to post
Share on other sites

Got it. It works.

 

The solution was simple. The modern dxwnd comes with scripts already set up for the steam Geneforge games. All I had to do was open dxwnd, then go file > import and look for the Geneforge 4 (steam) script in dxwnd's own directory. Someone already went through all the hassle (thank you whoever you are).

 

All I had to do then was right click Geneforge 4 (steam) script, select modify. in "main" just set the window size to what you want and to start the game in center of your screen. 

 

G4 now works, it looks good in a 1600x900 window, the mouse responds fine. We're off. That's the end of that hoo hah. 

Share this post


Link to post
Share on other sites

Awesome!  What a happy ending.

 

I'm moving this to Tech Support so the solution will be easier for other people who are having problems to find.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×