Jump to content
Sign in to follow this  
coderluke

Junk Bag Full Bug

Recommended Posts

Ran into what I think is a weird bug with the junk bag after reaching Angel's Rest. I went to put items into the junk bag and got a notification saying it was full. When I open the junk bag it shows all daggers with a mouseover title of unused. Any suggestions on how I can reset my junk bag since its unusable at this point?

 

Image here: https://i.imgur.com/NYrkx5f.png

Share this post


Link to post
Share on other sites

You could sell the contents, but you would probably better off going back to an earlier save before the junk bag error occurred.

 

This bug has been seen in other games.

Share this post


Link to post
Share on other sites

That's a bummer. I tried selling all in junk bag at a merchant but they didn't clear out. I ended up putting about a couple 'pages' worth in a random dresser to make some room.

Share this post


Link to post
Share on other sites

This happened to me in Escape from the Pit a couple times, and once in Ruined World. The first time I spent awhile removing the daggers and tossing them on the ground (I don't believe you can sell them). You can get them all out if you're patient enough. I don't remember if that caused any long term repercussions or not. The next time I just reloaded to an earlier save, before the daggers showed up, and everything was fine. Some random glitch seems to trigger that.

Share this post


Link to post
Share on other sites
Posted (edited)
On 2/14/2018 at 3:45 PM, Spidweb said:

I'll look at the code to this and see if there is an issue when the bag is full.

 

This bug has been reported in multiple places and yet when I started playing the game today, I encountered that very same bug: junk bag begins the game as full, with nothing but "unused" daggers that cannot be sold and must be cleared out manually (and that would take hours).

 

I enjoyed the previous two games, and appreciate that you are an independent software company, but we paid money for this game and leaving a bug of this nature unresolved isn't good at all. Please look into the code more thoroughly and fix it or post instructions as to how to resolve it. Thank you.

Edited by Redknight22

Share this post


Link to post
Share on other sites
Posted (edited)

Hello Redknight22,

 

This is a nasty bug I'm afraid, and I'm sorry that it's one you've been experiencing.

 

Unfortunately, this particular bug is a really difficult one to tie down. I can assure you that a lot of time has been spent trying to track down its source and to come up with a fix, both by Jeff, the main force behind these games, but also by his testing team and the wider community. Jeff is really passionate about making sure that his games are as bug-free as possible, so this is an issue that will not have been treated lightly.

The reason why it's so hard to pin down is because it happens so rarely, and so unpredictably. To my knowledge, no-one has yet been able to find a way to make the bug happen repeatedly. Repeating the same set of actions that caused the bug the first time won't cause it to happen again. This makes it really hard to figure out the cause, since even getting the bug to happen in the first place is difficult, let alone in a controlled manner. Without being able to easily trigger the bug, finding out the root cause of the issue is very difficult indeed.

 

Of course, this is of little help if you're experiencing the bug yourself.

 

At the moment, the best course of action, I'm afraid, is to reload to a point before the bug occurred. It might be worth checking your Autosave and Quicksave slots – it's possible you have a save close to where you were that is not yet affected by the bug.

 

Since you've experienced this bug yourself, it's possible that you might be able to shed some light on the issue. As you've played the previous two games with no problems, was there anything unusual about your playthrough of Ruined World? Did you perhaps use a very different party, or play on a different computer, or make more use of the keyboard/mouse? Any information that could give a greater insight into the problem is always helpful.

 

Alternatively, are you playing on a Mac? If you are, I might be able to take a look at your save file directly. I've had an idea of a way to potentially solve the problem for a while, but I've never been able to test it.

Edited by Ess-Eschas
Fixing a spelling issue

Share this post


Link to post
Share on other sites

Sniped by Ess-Eschas!  A few additions:

 

1) When you say "begins the game as full", do you mean it's full when you start a new game, or it's full when you load a save?

 

If it's when you start a new game, and it happens every time, it's probably a file corruption issue and "delete and redownload" is in fact likely to solve the problem.  I know we are used to that being an unhelpful non-answer from customer service people, but file corruption is a real thing that really does happen.

 

2) Also, while I understand the frustration behind "we paid money for this" -- that doesn't actually apply with Spiderweb.  They have a no-questions-asked 100% refund policy that they really do honor (http://spiderwebsoftware.com/come_aboard.html).  If this bug really makes it impossible for you to enjoy the game, I mean, that's what that policy is there for.  Nobody likes bugs, the developers least of all; but with this friendly company, your money is not beholden to them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...