Jump to content
Bearfax

Blades of Avernum unregistered? (GOG version)

Recommended Posts

So I recently bought the Avernum saga on GOG, and while 1 and 3 took a little while to apply the correct Wine version (since GOG's were inaccurate), 2, 4, 5 and 6 worked just fine from the beginning. However, Blades has a very... unusual issue. While it boots up just fine, it's apparently an unregistered copy, effectively making it no better than the demo. I reinstalled it, didn't fix it: though I did notice that the "Welcome!" message didn't pop up again, making me think this might be fixable by removing the save data (if it's not stored in the game itself). Either way, I'd appreciate any input on how this could be fixed. Thanks in advance.

 

EDIT: Also, I'm on a Mac. That probably also affects some things.

Edited by Bearfax62
Forgot to mention which platform I'm playing on.

Share this post


Link to post
Share on other sites

GOG sometimes modifies their versions of games to run better on modern computers, so you might end up having to contact GOG's own support for this one.

Share this post


Link to post
Share on other sites
1 hour ago, Lilith said:

GOG sometimes modifies their versions of games to run better on modern computers, so you might end up having to contact GOG's own support for this one.

Alright, I sent them a report. Hopefully they can find a workaround.

Share this post


Link to post
Share on other sites

They responded! I had to install the app again by a different installer in the BoA application. Strange workaround, but it works, and I'm a happy man.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×