Jump to content
Sign in to follow this  
Kelandon

Ascript/Alint

Recommended Posts

I upgraded to OS 10.11 a few days ago and found, to my surprise, that now Ascript hangs when I tell it to "Check with Alint." I also can't seem to install the command-line version of Alint anymore (or do anything else to get Alint to work).

 

I couldn't swear that it has to do with the OS update, but I can't think of anything else that would have broken this.

 

Does anyone have any suggestions?

Share this post


Link to post
Share on other sites

Windows has a Compatibility Mode that enables a new PC to run programs made with much older versions of Windows. I know nothing about using a Mac, never done it in my life.

Windows has dropped a few commands from the Command Prompt over the years. This might be the same story with Alint.

 

It is not often that I hear of this sort of problem from a Mac user!

Share this post


Link to post
Share on other sites

This must be fixed immediately. Kelandon needs every bit of convenience so he can finish the slithzerikai story!

 

I've never played the slithzerikai story but if it's as good as everyone says it is, I'd like to see the whole thing. :p

Share this post


Link to post
Share on other sites

A link to Ascript might be handy, I can't find one.

Problem seems to be in Alint.

Ask yourself what command-line functions might you be using in Alint, see if they are all still there.

Mac users will need to see what versions of OS will run Mac Alint.

Share this post


Link to post
Share on other sites

Unfortunately, I probably can't help you with this since I don't have access to OSX 10.11. You could try building it from the source (that might even be enough just on its own). If you figure out a fix, I'll accept a patch or pull request.

Share this post


Link to post
Share on other sites

Here's what seems to have happened: http://stackoverflow.com/questions/32590053/copying-file-under-root-got-failed-in-os-x-el-capitan-10-11

 

I disabled System Integrity Protection and installed Alint. I then typed the following:

 

alint homeland.txt

 

I got the following message:

 

-bash: /usr/bin/alint: Bad CPU type in executable

 

I Googled this and am now trying to fix it.

 

EDIT: Then I downloaded the most recent version of Alint, reinstalled, and it appears to work! Ascript still hangs, but I can use command-line Alint just fine.

 

EDIT 2: So, long story short, it appears that the problem is that OS 10.11 protects certain system directories from being written, even with root access. Alint by default installs into what has become, over time, the wrong directory. Someone who knows more about this than I do probably could fix it easily. I don't know what's wrong with Ascript, but I assume it's something related.

Share this post


Link to post
Share on other sites

No, it's not really like that, Ishad. The proper place to install applications on a Mac is "/Applications" for GUI programs or "/usr/local/bin" for command-line programs, but you can also put them anywhere in your user folder if you want (and that's true on Windows too). The Windows equivalent of installing it in "/usr/bin" would be to put it in "C:\Windows\", I think.

 

Regarding the Ascript hang, my guess would be that it can't find the alint executable where it expects to find it. Does it have a preferences option to specify where alint is installed?

Share this post


Link to post
Share on other sites

Regarding the Ascript hang, my guess would be that it can't find the alint executable where it expects to find it. Does it have a preferences option to specify where alint is installed?

It does not.

 

Also, maybe it can't "find" the Alint executable where it expects, but if so, I assume that must have something to do with whether the program can actually access Alint's location, because after I disabled System Integrity Protection, I installed Alint in the usual place. So Alint is where it normally is now.

 

Finally, on a hunch based on what you said, I opened up Alint's install.sh and changed the two references to "/usr/bin" to "/usr/local/bin" instead, ran the program per the usual command, and didn't get any error messages in Terminal. So I think that's all that needs to be changed in the command-line version. If I can remember to do it, I should throw the updated version on my site.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×