Jump to content
Sign in to follow this  
leshpar

Windows 10 slowdown A4

Recommended Posts

I recently upgraded to Windows 10 and am in the middle of an Avernum 4 playthrough. I have 2 computers, my laptop and desktop. Both are relatively high end and can play pretty much any AAA game out there. With windows 7 I was having a bit of lag whenever I'd hold Tab down (to show names and stuff), but otherwise the game played smoothly and rather fast. Upon upgrading to windows 10 it runs so slowly that it feels like I'm trying to play the game on a 486 or something (and honestly it might run better on that processor). Its so slow that it takes about 10 seconds from the time I press esc till the menu pops up. Everything works, but its so slow that it has become unplayable. Combat takes about 5 to 7 times longer than it should, as well as moving around, or even trying to save the game. The mouse cursor also suffers from severe cursor lag. This is happening on both of my computers, hense why I think this is related to windows 10. If anyone has a fix please let me know.

 

My desktop stats are as follows:

3.9 GHZ AMD FX 6350 6 core processor

12 GB of system ram PC3 10660

2 GB GDDR5 Geforce 760 GTX

 

My laptop stats are as follows:

2.0 GHZ Intel core i7 dual core

8 GB of system ram PC3 12800

2 GB GDDR3 Geforce 840M

 

I really want to finish playing the Avernum games. Please fix the slowdown issues Spiderweb! This is for Avernum 4 version 1.0.1 from GoG.com.

Share this post


Link to post
Share on other sites

open up the game folder and there will be two application files.

In A2CS they are Avernum 2 and Avernum 2 DirectX. I'm assuming that in the Avernum 4 folder it would be Avernum 4 and Avernum 4 DirectX.

select the DirectX application.

Share this post


Link to post
Share on other sites

I don't think we're talking about the same version of the game here. Keep in mind A4, 5, and 6 have not been remade since the mid 2000s (which technically was the first time they were made at all I think. Avernum 1,2,3 were originally Exile 1,2,3 in the 90s, but no 4,5,6 existed till the first remake.).

 

The picture I linked to is what is in my A4 folder.

http://i.imgur.com/d8f0hNK.jpg

Share this post


Link to post
Share on other sites

I took some time to try a fresh install and even started a new game and still get the same slowdown issues. I also installed Avernum 5 and tried that. Avernum 5 works perfectly. So I guess worst case scenario I can skip A4 for now, but I'd much rather play the games in order if someone can figure something out for me. Thanks to everyone who reads this. (I've already beaten and loved Avernum 1,2, and 3.)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...