Jump to content
Sign in to follow this  
ahninjascantrememberpasswords

Geneforge 1-3 extremely sluggish (XP 32 bit, Steam versions)

Recommended Posts

I've run the stand alone versions of Geneforge 1 and 2 on XP just fine in the past. When the entire series came to Steam, I decided to get the whole set. However, these versions of the games run at a less than satisfactory pace, with Geneforge 3 being especially slow. Moving the mouse around is jumpy in that "system playing catch up" sort of way, and bringing up the menu takes around 20 seconds, and basically hangs my system until it appears. I don't have access to my registered stand alone copies of 1 and 2 anymore, so that's a bust. Strangely, the title screens function just fine, it's only when I get in to the game proper that the problems appear.

 

4 and 5, on the other hand, run just fine, but I'd like to play the games in order.

Share this post


Link to post
Share on other sites

The search function here is near useless even if you know the exact topic name.

 

Welcome to Spiderweb Software. Please leave any remaining sanity at the door. Then you can find it when you finish looking for something here. :)

Share this post


Link to post
Share on other sites

This issue probably deserves a sticky, I had difficulty finding the post and I knew what I was looking for.

Share this post


Link to post
Share on other sites

This issue probably deserves a sticky, I had difficulty finding the post and I knew what I was looking for.

Done.

Share this post


Link to post
Share on other sites

I followed the instructions and while Geneforge 1 runs smooth the most time, there are some scenes (like in the first city, near the guards) where i experienced some lag (scrolling with mouse or arrow keys). I am on 64 bit Windows 10, with an Intel HD 3000.

Share this post


Link to post
Share on other sites

Sometimes the game slows down when it has lots of moving NPCs and creations in the zone. Jeff admits he isn't the best programmer and his code isn't the most efficient way to use the CPU for heavy graphics usage. This isn't a consistent problem and you sometimes see it other games for autosave or combat with a large number of monsters.

Share this post


Link to post
Share on other sites

Ok, then i know that this is a normal issue and not a problem with my system. Thanks!

But i must admit, that "heavy graphics usage" made me smile a bit! Thanks for that, too. :)

Share this post


Link to post
Share on other sites

I brought a friend of mine to the fold, told him to get the demos (they're enough to get one hooked) and he tells me he can't run them because of the screen resolution.

Share this post


Link to post
Share on other sites

...but it's possible to change the screen resolution. In fact, a pop-up from the game prompts you to change resolution when you start. Does your friend not get that pop-up? Or not have the ability to change screen resolution at all for some reason?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×