Jump to content
Altair

Geneforge 5 Lags(windows user)

Recommended Posts

Do I need a high end PC to run this game? Are you sure you put the right sys req ? Because this game lags like...you name it.

 

It took me 5 min to start a new game i couldn't even chose a character. On Fullscreen setting i had to restart the computer because the game won't quit...

Share this post


Link to post
Share on other sites

What programs did you have open? Did you open the Task Manager to find out how what the CPU Usage was?

 

How much memory do you have on your computer? What version of Windows are you running?

 

It works fine on my computer, I have a GB of memory and I wasn't running any other programs when I played the game.

Share this post


Link to post
Share on other sites

I have 2 GB of ram and 10 GB of free HDD memory, Intel Celeron 2.28Ghz, Windows SP3 which should be more than enough. Only 29, mostly system processes running in the background, no antivirus or anything like that.

 

Defrag-ing the hard didn't improve things at all.

 

The problem might be my onboard video card(S3 Pro Savage) but i doubt it since i can run games with graphics way better than Geneforge...

Share this post


Link to post
Share on other sites

I have an Intel Celeron processor as well, so I don't think that's the problem.

 

I don't know about your onboard video card, but have you checked to see whether the driver is up-to-date?

 

Also check if you have the latest version of DirectX.

 

If all else fails, un-install and re-install the game and run it again.

 

Maybe Windows Update was running in the background? I know that slows my computer down sometimes. Also, if your computer hasn't been restarted for awhile, try that as well, it may seem dumb but it could help. My computer gets a little slow when it hasn't been restarted for awhile.

 

Sorry if I can't offer any more direct advice, maybe you should try searching google if none of my suggestions work.

Share this post


Link to post
Share on other sites

Same here.

 

Horrible, abysmal performance on Acer Aspire 3690 laptop with 1.6 GHz Celeron processor and 1.5 GB of memory, onboard video card. I'm running Windows XP SP2.

 

The mouse pointer barely moves in the menu screens, and mouse clicks don't register over the buttons. In the game screen, the gameplay is jerky even on the lowest resolution and with the background effects turned off.

 

Also, I use extended desktop, because I much prefer my external LCD monitor to the laptop monitor. When on single desktop, the gameplay performance is a little better (though still not acceptable, with low resolutions), but menu screens performance is still way off.

Share this post


Link to post
Share on other sites

The Mac version is OpenGL, but graphics card problems are the most likely cause of the lag. Some graphics systems don't work well with OpenGL and it should have turned up in beta testing.

Share this post


Link to post
Share on other sites

All I can say is follow the instructions at the top of the tech support forum. They usually help.

 

1. Uninstall the game, redownload, and reinstall. Don't skip uninstalling!

 

2. Download the newest versions of your video card drivers and install them. Do this even if you think you have the newest version.

 

3. Run the game, go into Settings and set Graphics Extras to "Don't Draw."

 

4. If you don't have a dedicated graphics card (for example, if you have an Intel chip with a GMA processor), the game will always be a little pokey. Step 3 should help a lot.

 

If this doesn't work, I'm not sure what the issue is. The game was tested on dozens of systems, and the only time speed issues showed up was on Intel GMA graphics processors. Alas, Windows systems can fall prey to a wide variety of unpredictable issues with games. Hopefully the steps above will help.

 

- Jeff Vogel

Share this post


Link to post
Share on other sites
Originally Posted By: Spidweb
The game was tested on dozens of systems, and the only time speed issues showed up was on Intel GMA graphics processors.

- Jeff Vogel



My Aspire 3690 has Intel GMA 950 GPU frown

I believe the drivers are up to date, since I have the same version installed as the one available on Acer's website. Also, the system is a few years old and it's unlikely that they update the drivers every month.

Any idea whether the game will ever work with GMA graphics cards?

Share this post


Link to post
Share on other sites

I have the same graphics card on my Mac, and I've ironically run into the same issue with other games, though not any by Spiderweb. Oh well. frown

Share this post


Link to post
Share on other sites

The GMA 950 is terrible even by the standards of onboard graphics. The GMA 965 is a big improvement... but that doesn't really help you much.

Share this post


Link to post
Share on other sites

I had the same issues - really bad lag in the menu, and the game was unplayable once I got into a fight. The common thread with your problem seems to be that I was also trying to run the game on a system with onboard graphics. Here's how I made the game playable:

 

1. Updated my drivers

 

2. (and most importantly) my card has a graphics properties tab where I can change the default OpenGL settings. I played around with it, and found some settings which decreased visual quality slightly (disabling triple buffering, anisotropic filtering, selecting 16-bit frame buffers, and just generally reducing texture detail) and the game performance improved dramatically.

 

So it seems like there might be a problem with onboard video cards and the OpenGL processes the game uses. Unfortunately there doesn't appear to be an easy way to run the game in software - so I'd suggest if you're having performance issues, try to adjust the OpenGL settings directly through your video card.

Share this post


Link to post
Share on other sites

Same problem. I've updated my drivers - no go. I can't see lots of the text in the game, for example the lines at the bottom right of the title screen (which on the others say Spiderweb and Registered copy), and when I open settings, I can't read any of that either, so I can't tell which set of blocks (that's how they appear) is the one to change the graphics settings as Jeff suggested.

Any thoughts? I've been waiting patiently (okay not really patiently) to play the latest game, and now I can't! frown

Share this post


Link to post
Share on other sites
Originally Posted By: Spidweb
All I can say is follow the instructions at the top of the tech support forum. They usually help.

1. Uninstall the game, redownload, and reinstall. Don't skip uninstalling!
2. Download the newest versions of your video card drivers and install them. Do this even if you think you have the newest version.
3. Run the game, go into Settings and set Graphics Extras to "Don't Draw."
4. If you don't have a dedicated graphics card (for example, if you have an Intel chip with a GMA processor), the game will always be a little pokey. Step 3 should help a lot.

If this doesn't work, I'm not sure what the issue is. The game was tested on dozens of systems, and the only time speed issues showed up was on Intel GMA graphics processors. Alas, Windows systems can fall prey to a wide variety of unpredictable issues with games. Hopefully the steps above will help.

- Jeff Vogel

All done no improvement. frown

Share this post


Link to post
Share on other sites

When you post about problems, it is really, really helpful to give me some information about your system. Operating system, amount of RAM, sort of video card/chip, and so on. Based on the number of orders coming in and the experience during beta testing, problems with the game are probably quite uncommon, but I'd still like to help as many of the afflicted as I can.

 

Just so you know, Geneforge 5 uses OpenGL, but only the simplest and most basic of functions. Absolutely nothing exotic.

 

Deeda: If it's not even drawing the characters, something is really messed on your system. Some system specs might help.

 

SecretIdent123: The problem here is that the GMA is not a graphics card. It's a section of the main chip that handles graphics. It's a low end processor, really unsuited for gaming, and the 950 is at the low end of the low end.

 

Altair: I'm not familiar with the S3 ProSavage. I'd never heard of it before now. If they made it with no OpenGL support or if its OpenGl support broke on your machine, that would cause the problem, but I'm not sure what I can do.

 

Ahhhh ... Going to have a lot of fun over the next few months, I think.

 

- Jeff Vogel

Share this post


Link to post
Share on other sites
Originally Posted By: Spidweb

Altair: I'm not familiar with the S3 ProSavage. I'd never heard of it before now. If they made it with no OpenGL support or if its OpenGl support broke on your machine, that would cause the problem, but I'm not sure what I can do.

- Jeff Vogel

I've searched a bit and it seems S3 ProSavage doesn't have OpenGl support. (I'm quite perplexed; i can run for example counter-strike using opengl as render although it looks ugly)

I already have the lastest driver which is the last one; drivers are no longer updated for this card.

So is there any hope for me? frown

Share this post


Link to post
Share on other sites

Altair -- there were a number of different ProSavage chipsets made under the S3 name. Can you find the model number? For example, the ProSavage PM133, or the ProSavage KM266.

 

From what I can tell, Wikipedia suggests that all the ProSavage models recycled elements of chip models first produced in 1999, but I'm not clear if the article covers all ProSavage models ever made. Presumably, if your graphics hardware is 10 years old, that is the problem...

Share this post


Link to post
Share on other sites
Originally Posted By: Muumuurator Deniminator
Altair -- there were a number of different ProSavage chipsets made under the S3 name. Can you find the model number? For example, the ProSavage PM133, or the ProSavage KM266.

From what I can tell, Wikipedia suggests that all the ProSavage models recycled elements of chip models first produced in 1999, but I'm not clear if the article covers all ProSavage models ever made. Presumably, if your graphics hardware is 10 years old, that is the problem...


Where can i see that number?

I dunno if this helps but here is the dxdiag display tab:
http://img4.imageshack.us/img4/257/dxscr.jpg

Share this post


Link to post
Share on other sites

From the manufacturer's own forums:

 

"ProsavageDDR is really a legacy product. If you wanna play up-to-date popular games, I badly recommend you buying a new graphics card!!"

 

You do appear to have the latest version of the drivers. But the drivers were last updated in 2004. The chip technology came out in 1999. I think you've gone as far as you can with it!

Share this post


Link to post
Share on other sites

Two things that helped on my computer (I've got GMA too). Check it out and post if it helped:

 

1. Go into your graphics properties, there's something like "3W settings", at least in my language version. There're OpenGL settings there, set the "Driver Memory Footprint" to "high"

 

2. Set the color depth in G5 settings to the color depth of your system, if you use 32 bit set it to "Always use 32bit".

 

Hope it helps, it didn't kill the lag completely but now it lags only for a second or so when the effects kick in or when the dialogue starts, probably when buffering.

 

Don't turn off the effects, it doesn't increase the performance.

Share this post


Link to post
Share on other sites

I have the same problem, I have updated my drivers and I checked what my graphic card is:

Mobile Intel® 965 Express Chipset Family

 

I also downloaded the latest version of DirectX and have uninstalled and re-installed the game multiple times.

 

I cant change the graphics settings in the game because the game lags out and my mouse clicks dont register right after i click settings; it never fails to happen that way.

 

If theres a way around it could anyone please let me know?

I would really really really love to get a chance to play this one smile

Share this post


Link to post
Share on other sites
Originally Posted By: kkarski
Two things that helped on my computer (I've got GMA too). Check it out and post if it helped:

1. Go into your graphics properties, there's something like "3W settings", at least in my language version. There're OpenGL settings there, set the "Driver Memory Footprint" to "high"

2. Set the color depth in G5 settings to the color depth of your system, if you use 32 bit set it to "Always use 32bit".

Don't turn off the effects, it doesn't increase the performance.


Thank you very much for this feedback. I will put some of this information on the support page. One question - How did you reach Graphics Properties? Did you right click on the desktop, or is it a control panel?

Also, turning off effects DEFINITELY helps some people. For one thing, it drastically reduces the memory use of the game, which really helps on some cards.

- Jeff Vogel

Share this post


Link to post
Share on other sites
Originally Posted By: Dune2349
I have the same problem, I have updated my drivers and I checked what my graphic card is:
Mobile Intel® 965 Express Chipset Family


We had several testers with Intel GMA chips. Most of the time, they can be made to work. Sometimes, they never work at all. They're inexpensive low-end hardware that really weren't made for gaming. Look at the setting suggestions from other articles, and please let me know if one of them works for you.

- Jeff Vogel

Share this post


Link to post
Share on other sites
Originally Posted By: Spidweb


Thank you very much for this feedback. I will put some of this information on the support page. One question - How did you reach Graphics Properties? Did you right click on the desktop, or is it a control panel?

- Jeff Vogel

Thats a good question. laugh

It seems this guy: http://ubuntuforums.org/showthread.php?t=104355 managed to enable openGl rendering for my card. But the links are dead and i don't know what to search for.

Share this post


Link to post
Share on other sites

Ok, I think I managed to solve the lagginess problem on my GMA 950 based laptop. I did the following:

 

1) Updated the drivers to the latest version available on the Intel website. That by itself didn't fix the problem, so see next step.

 

2) In Graphics Properties, 3D Settings menu, I set "Force S3TC Texture compression" to On, and "Force FXT1 Texture compression" to Off. That completely got rid of lagginess at the cost of minor reduction in graphics quality.

 

EDIT: setting both of these to On really degraded the graphics and made the text look all washed out.

Share this post


Link to post
Share on other sites

Progress: outside the store room at the start of the game.

 

Symptoms: slowing down when characters other than the PC move; keypress and mouseclick have a chance of having no effect in inventory screen and during conversations.

 

OS: MS Windows XP Pro sp3 (5.1, Build 2600)

Processor: Intel Pentium 4 1.6GHz

RAM: 512 MB

Monitor: IBM9521

Language: English (Regional Setting: English)

System Model: 684434J

BIOS: PhoenixBIOS 4.0 Release 6.0 for IBM NetVista

DirectX Version: DirectX 9.0c (4.09.0000.0904)

 

Graphic Adapter: NVIDIA VAnta/Vanta LT

DAC Type: Integrated RAMDAC

Display Memory Size: 16 MB

Bios Information: Version 3.05.00.10.57

Vanta Timing Mode: Auto-Detect

Hardware Acceleration: Full (Geneforge 5 cannot display images when hardware acceleration is nil)

Main Driver: nv4_disp.dll

Version: 6.14.0010.4523 (English)

Date: 7/28/2003 14:19:00

WHQL Logo'd: Yes

Mini VDD: nv4_mini.sys

VDD: n/a

DDI Version: 7

 

Vanta OpenGL settings:

Support for enhanced CPU instruction sets: Enabled

(Disabling this and Geneforge 5 displays rectangles in place of characters)

Unified back/depth buffer: Not Used

Quadbuffered stereo API: Disabled

Overlays: Disabled

Texture memory: Not Maximized.

Conformant OpenGL texture clamp behaviour: Disabled

Default Color Depth: Always use 16 bpp

Buffer-Flipping Mode: Auto-select

Vertical Sync: Always off

Anisotropic Filtering: Disabled

 

Vanta Direct3D settings:

Fog table emulation: Disabled

Texture Anisotropic Setting: 2x (Lag increases when it is at 0x)

Mipmap Detail Level: Best Performance

PCI Texture Memory Size: Use up to 63 MB of system memory for textures in PCI mode

Refresh rate: controlled by applications

 

Sound device:

Name: Intel Integrated Audio

Device ID: PCI\VEN_8086DEV_2445SUBSYS_02451014REV_1;

Manufacturer ID: 1

Product ID: 100

Type: WDM

Driver Name: ac97intc.sys

Version: 5.10.0000.3523 (English)

Date: 8/17/1002 20:20:04

WHQL Logo'd: Yes

Provider: Microsoft

Hardware Sound Acceleration Level: Full

(All tests passed)

 

dxdiag settings:

DirectDraw Acceleration: Enabled

Direct3D Acceleration: Enabled

AGP Texture Acceleration: Enabled

(All tests passed)

 

Need any more info? wink

Share this post


Link to post
Share on other sites

@Schneider: Slowing down when characters move is extremely odd. It takes as much graphical power to draw a moving character as an immobile one.

 

It's possible that your video card is running out of memory, and so the game has to store images in regular RAM. Or maybe one of the walking graphics in corrupted.

 

Uninstall. Redownload. Reinstall. Then set Graphics Extras to Don't Draw. One of these might help. It will definitely lower the memory usage.

 

- Jeff Vogel

Share this post


Link to post
Share on other sites

It does not help.

 

I don't mind a little lag but what makes the game unplayable is the fact that mouse and keyboard events become Poisson when the dialog screen is open. I have no idea how many times I have to click on the dialog option before it takes effect and I dare not quadruple-click it lest it skips the next one.

Share this post


Link to post
Share on other sites

I have encountered the same kind of problem as the user above. The game slows considerably whenever a dialogue box or the character's inventory or ability screen is opened.

Share this post


Link to post
Share on other sites

I really don't understand why this game doesn't work and im starting to believe we are dealing with a little problem called: bad optimization. The system requirements are ridiculous and every user that posted here seems to meet them.

 

System Requirements:

 

* PC Running Windows 2000 or later or Macintosh running System 10.3.9 or later. OK

* Minimum 800 MhZ processor. OK

* 50 MB free RAM. OK

* 200 MB hard disk space. OK

* 1024x768 screen resolution with 16 bit color (Windows) or 32 bit color (Macintosh). OK

 

Ok we have 10 years old video cards but video cards are not even mentioned in the req.

 

frown

Share this post


Link to post
Share on other sites

I'm having that problem too but that fixed. I'm using my laptop which can play G5 if you using 16-bit , if you are using 32-bit it will be very slow.

Share this post


Link to post
Share on other sites

Well, is it that the mentioned video cards specifications are too low so they do not fit geneforge's requirements, or that this specific onboard graphcis card has a problem with the game.

Share this post


Link to post
Share on other sites

We are working on new, updated system requirements now.

 

I'll also be playing on Monday with adding options for having the game run at different color settings. (Thousands of colors versus millions of colors.) I'll put out a public beta soon to test if it helps.

 

Some other comments:

 

Altair: I'm afraid your problem is solved. A 10 year old video card with no OpenGL support has no chance of running the game. SOrry I can't be of more help.

 

Descending Angel: I can't do anything with posts in this thread without information about your system. For all I know, you have no video hardware at all. :-)

 

Schneider: I did some research on the NVidia Vanta. Like the GMA processor, it was a cheap addition to the processor (not a card) meant for budget machines, and it's quite old. You're probably always going to get poor performance on it.

 

Anyway, watch this space. When I have a new version of Geneforge 5 that supports lower color depths (which might help), I'll post in this thread and the Geneforge 5 thread.

 

- Jeff Vogel

Share this post


Link to post
Share on other sites

I'm clueless. The suggestions I provided earlier didn't fix the problem.

The worst thing is I have no idea what causes the slowdowns. Sometimes the dialogue/inventory window makes everything slow, sometimes not. Sometimes the combat slows down to a crawl when the PC is active, sometimes it goes on normally without a single lag.

 

I turned the background sounds off, and there seems to be some improvement, though I'm not really sure if it's not my imagination.

 

For those of you who insist that GMA is too weak to handle G5 graphics - it isn't laugh Trust me. I think the problem lies in poor handling of the OpenGL architecture via the Intel driver.

 

Another thing that wasn't posted yet and that may be helpful to Jeff - when I open inventory or dialogue starts, there is a brief flash in the background and several strange shapes appear as if, dunno, opening a window would reset the rendering. It is related to the GMA, as there is no such thing on my mac mini with an old Radeon inside.

Share this post


Link to post
Share on other sites

I got this information from the control panel:

Intel® Graphics Media Accelerator Driver for Mobile Report

 

 

Report Date: 02/22/2009

Report Time[hr:mm:ss]: 15:12:21

Driver Version: 6.14.10.4926

Operating System: Windows XP* Professional,

Default Language: English

DirectX* Version: 9.0

Physical Memory: 1013 MB

Minimum Graphics Memory: 8 MB

Maximum Graphics Memory: 256 MB

Graphics Memory in Use: 8 MB

Processor: x86 family 6 Model 15 Stepping 13

Processor Speed: 1994 MHZ

Vendor ID: 8086

Device ID: 2A02

Device Revision: 0C

 

Im a tad confused on how exactly to reach the options for my graphics card (or driver for that matter) could someone tell me how to get there?

Share this post


Link to post
Share on other sites

I love Spiderweb software because they make games for non-gaming computers, where quality of content makes up for lower quality special effects. I run XP on a cheap dell laptop Inspiron 1501 from way back in 2006, though geneforge 4 and avernum 5 played great right to the end, in G5 as soon as I try to choose a character or go to settings, the game crashes. I can see instructions, and other things, but the little registration text in the corner is all blocks.

 

From what I've read so far, I should give up trying to update drivers. I just don't have a gaming card. Maybe with the lower color version?

 

Anyway thanks for the years of games while they lasted.

Share this post


Link to post
Share on other sites

I am working on different speeding-up options for Geneforge 5. Try this. If you are having slow performance, set your display to 16 bit color, and then run the game. Please let me know how much this helps/doesn't help.

 

This should, among other things, reduce the memory the game takes on the graphics card, which really can cure bad performance.

 

I will work on this more this week, but letting me know if the 16 bit thing works would be very useful. be sure to remind/tell me what sort of hardward you are using. My main goal is to improve performance on the GMA processors.

 

- Jeff Vogel

Share this post


Link to post
Share on other sites

Just to throw this out there: I installed and played G5 on my old laptop, running an "Intel 945 Express Chipset", and suffered no lag. Drivers were up to date, but, this "card" appears older than some others in this thread.

 

Is it possible that there are other factors, and not just the graphics hardware, at work?

Share this post


Link to post
Share on other sites

@Jeff Nope x16 resolution doesn't improve things at all.

 

Also i forgot to mention: if i try to quit the game while i'm on fullscreen mode the computer will freeze.

Share this post


Link to post
Share on other sites

Nikki - Thanks. This problem is definitely intermittent. It is a mystery what is going on with the afflicted systems that causes the problem.

 

Altair - Geneforge 5 will not ever run on your system. You have to have hardware that supports OpenGL. I'm afraid that your video card is way way too old and odd.

 

- Jeff Vogel

Share this post


Link to post
Share on other sites
Originally Posted By: Spidweb

Altair - Geneforge 5 will not ever run on your system. You have to have hardware that supports OpenGL. I'm afraid that your video card is way way too old and odd.

- Jeff Vogel

frownfrown So no G5 for me... Thanks anyway.

Share this post


Link to post
Share on other sites
Originally Posted By: Altair

frownfrown So no G5 for me... Thanks anyway.


if your motherboard has agp-slot then you could buy few years old agp graphic card (from ebay for example).

if your motherboard doesn't have agp-slot and has only pci-slots then your options for better card are bit limited (some geforce 6600 or radeon 1x00 or maybe even bit older).

Share this post


Link to post
Share on other sites

Altair, it cost me less than $100 to get a new video card for my machine.

 

I just brought my PC in to a computer store (TigerDirect) and they picked out a good video card that was compatible with my system.

 

They were even supposed to install it, but the store was closing so I installed it myself. It was easy!

 

The lesson is, with a little perseverance and patience, G5 can still be yours to enjoy. smile

Share this post


Link to post
Share on other sites

(This is copied from the other thread.)

 

Some users have had speed difficulties with Geneforge 5: Overthrow for Windows. On some machines without an OpenGL compatible video card, the game can play slowly. Alas, this includes many machines with Intel GMA graphics chips (which are common).

 

Based on feedback from the field, we have released a test beta application which might be able to solve some of these speed problems. If the game plays slowly for you, to get the new version:

 

1. Download the new application file at

 

ftp://ftp.spiderwebsoftware.com/temp/Geneforge5v101test.zip

 

2. Unpack it. Copy it into the Geneforge 5 folder (which should be in Program Files/Spiderweb Software) and run it. (To verify it's running, the version number of the title screen should be v1.0.1test.)

 

3. When the Screen Size dialog box at the beginning of the game comes up, select the Play In Fast Graphics Mode checkbox.

 

4. See how it runs.

 

Please let me know if this helps (or doesn't help). You can post in this thread or write us at spidweb@spiderwebsoftware.com. When you give feedback, it is VERY helpful if you tell us about your system (OS, chip type, video hardware). Without any system information, your feedback probably won't help.

 

You can give us the most helpful information by: Select Run from the Start Menu, run dxdiag, hit the Save All Information button, and E-mail the resulting file to us.

 

I really hope this helps, and thank you for your patience.

 

- Jeff Vogel

Share this post


Link to post
Share on other sites

I get a bit of a lag in G5, but it's only when I start and end the program, when the resolution changes. Is there an option for so resolution doesn't change? My resolution is already set to one that G5 initially requests me to use, so it doesn't need to be changed.

Share this post


Link to post
Share on other sites
Originally Posted By: The Mystic
I get a bit of a lag in G5, but it's only when I start and end the program, when the resolution changes. Is there an option for so resolution doesn't change? My resolution is already set to one that G5 initially requests me to use, so it doesn't need to be changed.


You don't way whether you're using the v1.0.1 test or the v1.0. If you're using v1.0.1, you can keep the resolution from changing by not checking the Fast Graphics box. Then, in Settings, change Graphics Extras to Don't Draw. But you won't get as much of a speed bump when playing.

- Jeff Vogel

Share this post


Link to post
Share on other sites

I tried G5 v1.0.1 (on my cheap dell Inspiron laptop dual 64X processors with no graphics card) and now I don't even see the "screen size" box, it just goes straight to the game. The game still crashes when I choose a character or go to settings. (Only difference: With v1.0 I did see the screen size/resolution box)

 

Thanks for trying to help us stone age computer users.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...