• Announcements

    • Then and Where and Now and There and When

      Logging in   05/10/2017

      If you had an account and can't log in as of 5/9/17, this may be because of a change in logins with new forum software. You can log in using your publicly displayed name (not your username) or your email address and the password you used before.   If you have problems with this, please ask any of the mods or admins. 
Sign in to follow this  
Followers 0
sillu012

Avernum 2: Invalid zone script

8 posts in this topic

Exact error printed: "Error: Tried to run invalid zone script.."

'Lost' 16 minutes of playing as rebooting nor reinstalling the game didn't help. No updates available for drivers. Game is bought on Steam.

Happened when I was inside Giants Fort walking towards Lady Gremlins (Quest: Find Gremlin Women.). Not yet sure if it would occur again if I try going there again later in the game.

Share this post


Link to post
Share on other sites

Oh and, of course by reinstalling I meant "Delete Local Content" in Steam and downloading it again as there's no actual uninstall for Steam games.

Share this post


Link to post
Share on other sites

Huh, haven't seen this before. Especially weird that redownloading didn't fix it. I would email the developer directly at support@spiderwebsoftware.com .

Share this post


Link to post
Share on other sites

It sounds like an individual script for an NPC or monster in the zone had an error due to file corruption. The game has error checking features to help the developer locate problems like that.

Share this post


Link to post
Share on other sites

Oh and, of course by reinstalling I meant "Delete Local Content" in Steam and downloading it again as there's no actual uninstall for Steam games.

 

For future reference, you can often fix a corrupted installation of a Steam game without having to redownload the whole thing if you right-click the game in your Steam library and select Properties > Local Files > Verify Integrity of Game Cache -- although it seems like it might not have helped in your case if even reinstalling from scratch didn't do anything. (I'm not actually 100% clear on what you mean when you say that reinstalling didn't help: what exactly happened after you saw the error message, in terms of what you saw in-game and what actions you took? If you saved after seeing the error message, you should probably consider that save file a writeoff since saving the game while it was in a corrupted state means your save file will likely be corrupted as well.)

 

In general, if you see an error message like that, I'd recommend that you immediately exit the game without saving, open it up again, load your most recent save or autosave and go back to see if the same error happens again when you go to the same location; once in a blue moon a script just might not load correctly even if the file itself is fine. It might also be worth your while to download and run a hard drive monitoring utility like CrystalDiskInfo to make sure your problem isn't a failing drive.

Share this post


Link to post
Share on other sites

Sorry for late notice!

When the problem occured the first time, it also crashed my computer, everything went black and buttons were not functional. Autosave was just moments before the crash, I'm not sure how long :), probably something happened on that same moment.

 

Steam synchronizes savegames into their cloud, so I installed the game on other computer as well to make sure it's nothing to do with drivers etc, but same error. I guess the autosave was corrupted too.

 

Went there again, no problems occured this time. Just had to do some things again, nothing fatal :), just wondered if there were any other ways.. Was able to finish Gremlin Women quest without any further problems. I'll just try to save more often now, sometimes I play hours in a row without saving, and that would have been bad.

 

Thank you all for any help and advice!

Share this post


Link to post
Share on other sites

I had similar thing in Avernum Escape from the pit, got some error in Pyrog's cave and junkbag was full of iron daggers afterwards (nothing else in there) and game also crashed, reloading older save and replaying went normally. Some rare bug in code or quirk.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0