• Announcements

    • That Which Mourns Soundly

      Logging in   05/10/2017

      If you had an account and can't log in as of 5/9/17, this may be because of a change in logins with new forum software. You can log in using your publicly displayed name (not your username) or your email address and the password you used before.   If you have problems with this, please ask any of the mods or admins. 
negatus

How can one remove letterboxing?

9 posts in this topic

I recently picked this up through Steam and was disappointed that the game is floating in a sea of black. I understand the pillar bars to maintain 1:33 to 1:00 aspect ratio of the game, but why am I also getting horizontal bars (letterbox) on the top and bottom of the screen? I sent a note to support and after a week received a very brief note stating the game was coded at 800x600. Well fine, but Geneforge is also coded at that resolution and it isn't letterboxed (only pillar bars to keep the correct aspect ratio).

 

Is there any way to fix this? My monitor isn't large and I would like all the screen real estate I can get.

Share this post


Link to post
Share on other sites

If you run the game at 800x600, you should not have any bars at the top and bottom of your screen unless your graphics drivers are set up to letterbox non-native resolutions. The game has three display options: Run fullscreen at 800x600, run fullscreen in the center of the window at native resolution, or run in a window. I just tested both the Mac and Windows versions on my computer and there is no vertical letterboxing when running the game at 800x600.

Share this post


Link to post
Share on other sites

If you don't like 800x600 you are stuck, that is all.

I don't think you understand my post. I have no problem with 800x600 resolution. I don't like this game being both letterboxed and pillar boxed. The Geneforge games are 800x600, but they are only pillar boxed which maintains the aspect ratio of the display, which is good as it prevents distorted images.

 

Here is a link to a You Tube video that shows what is happening with Nethergate on my PC (again this letterboxing doesn't happen with any of the other Spiderweb games I have). http://www.youtube.com/watch?v=QnobllwDHjg

Share this post


Link to post
Share on other sites

Your computer is not running at 800x600 in that video. There are two separate settings that need to be made to make the game run fullscreen at 800x600. The very first time you launched the game, it gave you this dialog box:

nethchangeres.png

 

If you select "Always Switch Resolution" or "Switch Resolution This Time", it will change your screen resolution to 800x600 while running the game. If you select "Never Switch Resolution" or "Don't Switch This Time", it will keep your current screen resolution and run the game either in a window in the middle of the screen or letterboxes, depending on your settings. If you select "Always Switch Resolution" or "Never Switch Resolution", you will never see this box again. In order to play the game fullscreen without letterboxing, you need to set it to always switch or switch this time. If you had set it to never switch in the past, you can change that by going into the in-game preferences by clicking the floppy disk button in the lower right and clicking the box labeled "Ask at startup whether to change resolution."

nethprefs.png

Share this post


Link to post
Share on other sites

Tyranicus- Just to be clear, that is not actually my video. It's just a vid I found that illustrates how the game looks on my Windows 7 based computer. You mentioned two separate settings..I already Switch the resolution (if I don't, the game is the size of a postcard) to get the results you see from the You Tube video. So what is the second setting that needs to be changed to view full screen? Thanks.

Share this post


Link to post
Share on other sites

Tyranicus- Just to be clear, that is not actually my video. It's just a vid I found that illustrates how the game looks on my Windows 7 based computer. You mentioned two separate settings..I already Switch the resolution (if I don't, the game is the size of a postcard) to get the results you see from the You Tube video. So what is the second setting that needs to be changed to view full screen? Thanks.

The second setting is to make sure the box that says "Play in full screen window is selected. If it still doesn't take up the whole screen, I honestly don't know what to tell you. Both the Mac and Windows versions take up all the vertical space on three computers that I just tested.

Share this post


Link to post
Share on other sites

Thanks for your suggestions Tyranicus, but "Play in full screen window" simply toggles having a black border or seeing the desktop behind the game. It does nothing to change the size of the game display itself. Is your copy on Steam? I just wonder if something was altered in the Steam version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now